iReboot v1.1 "Error communicating with service!"

SuperFreak

New Member
Hi,

I've Vista installed on C:\ and XP on D:\.
I have EasyBCD installed on C:\ - and have iReboot installed both on C:\ and D:\.

First, my question: is it necessary to install iReboot in two copies, into both hard disk or partition? EasyBCD has no problem beeing installed only on Vista and it still can run under XP.

Second, a problem: this seems to be some firewall settings problem. I've got this message when I click to start iReboot:

"Error communicating with service! Cannot establish a connection to the iReboot service. Please ensure it is running, and try again later. Message Details: No connection could be made because the target machine actively refused it."

When I disable my firewall (ESET Smart Security) I can run without any problem.

Please tell me what port should I need to open, to use iReboot with my firewall. Thanks!
 

JustinW

Super Moderator
Staff member
It has to be UAC related... it wouldn't make sense for it to access/retrieve information from the internet as you're trying to reboot so a firewall shouldn't be the issue. iReboot works in conjunction with Vista's bootmgr, so it shouldn't need to be installed in all of the OSes other then Vista if that is the only one in which you want to use to boot straightaway into XP versus re-booting into Vista.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
You need to add iReboot to the exception list of your Firewall. This isn't related to UAC per-say, but rather the workaround that iReboot uses to get past UAC.

Your Firewall is over-aggressively blocking connections from localhost to localhost, and it shouldn't really be doing that. Just add iReboot to the whitelist and you should be good to go.
 

SuperFreak

New Member
Thanks, guys. Adding iReboot to firewall "whitelist" as both direction with TCP&UDP protocol, solved the problem.
 

mqudsi

Mostly Harmless
Staff member
Awesome - glad it's working.
 

littlenasty

New Member
Im having the same problem I havent done anything recently to trigger the problem I tried a reinstall but that doesnt work... I reset my mcafee firewall to defualt and the problems is still buggin me... The program actually opens when windows vista opens then gives me the error and closes... I dont have the same problem in xp... I see the option to add ireboots services in mcafee's firewall, but it wants to know what ports it uses for traffic... Thanks in advance for your help.
 
Last edited:

JustinW

Super Moderator
Staff member
Uninstall and remove iReboot from McAfee's program access list. Re-install. When McAfee asks you what to do click "Allow Access" and hit the OK button.
 
Last edited:

JustinW

Super Moderator
Staff member
You got the UAC-free version? If not, uninstall, remove from McAfee's program list again, and than grab it from the link provided in [post=20716]Mak's post[/post].
 

JustinW

Super Moderator
Staff member
Version 1.1 should be correct. It must be a problem with either another firewall on the machine (Windows firewall if its activated), McAfee, or a bug...
 

littlenasty

New Member
nope i checked windows firewall it is disabled... no other firewalls... i wonder if mcafee will allow it if I remove and reinstall mcafee...
 

JustinW

Super Moderator
Staff member
You might haft to, but first with iReboot installed...

Open Security Center, click "Advanced Menu" if you're viewing the basic menu, click "Configure", click "Internet and Network", click "Advanced" under Firewall Protection, click "Program Permissions". Find iReboot in the list and verify it has "Full Access". If its not there, add it manually with "Add Allowed Program".

If you continue to have problems, you could also try temporarily disabling the firewall during iReboot's installation and see if that helps any instead of resorting to a full re-install of McAfee.
 

littlenasty

New Member
it must be the program....

I have mcafee completly stopped with no trace of it on the computer and im getting the same error... :rage:
 

JustinW

Super Moderator
Staff member
Do you have the .net framework installed? (if you can run EasyBCD than yes...). With iReboot installed, type services.msc into the search box of your start menu. If you see any nst related service in there or one specifcally identified by iReboots name in it, make sure its set to auto-start. If its auto-start delayed change it to auto-start. Reboot and see if you still get the error.

You well need to provide more detail or possibly a screenshot of the error if you've got it so the developer has something to work with for patching a bug (if any) in a future release.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
It uses port 9076.

Check and make sure the iReboot service is running in services.msc
 

compie

New Member
service error in iReboot 1.1

I had the same error message on my Dual boot Vista Business <-> XP professional
Funny, it only started after a while, at first the iReboot 1.1 was functioning OK.
(Maybe due to some Microsoft Windows Auto Update in march 2009 ?)
- I had UAC de-activated the second I had Vista installed !
- I do not have McAfee installed, I use Etrust Inoculate/Windows Defender.
- I have Windows Firewall turned on.


Anyway, opportunistically I tried the older version (vs 1.0) after de-installing vs 1.1.
It works like a charm ! :??
Suggesting it's got nothing to do with the UAC, more likely with Windows Firewall

Maybe SuperFreak should give it al try too !
 

JustinW

Super Moderator
Staff member
The UAC version should be used in Vista though, unless you disable UAC all together, which I wouldn't do unless you're running as a limited user any way once you've got iReboot installed of course.
 
Top