Kubuntu and Vista Dual-Boot

#1
Hello
My system:
Motherboard Asrock 939SLI32-eSAT2, Processor Athlon 64 3700+, Memory 2048 MB DDR, Video card NVIDIA GeForce 7600GS, monitor Ag-Neovo F-419, harddisks 2x 148 GB SATA raid-0, 1x IDE 76 GB, 1x SATA 76GB.

My operating systems:
Vista ultimate C partition raid-0, Windows XP D partition raid-0, Suse 10.2 x64 IDE. On this disk I have a fat partion in front of the linux partitions, Kubuntu 6.10 SATA

My problem:
Until now I used the grub bootloader of Kubuntu To start from the SATA disk in which an entry was madew to start up the vista bootloader from which I could start Vista and XP. But now that EasyBCD is available I would like to start from the raid-0 disks with an entry for the linux partitions.
I made a new boot file in Kubuntu now only containing the linux entries and placed it in the bootsector of Kubuntu as well as the bootsector of Suse 10.2. Here you meet the first problem. The disk numbering is inconsistent. Kubuntu grub says the SATA disk is disk HD0, whereas Suse grub would say the IDE disk is HD0, whereas the other linux installation is always said to be HD2. Apparently the Raid config is always HD1.
Now this problem can be solved by changing the disk numbers in menu.lst.
The real bad problem is encountered in Easy BCD. It puts the grub bootloader invariably on the D partion (win xp) picking up the data from grub on the SATA disk boot partition. Here again confusion about the disk number.
After fiddling around with the disknumbers there was one configuration producing the grub bootloader once.
The next time I start up I only get the word Grub and a blinking cursor on screen.
I did not change the menu.lst on D \NST\ after it worked.
My conclusion is that it could basicly work if it worked once, but what is going wrong all the time?
 

mqudsi

Mostly Harmless
Staff member
#2
You've run into a limitation of EasyBCD 1.6-
EasyBCD 1.61 Beta+ address this issue of adding multiple Linux bootsectors.

Please remove all Linux entries from EasyBCD, then install this _BETA_ build and use it instead:
http://neosmart.net/forums/index.php?gettopic=630&p=3

Cheers!
 
#3
Hello computer guru,
I downloaded and installed EAsyBCD 6.2* ( I had 5.2). There is more information on the partitions in this version while adding the NST bootloader. Still I can't start the linux bootloader from the vistaloader. It now says: EMBRL missing -System Halted.
The confusion regarding disk number is still there, but I made a correction in /NST/menu.lst.
It now reads:
Code:
# NeoSmart NeoGrub Bootloader Configuration File
#
# This NeoGrub menu.lst file should be located at \NST\menu.lst of the boot drive.
# Please see the EasyBCD Documentation for information on how to create/modify entries

title Kubuntu
root (hd0,0)
kernel /boot/vmlinuz-2.7.17-10-generic ro root=/dev/sda1
initrd /boot/initrd.img-2.6.17-10-generic

title Suse 10.2
root (hd2,1)
kernel /boot/vmlinuz-2.6.18.8-0.3-default ro root=/dev/hda2
initrd /boot/initrd.img-2.6.18.8-0.3-default
Maybe I should also reinstate the suse grub bootloader on the IDE disk to avoid disk number rotation.

what is still wrong?
 
#4
hokay,

It would be awesome if the Bootloader configuration file had a GUI.
I have tried every possible combination of hard drives and bootloader values with no success.

I really just want to boot into XP with the Vista partition hidden, and boot into Vista with the XP partition hidden.
Can anybody help me out?

Both Vista and XP are loaded fine, and I can boot into both of them, but how do I hide the other partition?

XP is on disk 0 partition 1
Vista is on disk 0 partiton 2

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub menu.lst file, and should be located at C:\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries
# http://neosmart.net/wiki/display/EBCD

default 0
timeout 0

title Boot XP - Hide Vista
hide (hd0,2) # SET THIS TO THE VISTA DRIVE
# Optionally repeat the above entry for all the Vista drives
chainloader (hd0,1)/ntldr # SET THIS TO THE BOOT PARTITION
boot
 
#5
Billy Yoe
I have not the slightest idea. Why don't you hide the partitions of xp while running vista and v.v.
Anyway you should make it a post of yourself because it has nothing to do with the problem of this post.
I have found a temperary solution for my problem, by erasing both my linux distributions and reinstalling Kubuntu on the IDE disk and suse on the SATA disk.
The problem is that you cannot install grub to the boot partition (gives error messages: problem parsing number) then. You must put it in the mbr of the own disk (no problem with windows on the raid-0.
Now in Easy BCD I have added the linux bootloader located on hda. When I restart I first get the message:
Cannot load from harddisk. Insert systemdisk and press any key. Pressing any key produces the linux bootloader from hda mbr.
 

mqudsi

Mostly Harmless
Staff member
#6
OK....


BillyJo: you should open your own topic, but hide XP simply change the numbers to point to your vista and boot drives respectively then select neogrub on that bootscreen.

eeekie: That's an interesting error, that leads to me believe that you probably have something weird with your hardware configuration or a dirty MBR.

Try the "I don't have grub installed" option in EasyBCD?
 
#7
Hallo computer guru.
The only "weird" thing about my computer configuration might be the software sata raid-0. Linux can't handle this.
I could not find the EasyBCD option no grub bootloader installed. May be you can give me a hint.
Dirty MBR no doubt. I have messed around with multi booting for over a year. EMBRL missing fot example is a remnant of Boot-NG.
For the moment I am happy just one key away from my ideal situation. I can live with that!
 

mqudsi

Mostly Harmless
Staff member
#8
In the latest version of EasyBCD (the one in the post above), in the add/remove entries linux section there is a setting "grub isn't installed to the bootsector" as a checkbox at the bottom, isn't there?
 
#9
Computer Guru,
I have the latest version installed and in ther lowest chckbox I find only the partions ofsubsequent disks.
 
#10
Hello computer Guru
The one key stroke away from the ideal situation, means that when I choose the linux partitions in windows vista bootloader I first get a screen with the following text:

Bootpart 2.60 Bootsector ( c ) 1993-2005 Gilles Vollant http://www.winimage.com/bootpart.htm
Loading new partition
Bootsector from C.H. Hochstaetter
Cannot load from harddisk
Insert systemdisk and press any key

If I press any key I get the linux bootloader allright.
Obviously there are still files in the bootsector of the raid-0 disk from another multiboot program I once tried.
How do I get rid of these entries?
 

mqudsi

Mostly Harmless
Staff member
#11
What this tells me is that you probably selected the wrong partition in EasyBCD.... did you try all combos?
 
#12
Hello Computer Guru,
Whatever combo always the same result. Even the combo's with partitions of the sata drive give the seem intermediate screen aand after pressing any key thekubuntu bootloader.
I am sure I chosed the right partition as I wrote grub to the bootpartition of kubuntu.
I think a textfile of Bootpart is still sitting prior to the kubuntu bootfile. But where?
 

mqudsi

Mostly Harmless
Staff member
#13
Bootpart only loads the partition you chose in EasyBCD, it's a special kind of failsafe instead of loading it directly. It only gives that error message if (and only if) it detects that the bootloader isn't there or isn't correctly installed.

I think you need to reinstall GRUB to that partition from within Kubuntu, boot into Vista, delete the old Linux entry, and create a new one.

-OR-

Give me a minute and I'll upload the latest EasyBCD beta build with support for no-bootsector GRUB installs which should bypass the problem entirely through some advanced heuristics.
 
#15
Hello Comp.Guru,
My version of EasyBCD reads: 1.6.2683.20667. The most recent one in my view. I am satisfied with this version and the results I reached. The trash screen in between I 'll take for granted.
 

mqudsi

Mostly Harmless
Staff member
#16
Yes, but if you download and install the later build (the one in this thread), you can make even that screen vanish.

It's no risk - just create a new entry, and if it doesn't work, trash it.
 
#17
Hello Computer Guru,
I have installed your version, but I can't find out what to do to make the intermediate screen disappear.
My EasyBCD bootloader looks as follows:
Code:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device unknown
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
displayorder {059b6dc3-0e2a-11dc-9c72-00138f8829a5}
{059b6dbf-0e2a-11dc-9c72-00138f8829a5}
{059b6dc1-0e2a-11dc-9c72-00138f8829a5}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 5
Windows Boot Loader
-------------------
identifier {059b6dc3-0e2a-11dc-9c72-00138f8829a5}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista
bootdebug Yes
osdevice partition=C:
systemroot \Windows
resumeobject {ac76b941-2276-11dc-8b74-806e6f6e6963}
nx OptIn
pae ForceDisable
sos No
debug No
Windows Legacy OS Loader
------------------------
identifier {059b6dbf-0e2a-11dc-9c72-00138f8829a5}
device partition=C:
path \NST\nst_grub.mbr
description Linux bootloader
Windows Legacy OS Loader
------------------------
identifier {059b6dc1-0e2a-11dc-9c72-00138f8829a5}
device partition=D:
path \ntldr
description Windows xp
Looks O.K.
If I want to edit the legacy O.S. Loader with EasyBCD I get xp's boot.ini but not Grub.
If I open C: \NST\nst_grub.mbr with wordpad I get a some scribble and the text of the intermediate screen:
Code:
ë<ú3ÀŽÐ¼|¸°ŽØŽÀ¹‹ñ¿
ó¥¸ÐPŽØŽÀ¸dPËû¾[1]èo¹º€3ÛS»|S¾é¸BÍs¸BÍs¸BÍr.&>þ}Uªu%¸
Àt&¢$|¸
Àt&¢%|¸&£|¸&£‑|˾—[1]è´Ít2äÍëô2äÍ3ÒÍü¬
ÀuÃV´Í^ëò|?BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant [URL]http://www.winimage.com/bootpart.htm[/URL]
 
Loading new partition
 
Bootsector from C.H. Hochst„tter
 
Cannot load from harddisk.
 
Insert Systemdisk and press any key.
 
Uª
If I remove the text and save as mbr, the grub bootloader does not start, just hangs on the cursor.
Give me a few hints how to tackle the problems
 

mqudsi

Mostly Harmless
Staff member
#18
Why would you open nst_grub.mbr for editing?
It's binary (executable) file, you can't edit it like that!

Anyway, here's what you do:

Create a new Linux entry - Add/Remove -> Linux/BSD
Type: GRUB
Name: Test Entry
[x] Grub isn't installed to the bootsector (Make sure you check that option!)
Add Entry

Reboot. Try that option.
 
#19
Hello Comp. Guru,
This does the trick. I can get now straightforward into my linux bootloader.
Unfortunately only suse starts up flawless. Kubuntu doesn't because the bootloader says kubuntu is on harddisk (hd1,0) but the boot script thinks it is on (hd0,0) like before.
By editing this line and swapping the 0 for a 1 kubuntu starts up but drops into level 3. When I type: init 5 the x-server is started. After typing my password I get a box stating: could not start kstartupconfig.
So all in a sudden several files are damaged. I would not know how to repair. Reinstallation is for me the easiest option.
Is it just a coincidence or has my new EasyBCD entry ruined Kubuntu?
 

mqudsi

Mostly Harmless
Staff member
#20
It must be a coincidence because EasyBCD doesn't have write access to Linux partitions - only the MBR and Vista.

Try running
Code:
dmesg -tail
if you want to see a list of errors encountered in Linux.

Glad to hear the grub-less Linux option in EasyBCD works - that's really good news :smile: