My attempt at dual boot Vista64 & Fedora11

Coolname007

New Member
Current menu.lst:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki

#timeout 0
#default 0

#title /boot/grub/menu.lst
#fallback 1
#find --set-root --ignore-floppies /boot/grub/menu.lst
#configfile /boot/grub/menu.lst

#title /grub/menu.lst
#fallback 2
#find --set-root --ignore-floppies /grub/menu.lst
#configfile /grub/menu.lst

#title /boot/grub.conf
#find --set-root --ignore-floppies /boot/grub.conf
#configfile /boot/grub.conf

# All your boot are belong to NeoSmart!

#Manually added the below
default=0
timeout=5
splashimage=(h1,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=/dev/sdb2 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows
rootnoverify (hd0,0)
chainloader +1
You need to change it to this (no more, no less):

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki

#timeout 0
#default 0

#title /boot/grub/menu.lst
#fallback 1
#find --set-root --ignore-floppies /boot/grub/menu.lst
#configfile /boot/grub/menu.lst

#title /grub/menu.lst
#fallback 2
#find --set-root --ignore-floppies /grub/menu.lst
#configfile /grub/menu.lst

#title /boot/grub.conf
#find --set-root --ignore-floppies /boot/grub.conf
#configfile /boot/grub.conf

# All your boot are belong to NeoSmart!

#Manually added the below
default=0
timeout=0
splashimage=(h1,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
chainloader +1
boot
The Vista entry is not necessary in your NeoGrub menu.lst, because you boot that directly from the BCD (i.e. without chaining to NeoGrub, like you do with Fedora).
Then try it again, and see if it boots.
 

Erik Anderson

New Member
No, it still doesn't boot.

However, I may know the reason why and if I'm right, I don't know how to fix it.

My HP 9428f with an American Megatrends BIOS 5.2x (forgot what x is) sees the hd1 drive as only an 'USB Mass Storage Device' in the boot order. But the BIOS also sees the drive as a hard drive in the "Hard Drive" group.

My two drives listed are my normal hard drive (C )and my DVD-Rom drive. I cannot add a 3rd drive to the list in any way I can see yet there is room for six drives in that very list. HP has a newer version (5.35) of the BIOS firmware but that won't fix the problem as far as I can tell.

So I think I'm stuck in no-man's land and all the king's horses aren't going to solve this. I'm still open for ideas and thoughts on what to do. I appreciate all the time and effort that has been spent on my problem.

Erik
 

Erik Anderson

New Member
I wonder if I should have checked a box saying I was using an SCSI drive after reading this link: http://www.togaware.com/linux/survivor/Mass_Storage.html

And then I saw this. http://www.linux-usb.org/USB-guide/x498.html If I am correct, not only would it be a first, but then I wouldn't be sure where to do the mounting. Could I do it in the configuration file without reinstallation? Or would I have to install yet another time, but this time checking the SCSI option because the drive I want to install is seen as a "Mass Storage Device" by my BIOS?
 
Top