My attempt at dual boot Vista64 & Fedora11

#1
I'm struggling here to boot into Fedora 11 (F11) on a secondary hard drive.

I have Vista on C: and there's another NTFS partition on the second drive. The second drive is also where I want to place F11.

My Drive 1 (second drive) has:
Partition 1 M: as NTFS
Partition 2 is F11's /boot (formatted in ext3)
Partition 3 is F11's / (root) (formatted as ext4
Partition 4 is currently unused (to be used as a 'swap' directory when I get this working)

When I run BCD 2.0 Build 63 Beta, I point to the /boot partition for the Linux. Check that MBR is not installed to the boot-sector as I read the Dual Booting Fedora Linux and Windows Vista (which I wonder if F11 is somehow broken as that deal with Fedora 10 and I'm sure would work perfectly).

I reboot and choose my F11. I get a line about grub menu being loaded it shows temporarily hd(2,5). But then it says Booting Fedora Core and then root(hd0,5).

I looked at the Rescue Installation option from the Install DVD and it says my F11 is on sdb3.

So I am now completely confused as to what I should do. Thank you for any help you can provide.

Erik
 
#2
I reboot and choose my F11. I get a line about grub menu being loaded it shows temporarily hd(2,5). But then it says Booting Fedora Core and then root(hd0,5).

I looked at the Rescue Installation option from the Install DVD and it says my F11 is on sdb3.
Hello Erik, welcome to NST.
Can you please describe more clearly the exactly error message you get when attempting to boot into Fedora? Also, please boot into Vista, and copy over into your next post the output of the following command run from EasyBCD's Power Console on the Useful Utilities page:

Code:
bootpart
And please attach a screenshot of Disk Management as well, using the Manage Attachments feature of the forums, which you can find by scrolling down the page where you make a new post.
 

Terry60

Knows where his towel is.
Staff member
#3
DId you tick the "grub isn't installed...." box when you added the Linux entry in EasyBCD.
(You must do to workaround a grub problem if Linux is on a different HDD to the W7)
 
#4
When I attempt to boot into F11, the error message I end up with is: Error 22 No such partition.

The screenshot from Vista's Disk Managment is attached. Below is the output from bootpart:



Boot Partition 2.60 for WinNT/2K/XP (c)1995-2005 G. Vollant (info@winimage.com)
WEB : Gilles Vollant software and BootPart
Add partition in the Windows NT/2000/XP Multi-boot loader
Run "bootpart /?" for more information

Physical number of disk 0 : 1549f232
0 : C:* type=7 (HPFS/NTFS), size= 718482996 KB, Lba Pos=63
1 : C: type=7 (HPFS/NTFS), size= 14089005 KB, Lba Pos=1436966055
Physical number of disk 1 : 9e6ec85e
2 : D: type=7 (HPFS/NTFS), size= 1362736128 KB, Lba Pos=63
3 : D: type=6 (BIGDOS Fat16), size= 204800 KB, Lba Pos=2725474304
4 : D: type=6 (BIGDOS Fat16), size= 93805568 KB, Lba Pos=2725883904
5 : D: type=f (Win95 XInt 13 extended), size= 8389632 KB, Lba Pos=2913495040
6 : D: type=6 (BIGDOS Fat16), size= 8388608 KB, Lba Pos=2913497088
Physical number of disk 2 : 41172ba5
7 : E: type=de , size= 32098 KB, Lba Pos=63
8 : E:* type=7 (HPFS/NTFS), size= 67368577 KB, Lba Pos=64260
9 : E: type=f (Win95 XInt 13 extended), size= 10771582 KB, Lba Pos=134801415
10 : E: type=7 (HPFS/NTFS), size= 923706 KB, Lba Pos=134801478
11 : E: type=5 (Extended), size= 104422 KB, Lba Pos=136648890
12 : E: type=83 (Linux native), size= 104391 KB, Lba Pos=136648953
13 : E: type=5 (Extended), size= 9743422 KB, Lba Pos=136857735
14 : E: type=8e , size= 9743391 KB, Lba Pos=136857798
 

Attachments

#6
My Drive 1 (second drive) has:
Partition 1 M: as NTFS
Partition 2 is F11's /boot (formatted in ext3)
Partition 3 is F11's / (root) (formatted as ext4
Partition 4 is currently unused (to be used as a 'swap' directory when I get this working)
According to the Bootpart output, and the Disk Management screenshot, the Fedora /boot partition is on Disk 2 (the third disk in the BIOS boot sequence), not Disk 1. That's the 102 MB partition it shows on Disk 2 in the Disk Management screenshot.
That would be the one that says the following in the Bootpart output:
12 : E: type=83 (Linux native), size= 104391 KB, Lba Pos=136648953
Also, if your statement was correct about your root partition being partition 3 (beginning the count at 1, though Grub counts both partitions and drives starting at 0) on that hard drive, that would put your Fedora root partition in the place that, according to Bootpart, is occupied by a "Win95 Xlnt 13 extended" partition, or if you based that assumption on what Disk Management shows, the extended partition would have been skipped in the count, meaning that it would be the next partition after that in the Bootpart output....namely the one that says this:

10 : E: type=7 (HPFS/NTFS), size= 923706 KB, Lba Pos=134801478
So that also can't be correct since it is an NTFS logical partition, with the size of 923706 KBs (approx. 902 MBs). So that would seem to indicate you have somehow lost your Fedora /root partition (which contains the OS), which would explain why its not booting, and you get a message saying "Error 22: No such partition." :brows:

Physical number of disk 0 : 1549f232
0 : C:* type=7 (HPFS/NTFS), size= 718482996 KB, Lba Pos=63
1 : C: type=7 (HPFS/NTFS), size= 14089005 KB, Lba Pos=1436966055
Physical number of disk 1 : 9e6ec85e
2 : D: type=7 (HPFS/NTFS), size= 1362736128 KB, Lba Pos=63
3 : D: type=6 (BIGDOS Fat16), size= 204800 KB, Lba Pos=2725474304
4 : D: type=6 (BIGDOS Fat16), size= 93805568 KB, Lba Pos=2725883904
5 : D: type=f (Win95 XInt 13 extended), size= 8389632 KB, Lba Pos=2913495040
6 : D: type=6 (BIGDOS Fat16), size= 8388608 KB, Lba Pos=2913497088
Physical number of disk 2 : 41172ba5
7 : E: type=de , size= 32098 KB, Lba Pos=63
8 : E:* type=7 (HPFS/NTFS), size= 67368577 KB, Lba Pos=64260
9 : E: type=f (Win95 XInt 13 extended), size= 10771582 KB, Lba Pos=134801415
10 : E: type=7 (HPFS/NTFS), size= 923706 KB, Lba Pos=134801478
11 : E: type=5 (Extended), size= 104422 KB, Lba Pos=136648890
12 : E: type=83 (Linux native), size= 104391 KB, Lba Pos=136648953
13 : E: type=5 (Extended), size= 9743422 KB, Lba Pos=136857735
14 : E: type=8e , size= 9743391 KB, Lba Pos=136857798
 
Last edited:
#7
Disk 2 or 41172ba5 has an older version of Linux installed. I do not want to use that (Fedora 6). It's a Vista 32 drive I took out of my older computer and have attached to a USB <---> ATA cable so I can eventually move stuff over to the newer CPU.

My Fedora 11 /boot should be line 3 of

Physical number of disk 1 : 9e6ec85e
2 : D: type=7 (HPFS/NTFS), size= 1362736128 KB, Lba Pos=63
3 : D: type=6 (BIGDOS Fat16), size= 204800 KB, Lba Pos=2725474304
4 : D: type=6 (BIGDOS Fat16), size= 93805568 KB, Lba Pos=2725883904
5 : D: type=f (Win95 XInt 13 extended), size= 8389632 KB, Lba Pos=2913495040
6 : D: type=6 (BIGDOS Fat16), size= 8388608 KB, Lba Pos=2913497088

as I set that at 200 Mb.

Line 2: is the M: drive in Vista 64 (1299.61 GB)

Line 4 is supposed to be the / drive of Fedora 11.

Am I wrong? Doing something wrong and how do I fix it? Maybe I need to change the boot order in the BIOS so that it corresponds to what is expected? If so, what order should I do?

I really appreciate the help and time everyone is spending on this. I thought myself as at least somewhat computer-savvy but this has been knocking me for an infinite loop.

Erik
 
#8
Disk 2 or 41172ba5 has an older version of Linux installed. I do not want to use that (Fedora 6). It's a Vista 32 drive I took out of my older computer and have attached to a USB <---> ATA cable so I can eventually move stuff over to the newer CPU.

My Fedora 11 /boot should be line 3 of

Physical number of disk 1 : 9e6ec85e
2 : D: type=7 (HPFS/NTFS), size= 1362736128 KB, Lba Pos=63
3 : D: type=6 (BIGDOS Fat16), size= 204800 KB, Lba Pos=2725474304
4 : D: type=6 (BIGDOS Fat16), size= 93805568 KB, Lba Pos=2725883904
5 : D: type=f (Win95 XInt 13 extended), size= 8389632 KB, Lba Pos=2913495040
6 : D: type=6 (BIGDOS Fat16), size= 8388608 KB, Lba Pos=2913497088

as I set that at 200 Mb.

Line 2: is the M: drive in Vista 64 (1299.61 GB)

Line 4 is supposed to be the / drive of Fedora 11.
Ok, so that makes sense except for the fact that in the Bootpart output it shows that partition as a "BIGDOS Fat16" partition, while in Disk Management, it shows it as RAW. And according to what you said in the first post, the Fedora /root partition is formatted with the ext4 filesystem. But I'm wondering if maybe since ext4 is fairly recent, Bootpart is not reading the filesystem correctly, and believes it is Fat16 even though it is actually ext4. And of course, it would make sense that Windows Disk Management might display the partition as "RAW" since it does not recognize Linux filesystems at all (though Bootpart recognizes ext3).
And of course the same holds true for that 200 MB partition that you said is the /boot partition.

In that case, then it sounds like you would need to point the Linux entry in the Device drop-down menu under the Linux tab in EasyBCD's Add/Remove Entris section, at drive 1, partition 2 (as seen in EasyBCD), most likely. Is that where you pointed it?
 
#9
Yes, I pointed it (a second time to be sure) at Drive 1, Partition 2 as seen on TV or BCD. Maybe I should just try it all again and just use ext3? But any other ideas from anyone before I torture myself again with the choosing packages to install?

This is only a hobby, this is only a hobby... :??
 
#10
Hmm...it would seem ext4 is not fully supported by EasyBCD yet. :frowning: We have had reports of success with using the latest beta build of EasyBCD, with ext4, but those reports were few, and I suppose it is possible it doesn't work with all systems yet. (And then again, Fedora 11 may have changed something critical in the boot process...one never knows)
Unfortunately, I can't think of anything else at this point, other than do a reinstall of Fedora with ext3 instead, and see if that helps.
 
#11
Hope I catch you online, but in a response to Panarchy you said the following:

@Panarchy: Thanks for posting the current menu.lst. That is what I needed to see. Well...I guess its safe to say the best thing we can suggest to future users of EasyBCD who are having troubles booting into Fedora is to tell them to simply copy the entries from their Fedora menu.lst to the NeoGrub one, and use NeoGrub to load Fedora. It seems to be the best solution there is currently, since the Linux option (either checking the box or leaving the box unchecked) of EasyBCD doesn't work for Fedora at this point. I will keep that in mind for future reference.

Can you explain what that would mean if I tried to do the same as he did? If that doesn't work, then I will have a go using ext3 all the way.

Thank you,
Erik
 
#12
Hope I catch you online, but in a response to Panarchy you said the following:

@Panarchy: Thanks for posting the current menu.lst. That is what I needed to see. Well...I guess its safe to say the best thing we can suggest to future users of EasyBCD who are having troubles booting into Fedora is to tell them to simply copy the entries from their Fedora menu.lst to the NeoGrub one, and use NeoGrub to load Fedora. It seems to be the best solution there is currently, since the Linux option (either checking the box or leaving the box unchecked) of EasyBCD doesn't work for Fedora at this point. I will keep that in mind for future reference.

Can you explain what that would mean if I tried to do the same as he did? If that doesn't work, then I will have a go using ext3 all the way.

Thank you,
Erik
That was back when EasyBCD's "Grub is not installed..." checkbox option underneath the Linux tab did not work with Fedora, due to its separate /boot partition. :wink: But if you want to try using NeoGrub manually, perform the following steps:

Boot from your Fedora LiveCD:


  1. Get to the desktop.
  2. Open up the Fedora menu.lst, which can be found at /grub/menu.lst on your Fedora /boot partition.
  3. Hit Ctrl + A to select all in the file.
  4. Then open up a Document Application.
  5. Press Ctrl + V to paste the contents of your menu.lst into the new file.
  6. Save it as whatever you want.
  7. Copy the file somewhere where it can be accessed from Vista.

  1. Then boot into Vista.
  2. Open up EasyBCD.
  3. Navigate to the NeoGrub tab of the Add/Remove Entries section.
  4. Click Install NeoGrub (or if that option's not available, just hit "Configure").
  5. Hit Configure (obviously not necessary if you did it in last step :brows: ).
  6. Copy over the contents of the file into the NeoGrub menu.lst, which opens up, replacing everything in that file that is not commented out with "#".

Then save the NeoGrub menu.lst file, and try booting from your Fedora entries which will be found in the second menu after selecting "NeoGrub Bootloader" in the Vista boot menu.
 
Last edited:
#13
Darn, that did not work either. So, tomorrow night will be yet another fun-filled evening of attempting to install F11. This time, I will use ext3 for both / and /boot partitions and follow all of the advice given to me.

Thanks once again. Hope to come on here tomorrow from F11. If not, maybe we'll figure something else out. Like maybe it's a bug in F11 or the anaconda installer or the end-user who needs squashed.

Erik
 
#14
Ok, I'm back after installing both the / and the /boot with ext3 formats. Alas, I get a different error message, but it doesn't mention partitions. I get an error message on:

find --set-root --ignore-floppies /boot/grub.conf

I guess the /boot is pointing somewhere incorrectly?

The rest of my configuration is the same as I've previously written.

I ask for any other suggestions?

Thank you.
 
#15
Ok, I'm back after installing both the / and the /boot with ext3 formats. Alas, I get a different error message, but it doesn't mention partitions. I get an error message on:

find --set-root --ignore-floppies /boot/grub.conf
You appear to have added another Linux entry in EasyBCD, with the "Grub is not installed..." box checked, which means your NeoGrub menu.lst would have been changed back to the original state it had before copying over the Fedora menu.lst entries from your Fedora menu.lst. :wink: So you should try copying the Fedora entries again into your Neogrub menu.lst, replacing all non-commented lines.
 
#16
This is what my menu.lst looks like after using what I think were the Fedora's menu.lst:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki

#timeout 0
#default 0

#title /boot/grub/menu.lst
#fallback 1
#find --set-root --ignore-floppies /boot/grub/menu.lst
#configfile /boot/grub/menu.lst

#title /grub/menu.lst
#fallback 2
#find --set-root --ignore-floppies /grub/menu.lst
#configfile /grub/menu.lst

#title /boot/grub.conf
#find --set-root --ignore-floppies /boot/grub.conf
#configfile /boot/grub.conf

# All your boot are belong to NeoSmart!

#Manually added the below
default=0
timeout=5
splashimage=(h1,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=UUID=3e96c8c2-4e56-48fd-9555-2e208cd800f8 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows
rootnoverify (hd0,0)
chainloader +1


But I still get the Cannot mount partition error as before.

What should I look at to solve this problem? Is there any way to single-step or at least log the boot process so we can try to find out what is going wrong? Or is it my destiny to be the king of pain and will never have synchronicity between Linux and Vista?

Erik
 
#17
default=0
timeout=5
splashimage=(h1,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=UUID=3e96c8c2-4e56-48fd-9555-2e208cd800f8 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows
rootnoverify (hd0,0)
chainloader +1
Try changing the UUID line I marked in bold to /dev/sdb2 instead, and try the following in your NeoGrub menu.lst:

default=0
timeout=0
splashimage=(h1,1)/grub/splash.xpm.gz
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=/dev/sdb2 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.x86_64.img
Try that and see if it boots.
 
#18
After trying the /dev/sdb2 replacement, I still get the cannot mount partition error (three little words causing me more trouble than saying "I love you" to my wife. :wink:)

I've always noticed, but never wrote down before, but after selecting Neosmart Linux from the menu, the first thing I see is "Starting cmain() (hd0,0)". I bet that's part of BCD.

Any other ideas would be welcomed.

Erik
 
#19
Please post your current NeoGrub menu.lst.
 
#20
Current menu.lst:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki

#timeout 0
#default 0

#title /boot/grub/menu.lst
#fallback 1
#find --set-root --ignore-floppies /boot/grub/menu.lst
#configfile /boot/grub/menu.lst

#title /grub/menu.lst
#fallback 2
#find --set-root --ignore-floppies /grub/menu.lst
#configfile /grub/menu.lst

#title /boot/grub.conf
#find --set-root --ignore-floppies /boot/grub.conf
#configfile /boot/grub.conf

# All your boot are belong to NeoSmart!

#Manually added the below
default=0
timeout=5
splashimage=(h1,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.x86_64)
root (hd1,1)
kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=/dev/sdb2 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows
rootnoverify (hd0,0)
chainloader +1