Need Help with Dual Boot in Easy BCD


Active Member
Hey folks--

Noob here. I'll cut the chase of my question and then give you some background. I have two physical drives in my PC machine. Each drive has a separate OS on it. It started off with XP on one and Vista on the other.

I recently upgraded Vista 32-bit to Windows 7 64-bit and tried to keep XP unharmed. Well, that didn't happen and to make a long story short, I just finished rebuilding my XP drive.

Prior to the upgrade mishaps, I was able to see the OS selections and choose which one to boot into. After the upgrade, there was no boot selection screen. If I changed the boot order to the XP drive, then that's what booted. If I changed the boot order to W7 then that boots. I used Easy BCD to give me back my boot loader and now I see the boot choices, I can choose Windows 7 and it boots fine, but when I choose XP, the system just restarts the BIOS again.

I'm sure there's something fairly easy I can do, but I'm not a pro with this awesome utility (yet:grinning:) so I can really use some help.

Thanks in advance. Let me know if you need any more info.
Hi Razor, welcome to NST.
Boot from the W7 HDD
Install EasyBCD 2.0 latest build on W7
Delete the XP entry
Add it again
Let Easy2 auto-configure the XP boot for you when it offers.
Don't alter the XP drive address it sets up.

(sorry about the last line - but we've had a spate of people who don't understand the phrase "auto-configure". They have no experience of dual-booting, but still assume that they know more than the carefully developed software, edit what it sets up, then post that it doesn't work)
Ah, I fall into that category. When I first intalled BCD onto the W7 drive, it only showed W7 as an OS. I manually added XP and it defaulted to the C: drive--which is the same driver letter as the W7 drive, so I changed it to the physical drive letter (E) of where XP is installed. My bad. :??

I'll try the advice you posted. Thanks for the prompt response. I'll post back my results.

Thanks again,
Yeah, your C: drive is your "system" partition (as seen from Disk Management), meaning all boot files of all Microsoft OSes should be located in that partition. XP's boot.ini file is what points at the XP partition (NOT the BCD).
I learned something new, and it totally makes sense.



OK--followed all of the instructions and here is what I get when I choose the XP boot.

It tells me the files are missing and I need to use the XP CD to repair them. The file they say is missing is: \NTLDR and Status: 0x000000f

I'm going to try in BCD again and see if the reboot fixes it. Any advice is really appreciated.
Last edited:
Please post the contents of your boot.ini file, along with the Detailed (debug) settings in EasyBCD's View Settings section, and a Disk Management screenshot.
Sorry M8. I don't know where the boot.ini file is in W7. I searched online and read there is none in W7--it uses boot manager. Please advise.

Here are the debug detailed settings:

Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {89c90fc1-c0e6-11de-827c-a53047c54cf0}
resumeobject {89c90fc0-c0e6-11de-827c-a53047c54cf0}
displayorder {89c90fc1-c0e6-11de-827c-a53047c54cf0}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
Windows Boot Loader
identifier {89c90fc1-c0e6-11de-827c-a53047c54cf0}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 Business 64-Bit
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {89c90fc4-c0e6-11de-827c-a53047c54cf0}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {89c90fc0-c0e6-11de-827c-a53047c54cf0}
nx OptIn
Real-mode Boot Sector
identifier {89c90fc8-c0e6-11de-827c-a53047c54cf0}
device partition=C:
path \NTLDR
description Windows XP Professional
Look in your C: partition. It is "system".
And yes, the boot.ini is an XP boot file, not a W7 file, but all the boot files go into a single "system" partition, like I mentioned above.

You will need to be showing hidden files and folders, and unhiding protected system files, in the Folder Options of the Control Panel, before you can see the boot files.

EDIT: Oh, and while you're at it, you might as well make sure the ntldr and files are in the same place (i.e the root of the C partition)...
If they're not, that explains why XP isn't booting.
Last edited:
I unhid my system folders soon after I installed W7. There is nothing in the c:\windows\system folder and there is no boot.ini file in c:\windows\system32 (just checked there in case).

If I change my boot order in BIOS, Windows XP boots fine--FYI.

What am I missing?
No. The boot files are not stored in any directory of the "system" partition.
They are stored in the root (meaning NO directory, just C:/ ) of the partition.

Look again in the root.

You will also need to unhide protected system files (in addition to showing hidden files and folders).


Of course all of this is assuming you even followed Terry's instructions in the 2nd post, and ran the EasyBCD auto-config which is supposed to automate the whole process...

Did you?


BTW, I'm assuming you're looking into the C: partition from W7, not XP (since you say you can get into it by changing the boot sequence in the BIOS)? The drive letters are seen differently by different systems, in most cases. It is a registry thing that is specific to the booted system, nothing else.
Last edited:
Nope. There is just a file called bootmgr and if I try to open it in notepad, it is just jibberish.

See attached sccreenshot.


  • Doc1.doc
    171 KB · Views: 4
Ok, well there's your problem.
EasyBCD was supposed to create the boot.ini, NTLDR, and in the root of your C: partition (since it is system) when you ran the auto-configurator (assuming of course, you did...).

Try deleting and adding the XP entry again in EasyBCD, and accepting the offer to auto-configure.
Ok, well there's your problem.
EasyBCD was supposed to create the boot.ini, NTLDR, and in the root of your C: partition (since it is system) when you ran the auto-configurator (assuming of course, you did...).

Try deleting and adding the XP entry again in EasyBCD, and accepting the offer to auto-configure.

Trying again now.
If it fails to again, manually copy over the 3 files from XP's partition into the C: partition's root.
Then adjust the rdisk() values in both lines in your boot.ini file to say (1) instead of (0).

That should get your XP boot working.
Last edited:
No luck again. Let me clarify that you know each OS is on a separate physical drive? Not logical partitions.

I'm not familiar with the instructions you gave me. Are you saying to boot into XP and copy some file(s) say to my flash drive, then boot into W7 and paste it into a folder there? Can you break down the instructions for someone that hasn't done this before?

Many thanks,
Yes, I understand that the OSes are on separate physical HDDs.
No, no need to boot into XP. You can copy the files over straight from inside W7.

Just paste the files straight into the C:/ location of your C: partition (i.e. outside of any folder).

Sorry for not clarifying some of the stuff. A lot of the times, I assume the user has basic knowledge of computers, such as how to access the Control Panel, how to access Disk Management, etc. But unfortunately, that's not always the case.



EDIT: Oh, and sorry, if you were wondering what the 3 files I mentioned are, they're of course BOOT.INI, NTLDR, and NTDETECT.COM.
Last edited:
No worries. I like to make certain I'm doing something correctly when it comes to system files.

I know how to get to disk management: computer > manage > disk management, but I don't know which file(s) I need to copy and where they/it is.
Names of the files are in my edited post right above yours.
As for where they are, you can find them in the root (meaning outside of any folder) of your XP partition.