Partition resize on XP / Vista

Pedz

New Member
#1
Say, I suggest sorting partition resizing issues to one forum or thread.

Short story:
Happy camper so far w/ EBCD.,
but messed up with Parted Magic...

...canceled a minute after 1 out of 4 tasks completed (took 2 days),
2nd task just started.
Advice so far from sharing my TestDisk analysis, is...

> Use Linux fdisk to set
> 3 * Linux LVM 11456 0 1 13993 135 30 40765440
> to NTFS (7) type, set this partition as P(rimary)
> Set the second partition (Vista) as bootable
> Write the partition table
> Quit, reboot
> Try again to fix the Vista partition.

Does this look OK, if a no-go on quick-fix by Vista Recovery Env. Disk?
If so, does fdisk's "-t" command do the trick,
...if I give disk partition # & NTFS (7) type partition ?
- Then setting partition as P, and Vista as bootable?

+ For the curious, find more detail below,
inc. attached Parted Magic screenshot, & testdisk log.

- Cheerz, Pedz.


Long story:

Started w/ Vista, 'Vista restore' (factory installed) & XP partitions, all NFTS:
1) NFTS Vista Recovery partition, ~ 6 GB [ServiceV002].
2) NFTS Vista Partition, ~ 132 GB [SW_Preload].
3) NFTS XP Pro partition (I installed) ~ 20 GB [ some label ].

Last week used "Parted Magic" to resize the XP partition larger than native Vista resizer would allow, taking from Vista.
+ Ran Parted USB live disk in "Fail safe" mode.
+ Started 4 HD resizing changes, but missing 2 critical details =
a) Parted takes days to resize large HDDs...expecting hours.
b) Parted's advice = DON'T MOVE partition from it's 1st disk address.
My 1st chosen action looked SAFE, shrinking VISta down to 87 GB.
However, my other 3 changes set to move 1st cluster in XP partition...UNSAFE.
After visparted completed 1st task, resizing Vista partition (2 days);
CANCELLED next 3 tasks, ~ a minute after 1st task ended.
+ Visparted screen said: 2nd action started copying files, no other changes.
+ After, Visparted warned the XP partition had 'invalid magic', NFTS inconsistent,
& advised running chdsk /f soon. (Attached Parted screenshots)

+ Restarting laptop, neither Vista or XP would load, "bootmgr is missing".
I used a Vista Recovery disk from NeoSmart,
http://neosmart.net/blog/2008/windows-v ... -download/
http://neosmart.net/wiki/display/EBCD/R ... om+the+DVD

'Startup Repair' FAILED...install disk saw no OS.
Using Windows Recovery Env., (WinRE) cmd prompt, I can see Vista partition (C:smile:,
Vista Recov. Partition (E:smile:, but no XP.
+ Replaced C:frowning:Vista) boot folder with one from Vista Recovery Disk, & tried...
bootrec.exe /fixmbr
E:\boot\bootsect.exe /nt60 all /force (program in recovery partition)
These seemed to work, then:
del C:\boot\bcd
bootrec.exe /rebuildbcd
- This seemed to work, until WinRE declared only Vista choice (C:smile: = corrupted.

+ Ran TestDisk v6.9 from Parted USB live disk, started log file, and 'Deeper
search'. See attached log file, if you're curious.

'Deeper Search', found 7 drives report deleted (D),
3 partitions are visible using TestDisk -P, one (of 2) vsn's XP,
one (of 3) vsn's Vista, & 1 (of 2) vsn's Vista recovery partition.
One Vista version looks like original, before shrinking =
"NTFS, found using backup sector!, 132 GB / 123 GB" (/P cannot read)
 

Attachments

mqudsi

Mostly Harmless
Staff member
#2
That should work..

If you're not comfortable with clusters and TestDisk, I suggest grabbing yourself a copy of Acronis Disk Director and using its visual "Partition Recovery" expert to do the job - it's a lot easier.
 

Pedz

New Member
#3
That should work..

If you're not comfortable with clusters and TestDisk, I suggest grabbing yourself a copy of Acronis Disk Director and using its visual "Partition Recovery" expert to do the job - it's a lot easier.
I tried fdisk briefly, but did not set as bootable...
After, fdisk reported all partitions as not ending on cylinder boundaries (output below).
Also, can't seem to save anything to my USB drive,
Windoze won't see XP partition, & couldn't get Linux nftsprog to see the USB HDD.

Unless there's a quick n ez solution,
I'll go for Acronis DD.

Say, will Acronis boot CD work on my sleeping beaut?
...other option = maybe same idea, using a BartPE.

Cheerz Pedz

Fdisk Output =
root@PartedMagic:~# fdisk -l

Disk /dev/hda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x048b7bb8

Device Boot Start End Blocks Id System
/dev/hda1 1 849 6816768 27 Unknown
Partition 1 does not end on cylinder boundary.
/dev/hda2 849 11456 85201200 7 HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/hda3 * 11457 13994 20382720 8e Linux LVM
Partition 3 does not end on cylinder boundary.

Disk /dev/sda: 1027 MB, 1027604480 bytes
255 heads, 63 sectors/track, 124 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x91f72d24

Device Boot Start End Blocks Id System
/dev/sda1 * 1 125 1003488+ b W95 FAT32
Partition 1 has different physical/logical endings:
phys=(123, 254, 63) logical=(124, 237, 49)
 
Last edited:

Pedz

New Member
#5
Tried Disk Director, but it only said my XP partition (D) is corrupt,
others OK. DDir didn't suggest anything else,
so tried to use it for same advised changes in Linux fdisk,
but Acronis boot disk is a non-functione demo only, oh sh*t.

So revisited the only pgm that actually saw my XP files, TestDisk.
I followed the author's fdisk advice, & after using yr Vista boot disk, got back my Vista!
Cool!
...However, XP still in lala land, even trying XP recovery console.

Afer consulting TestDisk author again, think i'll follow next round of advice...
"In Geometry, set 240 heads, Analyse, Quick Search,
use the arrow kets to switch between P,D,L,* to get
P HPFS - NTFS 0 32 33 848 197 53 13633536 [ServiceV002]
NTFS, 6980 MB / 6657 MiB
* HPFS - NTFS 848 197 54 11455 212 46 170402393
NTFS, 87 GB / 81 GiB
P HPFS - NTFS 11456 0 1 13993 135 30 40765440
NTFS, 20 GB / 19 GiB
P HPFS - NTFS 16919 140 54 19457 21 20 40765440
select the Lenovo partition, use 't' to change its type to 27
On next screen, choose Write and confirm."

+ ...latter sounds OK, type 27 for NTFS win recovery partitions.
( http://www.win.tue.nl/~aeb/partitions/partition_types-1.html )
+ How about setting 240 heads? ...of course backing up 1st.

TestDisk rox !
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Yeah, TestDisk is brilliant.

If you still can't get that partition to be seen, you can stil use PhotoRec (also by CG Security) to recover the files from that deleted/corrupt partition.