Partitions and whole HDDs not found

Sarge

Active Member
#1
Alright, here we have

Intel Pentium D
2GB Ram
GF7600GS
2x320GB and there are 3 partitions, 2 on 1 hdd and 2 on the other hdd.

It's a friend of mines computer

Windows XP crashed, how? He just turned it on and while Windows booted it got stuck and not moving so he did hard reset and then he couldn't boot at all, when it should show Windows XP booting screen, there is one small "_" blinking on upper left corner of the screen and nothing else happens.

Ok, so I put XP cd and installation starts, and when comes to the point where I choose partitions I get that there are no partitions or hard drives on that computer, at the bottom there is "enter to continue installation" and when you hit enter you get blue screen of death and nothing moves and only way to get out of that is to hold power button until computer turns off. I tried to start installation many times and was trying different settings in BIOS, and still nothing.

I put Ubuntu Live CD and boot it up, and Ubuntu shows me all 3 partitions and all data is on the partitions, so, partitions are there, also all data is there too, I could copy data and load files and stuff like that.

I start Ubuntu installation, and I format one partition in FAT32(there wasn't NTFS in the menu), I thought maybe something wrong happened with that, and I tried to run XP installation again knowing that there IS one partition who is formated and ready for Windows to see it, but NO, it was still nothing there - Windows couldn't see anything.

Then I tried to install Ubuntu on the hdd, I thought maybe somehow I could reformat and get it ready for Windows, so I'm starting Ubuntu installation and all goes well, until 98% of installing system where it tells me that it couldn't make GRUB installed and that it was fatal error and installation failed.

What that could be, I can take a snap of the screen where Windows XP can't see partitions if needed.
 

mqudsi

Mostly Harmless
Staff member
#2
Sounds like the drive possibly bit the dust?

Only thing to try before throwing it out is low-level formatting the HD in Ubuntu live CD:
Code:
dd if=/dev/zero of=/dev/sda1 bs=4096
Make sure to replace sda1 with the right number.
 

Sarge

Active Member
#3
Yes, thank you Guru, I will give it a try tomorrow... (I hope I wont format wrong HDD :grinning:)
 

mqudsi

Mostly Harmless
Staff member
#4
I'm sure you'll do just fine :grinning:
 

Sarge

Active Member
#5
I did the line you mentioned, and I get "Permission denied" and I run it with "sudo" in front, and It doesn't say anything.

After that, I run installation and tell him to install Ubuntu on first whole HDD, and installation goes good and finishes successful. I can boot into Ubuntu from HDD, and everything works good.

I try to install Windows XP again and I get the same thing:


From that screen, what ever you press (enter, D, F3) you get blue screen of death.

My best guess is to try to format the HDD Ubuntu is on, in FAT32 and try Windows again, and if it doesn't see new partiton.. I don't know what to do... >.<
 

mqudsi

Mostly Harmless
Staff member
#6
Try another Windows CD?
 

Sarge

Active Member
#7
Oh yes, I tried friend's CD of Windows, and mine.. both the same :angry: I just have no idea.. linux works great.. Windows is blind :wtf:
 

mqudsi

Mostly Harmless
Staff member
#8
Are the two drives in a RAID configuration? Does his sata controller need to load the drives before you install?
 

Sarge

Active Member
#9
I wasn't sure, so, I removed one HDD, removed TV card, removed everything but one 1 RAM module, 1 dvd rom, graphic card, motherboard and power supply, and removed everything... there was just core computer needed to set up system. And XP installation still says the same :shame:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
Try updating the BIOS.
 

Sarge

Active Member
#11
Oh crap, I was hoping you wont say that :lup: but alright... how do I do that.. I don't have any cds with BIOS on them.. umm I never did that before... so how do I do that? :ldown:
 

mqudsi

Mostly Harmless
Staff member
#12
It depends...
You have to go to the motherboard manufacturer's site, and look at the product page for your mobo. It should have a download link for the BIOS + instructions on how to flash it.
 

Sarge

Active Member
#13
This PC is putted together by Acer, configuration model is "[SIZE=-1]Acer Aspire E500-EE69 Intel Pentium4(R)D CPU 3,40GHz 2x320GB HDD 2GB DDR II RAM nVidia GeForce7600GS, 256MB"

So... >.<
[/SIZE]

Addendum:

*cough* I don't like this :glare:

Flashing the wrong BIOS can cause harm to the system. Acer recommends that you should only upgrade your firmware/drivers if you have been instructed to do so by an Acer Customer Care representative.
By using these firmware/drivers you agree to accept the possibility of product failure.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#14
Sarge, if you're not comfortable flashing the BIOS maybe you should ask your friend to take it back to the shop? It should still be under warranty from Acer.
 

Sarge

Active Member
#15
Yes, I think we can do it tomorrow. I'm really wondering what will they do to make those HDDs work...
 

mqudsi

Mostly Harmless
Staff member
#16
Well, from what you're telling me the HDD is working fine (so Ubuntu can read/write to it without a problem).

If you've removed the other HD, then it's not a RAId issue, so Windows should be able t osee it without a driver, at the very least.

Possibly a bad IDE cable? (if they're not SATA, that is).

I just don't get why Windows XP can't see it, but Ubuntu installs just fine....... That really is weird.
 

Sarge

Active Member
#17
Yes it is very weird... I never saw this case in my life... I can't wait to see what are they going to do to it to make it work.. I wont leave them alone in the room without me :smile:
 

mqudsi

Mostly Harmless
Staff member
#18
:lol:

I'd like to know what's causing it too.
 

Sarge

Active Member
#19
Yeah, system was working fine, and once while booting it just got stuck and he did hard reset with holding power button. Second later it couldn't boot at all.
 

Sarge

Active Member
#20
Okay, we been there, they said we should get RAID drivers (hit F6 when Windows installation says if we need RAID drivers) So windows should see partitions when we install it :| But if we remove one HDD, it still says the same... is it possible it still needs RAID drivers for single HDD? No idea... but we'll try that tomorrow and see what happens...