Problem dual booting fedora 10 and vista

#1
I got EasyBCD 1.7.2 installed and got XP:MCE 2005, XP pro 64bit and Vista Home Premimum 64bit all setup and dual booting fine together but I can't get fedora 10 64bit to boot.

I've followed this toutorial but when it came time to booting fedora it came up, can not boot blah blah blah please insert system disk and hit any key... so I edited the fedora entry in easy bsd and this time checked off the grub is not installed check box thingy so it installs neo grub, rebooted and tried fedora again and this time it brings me just to some grub command prompt.

so I went back and edited neo grubs config to look like this one except changed all the vmlinuz-2.6.17-10-generic to vmlinuz-2.6.27.5-117.fc10.x86_64 and the /dev/sda2 to /dev/sdb4 cuz thats where its installed. tried to boot fedora again and now it brings up find --set-root /boot/vmlinuz-2.6.27.5-117.fc10.x86_64 for a while then says cannot find file or something like that.

so I tried the config posted near the bottom of this page but changed the 2.6.23.1-42.fc8 stuff to reflect mine and changed the rhgb to sdb4. tried to boot fedora again and it comes up again cannot find file or something like that.

so I tried like every combination of those 2 configs I could think of and tried different drives and partitions and the closest I came to it actually doing something was I changed the config to :

title Fedora
root (hd0,3)
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4
initrd /boot/initrd.img-vmlinuz-2.6.27.5-117.fc10.x86_64

and that came up:
filesystem type is ex2fs, partition type 0x83
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4

then error 2: bad file or directory type. so it got farther then the other ones by pointing to the correct linux partition but doesnt get any farther. :tongueout:

So I'm wondering if anyone would know what my config is supposed to be in order to get fedora to boot. :tongueout:

I tried booting my computer off the fedora 10 live cd (because windows doesn't seam to be able to read the linux file system) then browsing to the partition fedoras installed to then going to the boot/grub/ dir and trying to open the menu.lst to see how it's set up so maybe I could just copy and paste it to the neogrub menu.lst, but I guess it has strict permissions configured on it because it wouldnt let me open it or copy and paste it or do anything to it and I don't know how I would make it let me do that stuff while just booted from a live cd. :tongueout:

my setup is

4 hdd's, 3 only have 1 partition and 1 is partitioned into 4 for XP:MCE, XP:X64 Vista Home Premimum 64bit, and Fedora 10: X86-64

the drives are plugged into my mobo as
disk 1 - partition 1
disk 2 - partition 1 XP:MCE
- partition 2 Vista
- partition 3 XP: x64
- Partition 4 Fedora 10
disk 3 - partiton 1
disk 4 - partition 1

although in my BIOS boot order I have disk 2 set to boot before disk 1.

when I installed fedora it detected the drives as i have them listed above but I guess grub is detecting them as there set in my boot order because it sees disk 2 partition 4 as hd0,3 instead of hd1,3.

Anyways any help would be appreciated. :smile: Thanks.
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Hi DVL_IAC, welcome to NST.

Sorry for the problems you're experiencing. It sounds to me as though you may think Fedora's on /dev/sdb2 but the system/Vista is seeing it differently during boot time. The configuration where you didn't get the prompt is most likely correct, but your entries will need to be modified in menu.lst until you find the correct location.

Depending on the type of disks and how they are connected physically can also play a role on how the system sees the order. Its a shame all the OEMs and MS couldn't get together to form a universal method of identifying disk/partition order, but its a burden us dual-booters are regually faced with.
 
#3
for this config:

title Fedora
root (hd0,3)
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4
initrd /boot/initrd.img-vmlinuz-2.6.27.5-117.fc10.x86_64

for the "=/dev/sdb4", i've tried every possable hdd it could be from sda0 to sda4 to sdd0 to sdd4 and every time it came up bad command or file name, so is this command "kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4" even the right command and is "sd(alphabetical hdd number ex. a=1st hdd b=2nd c=3rd, d=4th, etc)(partition number)" the right way to tell it what hdd to look on?
 
#4
for this config:

title Fedora
root (hd0,3)
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4
initrd /boot/initrd.img-vmlinuz-2.6.27.5-117.fc10.x86_64

for the "=/dev/sdb4", i've tried every possable hdd it could be from sda0 to sda4 to sdd0 to sdd4 and every time it came up bad command or file name, so is this command "kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sdb4" even the right command and is "sd(alphabetical hdd number ex. a=1st hdd b=2nd c=3rd, d=4th, etc)(partition number)" the right way to tell it what hdd to look on?
First of all, you're giving two different locations in the same entry! :lol: (hd0,3) is the first drive, fourth partition, while sdb4 on the other hand is the second drive, fourth partition! That might be part of your problem...:wink:

-Coolname007
 
Last edited:
#6
1 gives me the no such partition error, 0 detects the linux partition because it comes up with the correct file system. so I think its the second line causing the problem. I've tried like every hdd and partition for the =/dev/(sda1-4, sdb1-4, sdc1-4, sdd1-4) and every time it came up with the same bad command or file name error...
 
#7
Sure you installed Grub to the partition, and not to the MBR? :wink:

If not, then run the following commands in a Terminal:

Code:
sudo grub
find /boot/grub/stage1
root (hdx,y)
setup (hdx,y)
quit
exit
where the "x" and the "y" in both the "root" and "setup" commands are replaced with the values found with the "find" command. That will install Grub to Fedora's partition, and then its a simple matter of pointing the entry there, and it should work fine.

-Coolname007
 
#8
Ya, I made the mistake of installing it to the mbr the first time I installed it and it messed up my other boots. So I formatted the fedora partition and repaired my mbr then when I re installed fedora I made extra sure that I choose the partition and not the mbr. :tongueout:
 
#9
Ya, I made the mistake of installing it to the mbr the first time I installed it and it messed up my other boots. So I formatted the fedora partition and repaired my mbr then when I re installed fedora I made extra sure that I choose the partition and not the mbr. :tongueout:
Ok...so what exactly did you do? did you hit the Advanced button, and if so, what location did you enter in?

-Coolname007
 
#10
like enter in for the partition to install fedora to?

in the installer it detected the partition I had set aside for fedora as sdb4 so I installed fedora to that.

but I guess now that hdd b has moved to hdd a's spot because hd0,3 in the root command in the config is the only one that brings up the right partition.
 
#11
like enter in for the partition to install fedora to?

in the installer it detected the partition I had set aside for fedora as sdb4 so I installed fedora to that.

but I guess now that hdd b has moved to hdd a's spot because hd0,3 in the root command in the config is the only one that brings up the right partition.
If the installer said your Fedora partition was sdb4, then it most likely still is, and means you need to change "(hd0,3)" to "(hd1,3)". :wink: Additionally, could you please post a screenshot of the "Drive" menu in the Add/Remove Entries section of EasyBCD, under the Linux tab? And perhaps one of the View Settings window in EasyBCD? I want to verify you're selecting the correct partition there.

-Coolname007
 
#13
Ok...so it seems everything there is pointed at the right place. When you were creating the entry for Ubuntu, did you check the box titled "Grub isn't installed to the bootsector" under the Linux tab in EasyBCD? Or did you install NeoGrub under the NeoGrub tab?

-Coolname007
 
Last edited:
#14
If by Ubuntu you mean Fedora, :tongueout: I checked the "Grub isn't installed to the bootsector" box under the linux tab then went to the neogrub tab and hit the configure button and entered in the config then saved.
 

JustinW

Super Moderator
Staff member
#15
1 gives me the no such partition error, 0 detects the linux partition because it comes up with the correct file system. so I think its the second line causing the problem. I've tried like every hdd and partition for the =/dev/(sda1-4, sdb1-4, sdc1-4, sdd1-4) and every time it came up with the same bad command or file name error...
If drive 0 is seen as the correct location, than the parameter in your ogrinal posted menu.lst file in the kernal line needs to be /dev/sda4 rather than /dev/sdb4. Its either one or the other. Whichever disk it may be, both the root line and any parameters need to be pointing to the same place.

I see from your screenshot that you have 4 different disks in the system. You'll need to try all the combinations: root (hd0-3,1-4) : /dev/sda1-4 - /dev/sdd1-4.
 
Last edited:
#16
If drive 0 is seen as the correct location, than the parameter in your ogrinal posted menu.lst file in the kernal line needs to be /dev/sda4 rather than /dev/sdb4. Its either one or the other. Whichever disk it may be, both the root line and any parameters need to be pointing to the same place.

I see from your screenshot that you have 4 different disks in the system. You'll need to try all the combinations: root (hd0-3,1-4) : /dev/sda1-4 - /dev/sdd1-4.
I don't think so, Justin. Judging from the below quote, where he said the installer detected his Fedora partition as sdb4, it most likely is still disk 1, not 0. :wink:

like enter in for the partition to install fedora to?

in the installer it detected the partition I had set aside for fedora as sdb4 so I installed fedora to that.

but I guess now that hdd b has moved to hdd a's spot because hd0,3 in the root command in the config is the only one that brings up the right partition.
As you can see, he said the installer detected the partition he had set aside as sdb4. So that means his (hdx,y) notation needs to be (hd1,3). Enough said.
If by Ubuntu you mean Fedora, :tongueout: I checked the "Grub isn't installed to the bootsector" box under the linux tab then went to the neogrub tab and hit the configure button and entered in the config then saved.
Yeah...that's what I meant. :smile: Ok...so if you checked that box when you created the entry for Fedora, then that means you would have been using the menu.lst on your Fedora partition to start from, but since you changed it...that means you're now using the NeoGrub menu.lst in place of the other one, most likely. :wink: So please post your latest NeoGrub menu.lst, so we can make sure its configured correctly.

-Coolname007
 

JustinW

Super Moderator
Staff member
#17
How the installer sees it from a live cd and how it is seen when you actually try to boot it are two different things. If it was that simple, we'd never have a user on here with the need to dig into thier menu.lst to modify thier entries. This especially applies when the users got multiple disks in the system, which from the EasyBCD screenshot above, shows that he has four.
 
#18
How the installer sees it from a live cd and how it is seen when you actually try to boot it are two different things. If it was that simple, we'd never have a user on here with the need to dig into thier menu.lst to modify thier entries. This especially applies when the users got multiple disks in the system, which from the EasyBCD screenshot above, shows that he has four.
Maybe so...but that same EasyBCD screenshot shows it as disk 1, not 0. :grinning: So as you can see, even EasyBCD shows it as the second disk, not the first...:??

-Coolname007
 
#19
Coolname007 said:
Yeah...that's what I meant. :smile: Ok...so if you checked that box when you created the entry for Fedora, then that means you would have been using the menu.lst on your Fedora partition to start from, but since you changed it...that means you're now using the NeoGrub menu.lst in place of the other one, most likely. :wink: So please post your latest NeoGrub menu.lst, so we can make sure its configured correctly.
my current config is:

title Fedora
root (hd0,3)
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sda4
initrd /boot/initrd.img-vmlinuz-2.6.27.5-117.fc10.x86_64

note: for the "root( )" and "/dev/[ ]" part of the config i've tried every possable hdd and partition but none worked so I figure it's a problem with the command i'm using and not a problem with choosing the wrong hdd or partition cuz none work. :tongueout:
 
#20
my current config is:

title Fedora
root (hd0,3)
kernel /boot/vmlinuz-vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=/dev/sda4
initrd /boot/initrd.img-vmlinuz-2.6.27.5-117.fc10.x86_64

note: for the "root( )" and "/dev/[ ]" part of the config i've tried every possable hdd and partition but none worked so I figure it's a problem with the command i'm using and not a problem with choosing the wrong hdd or partition cuz none work. :tongueout:
Ok...so try replacing what's in your current NeoGrub menu.lst with this:

# NeoSmart NeoGrub Bootloader Configuration File
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki

#This is our first entry
title Fedora
root (hd1,3) #Load Fedora from the 2nd harddrive's 4th partition.
chainloader +1
#End Fedora entry

#That's it!
That should work just fine...:wink:

-Coolname007
 
Last edited: