Still cant search for updates!

#1
Hello, I've never posted before and I'm not computer savy, but I.m desprate. I have tried so many fixes that I have a hard time remembering everything I have done. The following is the information I sent microsoft, but I have not gotten a reply. Perhaps you can help:

Error 80070424 -This appears to happen quite a bit. My laptop is an HP Pavilion dv2845se, running Vista 64-bit. I have tried every suggestion from SEVERAL different sites. I have been unable to get automatic updates for weeks and cannot install stand alone updates either.(install hangs up and has to be stopped through task manager) My System Restore was somehow wiped and only includes history since the problem beganso going back in time is not an option. My computer says I have never installed or checked for updates. I have renamed the software distribution file, performed the live care scan, verified the correct DLLs, installed and ran Malwarebytes and SUPERantiSpyware, checked the security certificates by un-checking the "require server verification" box and adding the various update addresses to the "TRUSTED SITE" location, and checked the BITS (started). I have booted from a Vista iso recovery disc to run repair and most recently, attempted to repair the update component itself by installing a new update agent. None of these has given my computer the ability to search for updates. Can you please help?
 
#3
Thanks so much for the quick response!
If you mean by using Command Prompt, it won't let me. After entering sfc /scannow, it appears to give me definitions of different tools, then tels me "Windows Resource Protection could not start the Repair Service" See attachment)
 

Attachments

JustinW

Super Moderator
Staff member
#4
Boot from your Vista DVD/our recovery disc -> Repair My Computer -> Command Prompt:

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows\
 
#5
It's running the repair right now (I'm on the desktop). I obviously didn't run the CD correctly the first time. I think I asked it to sysytem restore, instead of repair. When I interrupted it, I just got back to my regular desktop, so I thought it did'nt work. My fingers are double crossed. If this works, I will have the urge to don fresh lipstick and kiss both your cheeks!!

Addendum:

Regrettably, it did not work. ( I am also regretting the above comment after reading it since I forgot to specify which cheeks). The results were as follows:
Windows cannot repair this computer automatically
Root cause found: Unspecified changes to system configuration might have caused the problem.
Repair action: System Restore
Result: Cancelled
Repair Action: System files integrity check and repair.
Result: Failed. Error code 0x490
Time taken: 1045799ms
When I returned to the previous screen and asked for a command prompt window, I attempted the sfc /scannow sequence you stated above, but it kept giving me an almost identical response as the one I sent in the previous post. I can't really be sure I'm entering it with the correct spacing. The final line said "Windows resource protection cannot start the repair service"
What should I do now?
 
Last edited:

JustinW

Super Moderator
Staff member
#6
Time to backup your files to a safe place and re-install Windows or seek MS support for free for issues with Windows Update.
 
#7
OK Thanks for your help. Do you think I did this to myself when trying to fix the update snafu, or do you think it was the snafu itself. I guess I'm asking if I can convince microsoft to help me for free.
 

Terry60

Knows where his towel is.
Staff member
#8
If it's a problem with WUD failing, follow the links from the WUD site to contact MS by email. They'll help you fix it for free. (the only time they don't charge)
 

Attachments