Trouble w/NeoGrub Bootloader

#1
Ok, so I installed linux and then windows 7 on top of that. I followed the guide located at:
http://apcmag.com/how_to_dualboot_vista_with_linux_linux_is_already_installed.htm?page=1
pretty much exactly. The only thing that was different was I couldn't set the unpartitioned space to "active" in the command prompt, but win7 installed perfectly fine on the unpartitioned space anyways.
The linux partitions are still there, and I backed up the menu.lst file and restored it according to the guide.
I thought everything was fine until I went to boot linux using NeoGrub Bootloader and I received an error:
Windows has failed to start. A recent hardware or software change might be the cause. To fix the problem:

1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer.

File: /MST/NeoGrub.mbr
Status: 0xc000000f
Info: The selected entry could not be loaded because the application is missing or corrupt.


Here is the text copied from the linux install to the menu.lst file in easybcd

title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=4780965d-b3ac-4266-a287-2fbb8c456b8e ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=4780965d-b3ac-4266-a287-2fbb8c456b8e ro single
initrd /boot/initrd.img-2.6.27-7-generic

title Ubuntu 8.10, memtest86+
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/memtest86+.bin
quiet


Any help/suggestions would be greatly appreciated.
 
#2
Ok, so I installed linux and then windows 7 on top of that. I followed the guide located at:
http://apcmag.com/how_to_dualboot_vista_with_linux_linux_is_already_installed.htm?page=1
pretty much exactly. The only thing that was different was I couldn't set the unpartitioned space to "active" in the command prompt, but win7 installed perfectly fine on the unpartitioned space anyways.
Hi hdjunkie. Welcome to NST.
It is impossible to set "unpartitioned space" as "active" because it is "unpartitioned space"...:wink: Meaning of course, there is no actual partition there, just empty space. You can only set a *partition* as active. Win 7 installed because the setup created a partition out of the free space available...it didn't install to unpartitioned space.
The linux partitions are still there, and I backed up the menu.lst file and restored it according to the guide.
I thought everything was fine until I went to boot linux using NeoGrub Bootloader and I received an error:
Windows has failed to start. A recent hardware or software change might be the cause. To fix the problem:

1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer.

File: /MST/NeoGrub.mbr
Status: 0xc000000f
Info: The selected entry could not be loaded because the application is missing or corrupt.


Here is the text copied from the linux install to the menu.lst file in easybcd

title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=4780965d-b3ac-4266-a287-2fbb8c456b8e ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=4780965d-b3ac-4266-a287-2fbb8c456b8e ro single
initrd /boot/initrd.img-2.6.27-7-generic

title Ubuntu 8.10, memtest86+
uuid 4780965d-b3ac-4266-a287-2fbb8c456b8e
kernel /boot/memtest86+.bin
quiet


Any help/suggestions would be greatly appreciated.
See those UUID lines I marked in bold? They wont work with any versions of EasyBCD except for the newly released [thread=642]EasyBCD 2.0 Beta[/thread]. So my advice to you is to download the latest build (Build 53), and use it instead of whatever version of EasyBCD you're currently using. Try adding the Linux entry again, making sure to point it at the correct place (i.e. the partition that Ubuntu is installed to), and first leaving the box titled "Grub isn't installed to the bootsector" unchecked, and then if it still doesn't work, try it with it checked, and see if you obtain any better results. If its still not working then you will need to verify the Grub has been properly installed to the *partition's bootsector*, and not to the MBR.

Cheers, and let me know if you have any more questions.

-Coolname006
 
Last edited:
#3
Thanks, I was going to put "it formatted the drive automatically" but I didn't :|

Thanks, I obviously am clueless with this. I'll try the beta now.

Thanks for the quick response!

Addendum:

Ok, I tried that and now I seem to have a different error screen: It says "Try (hd0,0) ext2" when I choose grub bootloader

I know that is where ubuntu is, but I don't see that option in the neogrub tab

I also tried the linux option, and selected the appropriate drive but that option just seems to give me a black screen. I had already booted from the live cd and installed grub to the bootsector of the partition according to the guide in the wiki here: http://neosmart.net/wiki/display/ebcd/linux which also gave me an error similar to the one in my original post.
 
Last edited:
#4
Ok, I tried that and now I seem to have a different error screen: It says "Try (hd0,0) ext2" when I choose grub bootloader

I know that is where ubuntu is, but I don't see that option in the neogrub tab

I also tried the linux option, and selected the appropriate drive but that option just seems to give me a black screen. I had already booted from the live cd and installed grub to the bootsector of the partition according to the guide in the wiki here: http://neosmart.net/wiki/display/ebcd/linux which also gave me an error similar to the one in my original post.
Alright...so now please post screenshots (Prnt Scrn on the keyboard, and then paste into a Paint document) of your "Device" drop-down menu under the Linux tab in EasyBCD, and what the "View Settings" section shows for your Linux entry. Also, it wouldn't hurt to also post a screenshot of your Disk Management screen...:wink: The options under the NeoGrub tab is only for installing, removing, and configuring NeoGrub (manually-actually, what hitting the "Configure" button actually does is open up the menu.lst file used by NeoGrub, and that is what you then use to point it at the correct partition), not for directly telling the app where to locate Linux. You said you followed the instructions in the wiki to install Grub to the partition, but you didn't say what location you entered in after going to the "Advanced" option. We had a couple of users on here who *thought* they had installed Grub to the partition, but had in truth of fact actually installed to the MBR instead. Just remember a location like "/dev/sda1" would be the first partition of the first disk, so Grub would get installed there...but if you chose a location like just "/dev/sda", then it would it be installed to the MBR of the first disk, as you're not specifying what partition to install Grub to in that case, and so it gets installed to the MBR by default. Did you install Ubuntu to the same drive as Win 7 or was it to a separate drive? Answering that simple question should clarify whether or not you installed Grub to the MBR.

So you say you get a blank screen when attempting to boot off of an entry for Ubuntu you created under the Linux tab? Was that when you checked the box saying Grub wasn't installed to the bootsector, or when it wasn't? Have you tried *both* methods, and it still doesn't work? If so, then I'd say the best bet would be to try configuring NeoGrub manually to boot off the correct partition, which I will explain how to do if everything has failed for you so far.

-Coolname007

EDIT: And just to cover all points here, could you also go to EasyBCD>Useful Utilities>Power Console, and then type in:
Code:
bootpart
and post the output of that command here, please? Thanks!
 
Last edited:
#5
I tried with the box unchecked, and then checked. Both ways brought me to the black screen, and neogrub gave me the "try hd0,0 ext2"

Once in the grub command I tryped :
find /boot/grub/stage1

It came back with (hd0,0) and then I entered:

root (hd0,0)
setup (hd0,0)
setup (hd0,0) *didn't seem necessary but that's what the guide said to do*
quit


That was it. Anyways, hopefully this screen shots will help...

 
#6
I tried with the box unchecked, and then checked. Both ways brought me to the black screen, and neogrub gave me the "try hd0,0 ext2"



That was it. Anyways, hopefully this screen shots will help...
Posting the screenshots and bootpart output is still good, but have you tried deleting your current Linux entry, and then adding it again, with that box checked? I ask because the default configuration uses the menu.lst on the Ubuntu partition, but when you edited the NeoGrub menu.lst, it made it so it is now using the NeoGrub menu.lst instead of the Ubuntu one, which may not be configured correctly (though you copied the entries from your Ubuntu menu.lst, I know). I'm just trying to cover all points here, and come up with a solution...:wink:

-Coolname007

Addendum:

Ok...so try giving your "system" partition a drive letter, and then try creating the Linux entry again. :wink: I also still need a screenshot of the "Device" menu under the Linux tab, and the output of that "bootpart" command run from EasyBCD's Power Console.

-Coolname007
 
Last edited:
#7
Ok, I tried deleting the entries and adding linux with the box checked and I got the try hd00 ext2 error again.
I'll try your new suggestions now...

 
Last edited:
#8
Ok, I tried deleting the entries and adding linux with the box checked and I got the try hd00 ext2 error again.
I'll try your new suggestions now...
Ok...so try this configuration instead (and replace your current NeoGrub menu.lst entries with this):

#This is our first entry
title Ubuntu
root (hd0,0) #Load Ubuntu from the 1st harddrive's 1st partition.
chainloader +1
#End Ubuntu entry
It may work better. :wink:

-Coolname007

Addendum:

Sure you selected Drive 0, Partition 1 under the "Device" menu in EasyBCD for the Ubuntu entry when you created it? :wink:

-Coolname007
 
Last edited:
#10
Hmmm....I changed the menu.lst to #our 1st entry and I received a familiar error:

Try (hd0,0): EXT2:_
You must not have selected Disk 0, partition 1 under the "Device" menu when creating the Ubuntu entry then...:wink: It should be working flawlessly otherwise.

-Coolname007
 
#11
All I did was open easybcd 2.0b and deleted my previous entries. Then I selected the neogrub tab/install/configure and pasted your code. Then I clicked save, and restarted. Am I missing something?

here's what the settings looked like after reopening easybcd

 
#12
All I did was open easybcd 2.0b and deleted my previous entries. Then I selected the neogrub tab/install/configure and pasted your code. Then I clicked save, and restarted. Am I missing something?

here's what the settings looked like after reopening easybcd
Oh...you're right. What was I thinking? :lol: Yeah, obviously everything should be working the way it should be now, without creating any more entries under the Linux tab. :wink: Have you followed my earlier advice though in assigning a drive letter to your "system" partition? I think that may be the cause of it all, because your Linux entry was showing that it was pointed at "C:" and "C" is not your "system" partition according to your earlier posted Disk Management screenshot. You need to add a drive letter to your "system" partition, try deleting NeoGrub under the NeoGrub tab, and then try adding a new Linux entry under the Linux tab again, and hopefully this will fix it. I think the problem is NeoGrub uses the "system" flag to locate its boot files (such as its own menu.lst), and then uses that to point back at the Linux partition, but since your Linux entry is not pointed at your "system" partition, that means it is pointed at somewhere else, and so it can't find the files needed to boot.

BTW, please post any further screenshots by using the "Manage Attachments" section of the new post area on this forum, instead of linking back at ImageShack, because your screenshots keep getting screwed up.

If you have made any changes to your partitions since the last screenshot of Disk Management, then please post a fresh screenshot of Disk Management, so I can see firsthand the changes you have made. Where did the "L" drive letter come from? I don't remember seeing it in the now *mysteriously lost* screenshot of your Disk Management screen...

-Coolname007

EDIT: Never mind...I guess everything must be screwing up on my end alone, because I now see the Disk Management screenshot again, when I didn't previously. Very odd...

EDIT #2: But unfortunately, there are errors when clicking on the image, to be redirected to the ImageShack site...
I think you definitely need to use this forum alone to post screenshots from here on out! That would be the best method, me thinks...
 
Last edited:
#13
Yeah, if you look in the above screenshot you'll see that I mapped the system part to L: and that's where the menu.lst file is now. I already tried the linux tab also.
I just booted from the live cd, and put "sudo fdisk -lu" in the shell and it returned:

ubuntu@ubuntu:~$ sudo fdisk -lu

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x7cd17c0c

Device Boot Start End Blocks Id System
/dev/sda1 63 51199154 25599546 83 Linux
/dev/sda2 * 51200000 51609599 204800 7 HPFS/NTFS
/dev/sda3 51609600 300849151 124619776 7 HPFS/NTFS
/dev/sda4 300849255 312576704 5863725 5 Extended
/dev/sda5 300849318 312576704 5863693+ 82 Linux swap / Solaris
ubuntu@ubuntu:~$

I'm not sure if that helps. I'm going to restart again with the box checked again.

Ok, no dice again. try (hd0,0) ext2
 
Last edited:
#14
Yeah, if you look in the above screenshot you'll see that I mapped the system part to L: and that's where the menu.lst file is now. I already tried the linux tab also.
What do you mean you "mapped the system part to L:"? Are you saying you gave the "system" partition the "L" drive letter? If so, then that's perfect, and is exactly what you needed to do. :wink:

-Coolname007
 
#15
Yeah, that's what I meant. Well, I need to do something else because it's not working.

Thanks for all of your help so far, by the way.

It's been two days trying to get this working so far. I tried installing ubuntu after win7 originally but it broke windows. I'm really starting to question if having linux is worth all this trouble.

I'm considering re-instating the grub menu as a last resort, but I'm not confident I'll be able to get back to windows after doing that; nor do I want grub to be the default.

Addendum:

Well, I gave up on easybcd and am using the grub loader.

It worked the first try, and now I can boot into linux and windows 7! I would of liked to use easybcd but it obviously became far too difficult. I wonder if there is a way to make grub default to windows?

Addendum: That was a much easier solution: I just re-ordered the menu.lst file . If I had known it would be this easy I would have done this hours ago.
 
Last edited:
#16
Glad Grub at least worked for you, but am sorry to hear EasyBCD failed for you. :wink: It should have worked perfectly fine with at least that last configuration of the NeoGrub menu.lst I suggested you use (though it should have even worked with simply adding a new entry for Linux under the Linux tab, with that box unchecked). I guess I need to contact CG about this issue, since it seems UUID lines still don't work with EasyBCD, not even with 2.0 Beta, though its supposed to. :smile:

Cheers, and feel free to stick around. We'd love to have you in the forums. Drop by the [thread=7]Introduction Thread[/thread] sometime, and introduce yourself. :wink:

-Coolname007
 
Last edited:
#17
Thanks again for all of your help. I see the potential of easybcd, and I'm sure I'll try it again when these issues are resolved.

I'll take a look through the forums...
 
#18
NP. :smile: Glad to be of "assistance". :brows: Let us know if you have any more questions. :wink:

-Coolname007
 
#19
Hello,

I justed want to let the posters on this thread and others who may read it know that I got Windows 7 and Linux Mint to dual-boot with NeoGrub and EasyBCD 2.0 Beta. Version 1.7.2 had similair issue as the original poster.

If I can help in any way, please let me know.

Thank you.
 

Terry60

Knows where his towel is.
Staff member
#20
Thanks for the info Jenk, and welcome to the forum.