Upgraded Vista to Win7 and XP no longer boots.

#1
I used to have an XP and Vista x64 dual boot with XP on the first partition and Vista on the second with the third being a data partition and it worked perfectly.
I installed Win7 RC1 x64 in the Vista partition and since then when I try and boot XP I get the error message regarding \ntldr not being found.

I tried running the Auto-Configure Boot.ini tool and that didn’t help.
Under Win7 the first physical partition which contains XP is not assigned a drive letter so I assigned it to Z and reran the Auto-Configure Boot.ini tool but it still didn’t help.

I’ve attached images showing the EasyBCD settings and the drive partitions and attributes.
Help greatly appreciated.

Disk 0
WinXP NTFS Healthy (System, Active, Primary Partition)
Windows 7 (C:smile: NTFS Healthy (Boot, Page File, Crash Dump, Primary Partition)
Data (D:smile: NTFS Healthy (Logical Drive)

EasyBCD 2.0 Beta Build 64

Default: Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: XP Pro
BCD ID: {ntldr}
Drive: C:\
Bootloader Path: \ntldr

Entry #2
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
 

Attachments

#2
Hi,

Easybcd is pointing to C as the location of ntldr.

Ntldr should be on the Active partition - in your case that happens to be the same partition XP is installed on. Bcd entry should be pointing there for the location of ntldr.

I don't see a drive letter for the XP partition in your screenshot.

Try using Easybcd to remove the existing XP entry.

Next, give the XP partition a drive letter.

Then use Easybcd to add a new XP entry and let it autoconfigure.

Otherwise, open an elevated command prompt, and type:

bcdedit /set {ntldr} device boot

Then press enter

Hope it helps
 
#3
Thanks. I played around with the settings and it now shows as below. Can someone confirm that this should be good to go as I don’t want to vaporize both operating systems?
What concerns me is that the Boot Drive is showing as Z when it used to point to the C drive!

Partition 1, XP = Z
Partition 2, Win 7 = C

EasyBCD settings:

Default: Windows 7
Timeout: 10 seconds
Boot Drive: Z:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: XP Pro
BCD ID: {e9934c18-942b-11de-812b-fa535dadf57a}
Drive: Z:\
Bootloader Path: \ntldr
 

Terry60

Knows where his towel is.
Staff member
#4
"boot drive" = "system" flag.
Thats's XP
Everything looks correct.
Please see point 3 of the sticky
 
#6
That worked nicely. Thanks everyone.

Is there a way to remove the drive letter assignment of the XP partition (Z) and still keep the dual boot working?
 
#7
That worked nicely. Thanks everyone.

Is there a way to remove the drive letter assignment of the XP partition (Z) and still keep the dual boot working?
Yes, I believe you can remove the drive letter in Disk Management, and it shouldn't affect the dual-boot at all. But I don't understand why you would want to...
 
#8
Yes, I believe you can remove the drive letter in Disk Management, and it shouldn't affect the dual-boot at all. But I don't understand why you would want to...
I have no need to access the XP partition from within Win7 so having it showing as a drive letter is redundant so I’d prefer to slim line the configuration.
 
#9
I have no need to access the XP partition from within Win7 so having it showing as a drive letter is redundant so I’d prefer to slim line the configuration.
Ok, well let us know if you succeed removing the drive letter or not. I've never tried removing the drive letter of a "system" partition before, but I suppose its worth a try.
 

Terry60

Knows where his towel is.
Staff member
#10
Disk Management won't let you change any partition with "system" "boot" or "page" flags.
 

Terry60

Knows where his towel is.
Staff member
#12
Weird !
I just looked (I'm 99% in W7 these days), and sure enough Disk Management hasn't greyed the option.
It's offering to let me commit suicide and reletter my OS. (full-house system/boot/page).
As you can see the documentation still says it's impossible, but someone who wrote the code has evidently forgotten to put in the self-destruct protection contained in the earlier OSs.
Be careful.
I'd class this as a W7 bug (or an "unintended feature")
 

Attachments

#13
Hi Terry,

Yes, surprising it allows you to do that.

MS limited Disk Management functions to make it hard to mess things up.

Seems that one slipped by.