Vista 64 bit + Fedora 9 , 2 HDD = not loading Fedora

6yp

New Member
#1
Hello Neosmart users!
I and to thank you for a such a nice program, Is been working with RHEL 5 + Vista very well. However now I cannot figure out why I can not load fedora 9.

I have 2 HDD
1st. - Fully Vista /dev/sda
2nd - Half Fedora 9 fresh install. /dev/sdb/

When I install fedora 9 I follow a neosmart wiki guide for fedora.
I specify Install on second drive, boot loader GRUB install on /dev/sdb(second hard drive) also I specify "First sector of boot partition" to put GRUB /dev/sdb1

Then I reload I chose Vista and Launch EasyBCD and go to the "Add/Remove Entries"
I add linux grub chose drive where is boot installed - /dev/sdb(?)

then I try to select Neogrub Linux I receive following :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant http://www.winimage.com/bootpart.html
Loading new partition
Bootsector from C.H. Hochstatter
GRUB _ (flashing)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

thats it, nothing loading any more.
I am a new linux user and try to learn, please if I need to modify in linux something explain in a simple english.
Thank you very much for your support!!!
Best regards,
6yp

Addendum:

sorry I forget to say that I have 2 hard drive SATA on laptop HP 9200 CTO
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Disable Vista's drive temporarily in the BIOS and assure you can boot Fedora. If not, re-install and verify it is working properly first. Then re-enable the Vista drive and assure it is first in the boot sequence. Add a new entry in EasyBCD for Fedora by making sure you are on the Linux tab in Add/Remove Entries, pointing to the correct disk/partition, and then checking "grub is not installed to mbr" before adding the entry.
 

6yp

New Member
#3
Hello Justin!
Thank you for trying to help me.
When I remove my 1st drive with Vista, and try to boot I have a black screen and its says: "Operating system not found ", I try to re-install Fedora 9 with only one drive available. Also I add a boot from MBR of /dev/sda (the only dive was available at the time of installation, second without vista) NOT A First Sector of boot partition. And I still receive receive a same error: "Operation system not found".

Then I add a first HDD with Vista, and boot vista, Then open EasyBCD I remove old linus, and add a new one with option "grub is not installed to mbr" here is the error I have:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
booting 'find /nst/menu.lst'

find --set -root --ignore-floppies /nst/menu/lst
(hd0,0)
filesysytem type ntfs (????? WTF????), partition type 0x7
configfile /nst/menu.lst
Turning on gate a20.. Succcess.
Starting cmain() ... find --set-root --ignore-floppies /boot/grub/menu.lst
_ (flashing)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Then I try to boot from CD and in Recsue mode, jump to my ../sysimage and execute "startx" I receive a following:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
xauth: localhost.localdomain: Host name lookup failture.
xauth: error while loading shared libraries: libxmuu.so.1 : cannot open shared object: No such a file or directory.
(same thing 3 more times)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
then I check my grub file in /boot/grub with vi editor - its empty all the file has:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
~
~
~
~
~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I dont know what to do, I re-install 3 times and it not helps, I check MD5 sum on CD - fine. I donwload it from offical frdora web site.

I think that may be its not suppose to be a (hd0,0) ??
Or for a some reason my second HDD is not set as a bootable??
Unfrtunally I CAN NOT turn it off in BIOS, and have to disconnect.

Please help me.
Tnank you!
 

JustinW

Super Moderator
Staff member
#4
Okay, make Fedora's drive first in the boot sequence in the BIOS. Boot from the Fedora live CD and select the "Check CD for Defects" option to verify the disc was burned properly. Re-install Fedora allowing it to write to the mbr of the drive you installed it to (ie. Fedora's drive). Since it is first in the boot sequence, reboot when the install prompts you to, finish the installation, and verify you can login and get to the desktop.

Run a terminal window and issue sudo gedit /boot/grub/menu.lst to open grub's configuration file in gedit with root privallages. Find the root (hdx,y) lines for the entries in the file and change x in root (hdx,y) from 0 to 1. Save the file and change back the boot sequence in the BIOS so that Vista's drive is first and Fedora's drive is second.

Then when you reboot into Vista, fire up EasyBCD and click on Add/Remove Entries. From there, click on the NeoGrub tab and uninstall NeoGrub. Delete the current entry you created for Fedora and then click on the Linux tab. Select the right disk/partition from the drop-down to point to Fedora's disk, select "Grub is not installed to mbr" and then finally add the entry. Reboot and test to verify it is working.
 

6yp

New Member
#5
Hello Justin!
I appreciate your fast reply, Unfortunately I can not make a my second drive (Fedora drive) first in BIOS, its not allowed me, I simply do not have this feature. However before I physically remove from laptop 1 st HDD with vista and Install Fedora on second, with write to MBR option.
While installation - I check CD Its been burned properly.
After this then Its restart - I found black screen with: "Operating System not found"

Also I have to tell, on 2nd HDD is 50% of the space is NTFS vista partition, and only other 50% is for Fedora - about 50 gb.
 

JustinW

Super Moderator
Staff member
#6
All BIOSes have a "Boot Sequence" or "Boot Order" section that allows you to move up/down or en/disable possible boot devices in a list. It operates in linear form, where the first device in the list is the first device the system attempts to boot from. I cannot give you specifics on this, as just about all systems are different as they have different BIOSes, but the basic features are generic.
 

6yp

New Member
#7
ADDON: I don't know how to explain this, however Then I take phisacally my first HDD (WITH VISTA) and on its place, I mount a second (with FEDORA) Manually inside on my latop. Fedora - START WITH OUT ANY PROBLEM.

Can you please explain, how is this possible???
Is any solution for this??

Addendum:
Here is my Boot order in BIOS:
USB Floppy
atapi cd/dvd rom drive
USB Diskette on Key
USB Hard Drive (tryed this one - not working)
NoteBook Hard drive
!Network Adapter

Unfortunately I can not choose witch HardDrive it will load under "Notebook hard drive"

Under diagnostic area I can see:
-Primary Hard Drive disk self test
-Secondary hard Drive disk self test

BIOS the latest for my version from 08/2008
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#8
As well as the BIOS sequence of device types you quote, there should be another section (probably on a different page), where you can change the sequence of the HDDs within the overall device sequence.
Just keep going through all the BIOS options till you locate it.
 

6yp

New Member
#9
hello Terry,
thanks for trying to helping me, unfortunately I search it all - and where is nothing to choose of HDD to load.
Please take a look on post above, then I physically change drive - Fedora start without any problem. How to configure windows boot loader on primary vista HDD in order to boot fedora then its locate on secondary drive?
 

Terry60

Knows where his towel is.
Staff member
#10
Sorry, won't attempt to help you with Fedora. I don't use Linux at all, so you know more than me.
I've never seen a BIOS that didn't allow the choice of which HDD to boot first, so can't help you any more with that, except to advise you to check with your OEM support group if they've disabled the BIOS option for their own reasons.
 

6yp

New Member
#12
I repeat post # 4 and receive following:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
find --set -root --ignore-floppies /nst/menu/lst
(hd0,0)
filesysytem type ntfs (????? WTF????), partition type 0x7
configfile /nst/menu.lst
Turning on gate a20.. Succcess.
Starting cmain() ... find --set-root --ignore-floppies /boot/grub/menu.lst
_ (flashing)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Everything is stops here, no load
 

JustinW

Super Moderator
Staff member
#13
If you followed the directions exactly, then is Fedora's disk second in the boot sequence and Vista's is first and that all of the entries in menu.lst have been changed in x on the root (hdx,y) lines from 0 to 1 since it is the second drive?

If you got it to boot correctly to edit menu.lst and then move on, go ahead and post your modified menu.lst so we can get a better idea of what might be wrong with it. You can do that either by switching back devices in the boot sequence or by booting from the live CD.
 
Last edited:

6yp

New Member
#14
Hello Justin,
Here is my /boot/grub/menu.lst
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,5)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25-14.fc9.x86_64)

root (hd0,5)
## TOP was modify to:"root (hd1,5)" like you tell in post #4

kernel /vmlinuz-2.6.25-14.fc9.x86_64 ro root=UUID=453813a4-d564-4145-86ee-9fae248ed9c7 rhgb quiet
initrd /initrd-2.6.25-14.fc9.x86_64.img
title Other
rootnoverify (hd0,4)
chainloader +1
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 

JustinW

Super Moderator
Staff member
#15
Yep... the root (hdx,y) entries need to be changed in x from 0 to 1 since it'll be the second drive in the system when chainloaded from Vista's bootloader.
 

6yp

New Member
#16
Hello Justin,
I did modify root (hdx,y) entries need to be changed in x from 0 to 1, however I receive a error in post #14
Do you mean I need to modify:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
splashimage=(hd0,5)/grub/splash.xpm.gz --> splashimage=(hd1,5)/grub/splash.xpm.gz
root (hd0,5) --> root (hd1,5)
rootnoverify (hd0,4) --> rootnoverify (hd1,4)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Because I receive post #14 error then I modify only root (hd0,5) --> root (hd1,5)
Please let me know.

thank you for your help.
 

JustinW

Super Moderator
Staff member
#17
Yes... any entry that hasn't been changed well be pointing to Vista's drive which would be bad since any files needed to boot Fedora well be on the second drive in the system.
 

6yp

New Member
#18
Hello Justin!

I just change my
/boot/grub/menu.lst

TO THIS:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,5) <-- change
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sdb <-- change
default=0
timeout=5
splashimage=(hd1,5)/grub/splash.xpm.gz <-- change
hiddenmenu
title Fedora (2.6.25-14.fc9.x86_64)

root (hd1,5) <-- change

kernel /vmlinuz-2.6.25-14.fc9.x86_64 ro root=UUID=453813a4-d564-4145-86ee-9fae248ed9c7 rhgb quiet
initrd /initrd-2.6.25-14.fc9.x86_64.img
title Other
rootnoverify (hd1,4) <-- change
chainloader +1
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

And I still receive this error:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
find --set -root --ignore-floppies /nst/menu/lst
(hd0,0)
filesysytem type ntfs (????? WTF????), partition type 0x7
configfile /nst/menu.lst
Turning on gate a20.. Succcess.
Starting cmain() ... find --set-root --ignore-floppies /boot/grub/menu.lst
_ (flashing)
~~~~~~~~~~~~~~~~~~~~~~~~~
Why on this error I have,
(hd0,0)
filesysytem type ntfs (????? WTF????), partition type 0x7
Is it not suppose to be (hd1,5) ???? In /nst/menu/lst

Please let me know what I need to do else?

thank you!
 

JustinW

Super Moderator
Staff member
#19
If 0 nor 1 worked and you have only 2 drives in the system, then it is either a problem with the way it is seeing the partitions (sometimes this is an issue though it is mainly a problem only with disks) or something hasn't been installed properly.

For troubleshooting purposes, I would go ahead and remove the hiddenmenu line from the file, so that all of the entries in menu.lst are immediately displayed in the menu without you having to arrow down to reveal it. Assuming that you have at least 5 partitions or more on fedora's disk as indicated by the entries in your menu.lst, try any combination of x,y in (hdx,y).... 0,1, 0,2, 1,1, 1,2, 1,3, etc...

Getting Linux to work is a matter of trial and error, so just be paitent and try just about anything you can think of until you get it to work. Don't be afraid to go back to post 4 either... sometimes repetition of steps is the best way to learn something that is new or confusing.
 
Last edited:

6yp

New Member
#20
Hello Justin,
Please answer,
In my error I have this:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
(hd0,0)
filesysytem type ntfs , partition type 0x7
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Is it not suppose to be (hd1,5) ???? In /nst/menu/lst

May be its not loading because, its not funding a drive??
Why I have to edit /boot/grub/menu.lst

May be I need to edit /nst/menu/lst so its not pointing on (hd0,0) and make it point to (hd1,5)???

I just want to know that I move in the right direction??
 
Last edited: