Vista Analog Speakers

#1
I just got a new machine with Vista Home Premium 32bit with SP1 and I can't figure out why it won't read my speakers when they are plugged into the lime green jack in the back and power up and work fine on my old machine. I just want to use regular speakers but cannot!

I go to Control Panel and select "Realtek HD Audio Manager" and it lists all the analog jacks and the Digital jack on the right but the analog ones all look lightened like they are disabled? http://filebox.vt.edu/users/ategenka/Vista/RealtekHDAudioManager.jpg

It appears everything is fine in Device Manager as that says it is Realtek High Definition Audio and I have tried both versions from HP and Realtek and got nothing.

My machine is HP Pavilion Media Center M8200N Desktop PC like http://www.amazon.com/Pavilion-M8200N-Desktop-Dual-Core-Processor/dp/B000VTYKRY or specs from http://www.tigerdirect.com/applicat...tails.asp?EdpNo=3581365&body=MAIN#detailspecs

Thanks for any ideas!
Andrew
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Hello,

From what i see in that picture. You have the Digital signal enabled. Not your Analog. The black circle is in the Digital area which means that signal is active not yoru Analog. Put the black dot in the Lime Green area should enable your speakers.

Cheers,
Mak
 
#3
Thanks for the tip but I actually tried that before and the problem is that those analog ones are acting like they are disabled. It will not let me click on them. And since in the screenshot "Set Default Device" is disabled as well I don't know what else I can do with that. Also, if I go to Control Panel, Sound it says my Speakers are not plugged in even though they are :frowning:
 
Last edited:

simonb

New Member
#4
Hi Andrewteg,

hum! the "set default device" is disabled??? in which case, you cannot click on the default fomat tab in the Realtek menu? if this is true, than i suspect something's up with the driver...i use Realtek driver on my HP, and i never saw this issue. What happens if you click on default fomat tab, what output is it set on please???
 
#5
Just a dropdown with a bunch of audio rates...
http://filebox.vt.edu/users/ategenka/Vista/RealtekHDAudioManagerDFtab.jpg

My driver is Realtek High Definition Audio Version 6.0.1.5502. Just saw http://h10025.www1.hp.com/ewfrf/wc/softwareList?os=2093&lc=en&cc=us&dlc=en&product=3548185 has 6.0.1.5548 so will try that next...

Addendum:

Actually HP Update popped open while I was downloading that update (irony or HP tracking?) and so I just ran that and it updated me to 6.0.1.5548 but still no luck. It is just so weird that when I right click the speaker and choose Playback it says
Speakers
Realtek High Definition Audio
Not plugged in

So of course I cannot set it to the default or anything useful. I've tried http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&cc=us&docname=c00820207&dlc=en&product=3548185 as well and gotten no luck from those ideas.
 
Last edited:

simonb

New Member
#6
Basically, at this point, you updated the drivers directly from HP and still your audio device doesn't function properly. From the jpg's you posted, it sure doesn't look like you have a speakers tab, i mean you have the digital output tab only showing and that's it. If the drivers installed are updated, the speakers tab would be able to be shown in the menu. If your laptop is OEM, i would try the HP tech support to know the exact driver that fit your package.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#7
Hello,

From the sounds of it you have compounded one set of drivers onto another which in the long run has given you a driver conflict and caused corruption along the way. Please download, install and run Driver Cleaner Pro. this will allow you to select the drivers you wish to remove and get them fully off the system. Restart the PC and then from there download and install the latest drivers available from teh Manufacturer site.

Driver Cleaner Professional download from Guru3D.com

Cheers,
Mak
 

JustinW

Super Moderator
Staff member
#8
Hello Andrewteg, lets start with the basics. Make sure that Windows volume is maxed out at a hundred with a decent volume setting for the speakers and ensure that it is not muted.

Vista can be picky whenever the audio setup changes or new drivers are installed. In order to correct the issue, sometimes you must go into vista's built in sounds configuration and reconfigure the speakers. This can be done by going to control panel and following the attached thumbnail.

1) Open "Control Panel"
2) Select "Classic View" from the options pane
3) Select "Sound" from the list of options
4) Click Speakers in the list. If there are multiple items of this title, select the one that supposedly is working
5) Click the "Configure" button
6) Use the speaker setup wizard to test and reconfigure your speakers settings

EDIT:
I read from your earlier post and the speakers option claims that the device is not plugged in. Since you cannot change settings from either settings dialog, I would uninstall your audio software/drivers and re-install them and ensure that analog is selected. If the speakers do not function after that, then the instructions I have provided you with well most likely fix any remaining problems with getting it to work.
 

Attachments

Last edited:
#9
Well I've tried these options and gotten no better response. It just does not recognize the green jack in the back. For fun, I plugged the speakers into the other jacks in the back and when I plug it into the blue (line in) jack it adds a tab for Line In to my Realtek HD Audio Manager. The rest of the 6 jacks obviously cause that tab to go away but no other tab comes up. It just won't recognize speakers. I've tried 3 pairs of working speakers, all of which work on my Dell with XP just fine.
 
#11
Thanks

Thanks Justin. I did reset my BIOS and my system to "factory defaults" as it is an HP. It has a 90 day warranty so HP has agreed to take it back and test it so I'm going to let it be their problem for now!

Thanks,
Andrew
 

Terry60

Knows where his towel is.
Staff member
#12
Let us know what they did to fix it when you get it back (if they tell you)