Vista Boot Repair Problems!

#1
I'm trying to fix the bootloader as described here: http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD

The problem is that when I enter the line "E:\boot\bootsect.exe /nt60 all /force", the system can't find the file. When I enter "dir E:\boot", the only files shown are "bootfix.bin", "bcd", boot.sdi" and two directories that look like "-" and "--". My conclusion is that the exe is not on the disk.

I downloaded the iso from this site, and I burned it using IMGBurn. Am I doing something wrong? Or does the wiki or iso have problems?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
I checked the ISO that was the first one created for the site. It doesnt have the file on there that i seen. It could be that the file is only on the actual Vista DVD. At least i didnt see it on the CD myself. I checked the Boot folder, unhide all the files and it wasnt there. So could be that this step can only be done with a Vista DVD and not the Recovery CD.
 

Terry60

Knows where his towel is.
Staff member
#3
I seem to remember some discussion a while ago that it only shipped with early Vista DVDs and not more recent ones ?
 

YSbird

New Member
#4
I have 2 earlier versions of Vista DVD's. I checked my upgrade disk and it has the bootsect.exe file on it. Haven't checked my Anytime disk yet.

Would it help if I uploaded it here?
 

JustinW

Super Moderator
Staff member
#5
The thing here is we need to take the bootsect.exe step out our wiki and make a workaround since most users going there are using the recovery disc from this site. I happen to have a Vista disc from when it first came out so I'm going to look for bootsect.exe on there when I get the chance. I already know it doesnt get installed with an install either.

Addendum:

As far as redoing the .iso or uploading, you think we could legally do that??
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
The ISO was created during the Beta of Vista SP1 when they offered the option to create a Recovery Disc. It has since been removed from Vista and there is no way to do it. I might be able to edit the ISO with ISOBuster and add the file if i can find it on one of my DVD's but that doesnt mean adding that file will work. If there are other files associated with it then it might now work.

I will have a attempt at it. But since this isnt even a Real Microsoft sanctioned item anymore. I dont see why we cant try to edit it.

Addendum:

Well i just tried to add the file. When i loaded the ISO in ImgBurn it said that the file had been externally modified and no longer valid.

Addendum:

Tried it again. This time got it to burn but when the CD tried to boot got a error:

CDBOOT: Boot Manager not found

So the CD isnt bootable anymore after adding that file through MagisICO.

If anyone has any ideas on how to get the file added with keeping the ISO the same. I am all ears.
 
Last edited:
#7
ISO Commander was one iso creation/editing program someone pointed me some time back for adding things into an existing image. But I think the problem you are running into there is the program being used to burn the image to disk not seeing it made bootable but a simple data disk.

When first going to burn GParted live cds I ran into the bootable disk problem where BurnOn's free version followed by DeepBurner were used. Lately however the free version of StarBurn has been a champ for any iso images. http://www.rocketdivision.com/download_starburn.html
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
I am using the same prgram we suggest to all our members who want to burn the disc. Which is the best way to do it. Cause if we suggest ImgBurn it should be able to be burned via ImgBurn right? :wink:

I dont think it is necessary to have to go thru and give 4 or 5 different options for burning a ISO. ImgBurn is perfectly fine. I just have to find a way to edit the ISO such that i can add that file to it and make it work.
 

mqudsi

Mostly Harmless
Staff member
#9
There's a proper way of remaking the image via the WAIK toolkit, which I used to get the x64 image out.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
Alright. Downloading the WAIK Toolkit now. See if i can get this thing working.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#12
Havent gotten the WAIK installed yet to try and get it working. Will work on it sometime tomorrow.
 
#13
Sorry for not responding at all earlier. I'm pretty much a noob at this site and forgot to set it so that when a response was made, I would get an email. As I haven't gotten any emails, i didn't realize anyone had responded. Anyway, thanks for all the work you're putting in.
 

JustinW

Super Moderator
Staff member
#15
Everyone's been busy with the holidays and such. I'm sure one of us will get it updated within the week here.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#17
No i have not forgotten. But every attempt i have made has created a coaster. I am still trying to work it out.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#18
Alright. I have accomplished this task. I have added teh file bootsec.exe to the boot folder and the ISO when burned booted. I have tried to test but for some odd reason i could not get the Command Line to change the directory to that path and stay there....

I would have tried to run the command. But i dont need to crash mu multi boot system just yet.

I will contact Guru and see if he wishes to use this new image or the old one.
 

JustinW

Super Moderator
Staff member
#19
It should actually go in x:\boot\sources since that is where command prompt opens to. If you need to access a different directory on a different drive with cd, you specify the /d switch like: cd /d c:\boot for example.
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#20
I have tried X:\Dir and i get a bunch of Windows files. Maybe cause i have Win7 on here there is the boot partition?!?

I have tried to use the cd h:\boot and it went right back to the X:\ Prompt. I have tried several variations of this as well. I did not try the dir /d option. I use cd for change directory which has always worked in teh past for me. But not this time.