Win 7 backup failure (and other issues) after new system drive installed

Terry60

Knows where his towel is.
Staff member
#21
Disk Management flags have the following meanings

"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"
 
#23
Well months later and this has finally been solved.

I continued to have no problems using the PC except for the original issues that I stated at the beginning of the thread. However, a recent set of Windows updates triggered a bad situation. After the updates were applied, the usual restart had to occur. When the restart began the bootup phase, I got the error 0xc0000428 "Windows cannot verify the digital signature of this file".

This left me in a state where I could not get past the boot manager. In the BIOS everything seemed OK except for multiple duplicate boot device entries some of which had different boot behaviour (some would try to boot into my new SSD, some appeared to try and boot using my old drive). In any case, I tried using the Windows 7 installation drive to use Startup Repair. Initially it could not do anything because it did not see an operating system installed -- even though when I tried looking for drivers to load in that screen it could see all of the drives including the one with Windows installed on it. Even bootrec /scanos returned nothing.

Later I tried disconnecting all but the Windows drive. I found using diskpart that the drive was not active as the boot drive so I set it to be so. Then, when trying the bootrec /scanos, it ended up finding an OS. I then proceeded with the other bootrec commands to try and repair the boot config. However, it still wasn't successful on bootrec /rebuildbcd (something about the device not being found or something -- can't remember now).

Finally, after some more frantic searching on the web, I stumbled upon a post that sounded quite similar to my bootup issue. I did notice that the Windows boot partition was labelled D: while the System partition was labelled C: The magic formula that fixed it then became:

> diskpart
> select vol d
> active
> exit
> bcdboot D:\Windows /s D:
> bootsect /nt60 all /mbr

After the restart and selecting the right boot device in the BIOS to boot from, I finally got Windows to start up. After setting the BIOS boot order correctly and re-attaching the rest of the drives I was able to get everything back up. And the rest of the issues at the beginning of this thread were finally corrected. (You wouldn't believe how close I was to re-installing...)

I hope this post might help others with this extremely frustrating problem.