Win7's msconfig/boot dead

#1
Hi,

I just noticed that the Boot tab on MSConfig in Win7 is totally inert. Clicking anywhere does nothing. I've never seen this before. Is it because EasyBCD took over the bootloading task?

Thanks,
p.
 

mqudsi

Mostly Harmless
Staff member
#2
Nope. EasyBCD doesn't mess with that, probably a bug in Windows - and a good reason to use EasyBCD instead :smile:
 
#3
Ok, thanks for the quick response. I'm suddenly unable to enter hibernation as well. I'm not sure it's related, but something is going on.

bw,
p.
 

mqudsi

Mostly Harmless
Staff member
#4
Try System Restore?
 
#5
That's exactly where I see this going. Suddenly I have sluggish boots, the inert msconfig boot tab, and the inability to hibernate. I checked system restore, and windows update set six restore points in the last three days. I'm unaware of any other changes, and I've tried toggling the hiberfil.sys off and back on, to no avail, so I'm reluctantly looking at rolling back the system.

p.
 

Terry60

Knows where his towel is.
Staff member
#6
That tab is inert on my W7 too. I've always assumed it's because I boot via grub4dos from a separate boot partition on a different HDD, which chains bootmgr on my W7, leaving msconfig in confusion between "system" and BIOS "boot".
Perhaps it just doesn't work any more ?
Not sure it's related to any other problem.
Have you picked up a virus ?
 

mqudsi

Mostly Harmless
Staff member
#7
I think it has something to do with the BCD being somewhere that Windows doesn't know about?

EasyBCD still prompts you to select the BCD manually, right Terry?
 
#8
Terry - All my action happens on the C drive, but I was thinking along the same lines as you. I admit I'm a bit fuzzy on what exactly is going on under the hood at boot time. I know this tab used to work, back when I was setting up the way I wanted the machine to boot via easyBCD. But I never checked it afterward.
 

Terry60

Knows where his towel is.
Staff member
#9
@CG Yes, Easy works after I point it to the BCD
 

mqudsi

Mostly Harmless
Staff member
#10
Yeah I think that's the reason.
 
#11
The plot thickens. I opened easyBCD and got an error: boot configuration data store could not be opened. Subsequently eBCD opened with no data loaded. This sounds like a need to "recreate boot files"?
 

Terry60

Knows where his towel is.
Staff member
#12
Check your "active" flag.
EasyBCD looks for the BCD on the active partition of the booted HDD.
If it's not there, it will ask you for the location. That's the normal state of affairs with my setup, but maybe you've accidentally got something awry.
Check that W7 is active, and that you are booting from that HDD.
 
#13
Let me clarify. I am booting into Win7 without problems (except sluggishness, which I suspect is unrelated). The Active flag is assigned to a 200MB System partition; Win7 comes next, with a Boot flag. The problem that brought me here is that MSConfig's Boot tab has gone inert.

Last night I ran the Win7 Restore function, and to my surprise it left the easyBCD screen intact. Then I ran easyBCD's Write MBR function, and was surprised that it did the same.

At this point I want to read up further, to understand what is happening and why that Boot tab is dead.
 

Terry60

Knows where his towel is.
Staff member
#14
Maybe putting the boot files on the hidden partition (W7's default action if you don't take control of the partitions manually when you install it) is the problem ?
Perhaps other readers of the thread can report whether that tab is inert and whether they have the BCD on the same partition as the rest of W7, and we might see a correlation (or not).
 
#15
Doesn't it seem unlikely, though, that Win7's default install would nuke the Boot tab? And I'm almost certain that this tab was working before I began changing things.
 

Terry60

Knows where his towel is.
Staff member
#16
Law of unintended consequences, perhaps ?
It's always been a dead tab in my configuration.
Maybe the team that wrote the "lets hide the boot in case someone wants to use bitlocker !" code failed to communicate with the "msconfig" author(s).
Windows gets bigger and more convoluted with every release, and the potential for such problems increases exponentially.
Maybe if we get some feedback posts from other "dead-tab" users we can debug it for them.
 
#17
I'm beginning to think that some process has frozen the BCD. Using easyBCD I have gone through Write MBR, Reset MBR, and Recreate MBR, and I'm still getting the original boot screen I fashioned with easy several weeks ago. That is precisely what I should have reset, correct? I'm getting successful notices after each operation, and I'm logged on as an admin. I'm glad I can boot into Win7, but I'm baffled at this point.

BTW, a point of terminology. Isn't all this BCD stuff in reference to the PBR rather than the MBR?
 

Terry60

Knows where his towel is.
Staff member
#18
It sounds like the BCD you're operating on, and the one that's actually in use aren't the same.
Check whether you've got a \boot\BCD on C. (the one in the hidden partition should be the one in use - you'll need to give it a letter to navigate to it via the Explorer dialogue box. Which one has the "system" flag ?)
 
Last edited:
#19
That may be, and the one in use was lifted from the one I installed via easyBCD. I took your suggestion and looked into the system partition, and there was a \boot\bcd file. But there also were other rather ominous things, such as EASUSLD.LDR, which looks like some kind of loader. I've used Easesus on this machine, but I don't recall what for exactly.

Also odd is the name this newly-revealed partition came up with: Microsoft Office Click-to-Run 2010 (Protected).

I've now tried the Win7 recovery disk, using the BootRec commands, and they too did not affect my existing boot screen. When they say Protected, they mean protected. Next up is the BootSec command.

Addendum:

BootSec is unrecognized in the Recovery environment, even when I navigate to it in the easyBCD folder. Next stop, easeus, to see what it has done.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#20
The inert msconfig tab is caused by the same thing that makes EasyBCD ask you to find the BCD location.

It means someone or something changed your active partition. And most likely, the BCD bootloader is *not* first in the boot sequence, because if it were, it wouldn't be able to find the BCD registry.

Addendum:

OK, I hadn't seen your updated post. Sounds like this "thing" I'm referring to is your EASUS file. Are you sure you spelled that right, because it turns up literally zero results on Google.
 
Last edited: