Windows 7 Repair Disc

#1
I'm not great with computers but so far managed to download/burn your Windows 7 repair disc as my laptop won't boot. Everything goes fine til the end when startup fails :frowning: apparently the registry is corrupt.

Can anyone suggest anything please?

Thanks

Karyn
 

Terry60

Knows where his towel is.
Staff member
#2
Can you F8 at power-up and reach the extended boot menu ?
If so, try safe-mode and system restore to a point before the problem started.
If you can't get to the F8 menu, the W7 repair disk should offer you the same facility to access system restore.
 
#3
thanks for the prompt reply, tried F8, won't start in safe mode, if I try safe mode with command prompt screen freezes. Recovery mode/repair mode doesn't work either.
 

mqudsi

Mostly Harmless
Staff member
#4
I'm not sure I understand your initial post.

Did you mean that everything goes fine when booting the recovery cd until the startup fails? Or were you talking about normal startup on your laptop?
 
#5
sorry, no my laptop won't boot at all. When powered up it goes to Windows Error Recovery screen, selected Launch Startup Repair but it fails so tried loading W7 repair disc which seems to run fine but fails at the end as registry is corrupt?
 

Terry60

Knows where his towel is.
Staff member
#6
The repair disk boots into an OS independent of your broken PC. The state of its registry shouldn't be an issue.
Are you sure you're booting the CD ?
Do you see a "press any key to boot from CD" message as you power-up with the CD in the tray ?
If not, you need to change the BIOS boot sequence to put CD before HDD.
 
#7
I changed the BIOS to boot from CD, repair disc loads and goes through system recovery options, select keyboard input method etc, I selected " Use recovery tools......". The next screen states " Your computer was unable to start Startup Repair is checking your system for problems" it then attempts repairs without success.

Hopefully you can understand my ramblings lol
 

Terry60

Knows where his towel is.
Staff member
#8
Try booting the CD > "repair your computer", but then instead of "startup repair", enter the "command prompt" option.
From there, run chkdsk /r against your broken OS. It will take a long time to run, but might fix HDD errors which could be causing your problem.
If you can't get past this, then we'll advise on how you can rescue your personal files from the PC before you resort to an OEM "factory reset".
 
#9
Tried running chkdsk/r and got message

" The type of the file system is NTFS.
Cannot lock current drive.
Windows cannot run disk checking on this volume because it is write protected"

Karyn
 

Terry60

Knows where his towel is.
Staff member
#10
Follow the syntax in the link and include the letter of your broken OS partition as the repair disk sees it.
Just putting /r with no address parameter will make the repair disk try to repair itself instead of the broken system, hence the "no-can-do" message.
 

mqudsi

Mostly Harmless
Staff member
#11
Terry means type in something like:
Code:
chkdsk /r C:
But you may need to change "C:" with a different letter. But it's most likely C:
 
#12
thanks, did say I wasn't very good lol, right the result of chkdsk/r C:

process goes through stages 1 to 5 and finishes with " Windows has checked the file system and found no problems" at the very end of the message after breaking down disk space it says "Failed to transfer logged messages to the event log with status 50"

I do appreciate all the help you're giving, thanks

Karyn
 

Terry60

Knows where his towel is.
Staff member
#13
Have you tried booting the repair CD, then "repair your computer, then "startup repair" three times ?
(It might have several things to fix and only does one per pass)
What exactly happens when you try to boot (error message / stop code / etc) ?
 
#14
Tried booting repair CD 3 plus times but still no joy.
When I try to boot without CD Windows Error Recovery screen appears with option to launch startup repair (recommended) or start windows normally.
Next screen is Windows Boot Manager which advises:
Windows has encountered a problem communicating with a device connected to your computer.
This error can be caused by unplugging a removable storage device such as an external usb drive while the device is in use, or by faulty hardware such as a hard drive or CD RM drive that is failing. Make sure any removable storage is properly connected and then restart your computer.
Status: 0xc00000e9
Info: An unexpected I/O error has occurred
 

Terry60

Knows where his towel is.
Staff member
#15
If the "startup repair" won't fix the problem, even after multiple runs, try moving on to the manual steps in these instructions.
 
#16
thanks Terry, you're being extremely patient!
I've followed instructions but whichever letter I used for CD/DVD drive I can't get any further. I thought drive was D drive but I get message "The system cannot find the path specified", have also tried using E too. Looks like I'm going to have to give up and take into local repair shop:frowning:
 

Terry60

Knows where his towel is.
Staff member
#17
From command prompt use the "dir" command
dir c:
dir d:
.....
dir z:
until you find what you're looking for.
You'll be able to work out what letters the recovery environment is associating with all your devices by seeing the contents.
 
#18
according to "System recovery options" D is definitely CD/DVD drive. I enter "bootrec.exe /fixmbr" and response is "The operation completed successfully"
I then enter "D:\bootsect.exe /nt60 all /force" and the response is "D:\bootsect.exe is not recognized as an internal or external command, operable program or batch file"
I'm obviously doing something wrong.
 

Terry60

Knows where his towel is.
Staff member
#19
bootsect isn't on our CD (MS stopped including it). It's mentioned in the instructions where to find a copy.
 
#20
Recovery Disk for Windows 7

do we need to extract the files and burn them on one DVD/CD or just use imageburn and burn the Zip file?
ok, I burned the file without opening anything and it is loading recovery..
answered my own question.
 
Last edited: