WinXP to Win7 lost dual boot

khits

New Member
#1
I just custom installed Win7 over what was a Win XP partition. I had a previous dual boot of WinXP and Win XP on a seperate partition, same drive for audio recording reasons. After installing Win7 I no longer had the choice of dual booting any longer. I tried BCD 2.0 with the instructions you've given others and got the initial " fail, harware or software must've changed...yada yada... Tried ur remedy for that( delete re add let it configure itself etc. I then had the choice of the two oS's but if I chose XP it would just reboot to the dual boot screen again. I then chose Win7 from the boot screen and was greeted with a notice saying Win7 had to be repaired. I eventually had to reinstall Win7. Any ideas of what I can do to remedy this situation? I am running Win7 64bit, the XP installation is 32bit. Thanks for any help in advance.
 

JustinW

Super Moderator
Staff member
#2
Post the contents of boot.ini with Tools > Edit Legacy Entries after you've let EasyBCD autoconfigure XP's boot files as well as a screenshot of disk management.
 

khits

New Member
#3
Thanks no Boot.ini

So perhaps the problem is there is no longer a boot.ini file. I tried to use the tools but it says easyBCD can not find Boot.ini. I tried to repair the Boot.ini file with the XP disk but it couldn't do it. I then manually created one and put it in the root drive etc. I was able to have the option to choose dual boot now, but if I choose XP it comes back with "missing or corrupt ntoskrnl.exe file" The file is there so maybe it's corrupt or perhaps I have the rdisk and partition numbers wrong? In disk manager my C drive is disk 1 (not 0) and the partion for XP is the second partion on that drive.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Did W7 install with an unlettered "system" partition ?
If so, give it a letter and delete/add the XP entry again.
 

khits

New Member
#5
No...it installed with a letter for every drive. If I post a screen shot of Disk manager could you tell me what number my drive and partition should be in Boot.ini?
 

Terry60

Knows where his towel is.
Staff member
#6
By all means post DM and "display settings" info as detailed at the end of the sticky
 

khits

New Member
#7
Disk Manager shots etc

Thanks,Hope this helps. The drive with XP on it is the E: DAW drive.

View Settings text:
There are a total of 2 entries listed in the bootloader.
Default: Windows 7
Timeout: 30 seconds.
Boot Drive: C:\
Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: Microsoft Windows XP
BCD ID: {d15f14b9-f756-11de-93a2-f1ff632141e5}
Drive: C:\
Bootloader Path: \NTLDR

DM Capture.JPG
 

Terry60

Knows where his towel is.
Staff member
#8
Put the W7 drive first in the BIOS boot sequence, boot W7 then use EasyBCD 2.0 to delete/add the XP entry again and let it auto-configure.
The only reason I can see why this might not have worked before is that you appear to have the wrong HDD at the top of your boot sequence (it has no active partition, so will move on to the next HDD, booting succcessfully but possibly confusing Easy2)

(Note to CG - would this make auto-configure choose the wrong location to copy the XP files ?)

The reason why Easy2 auto-configures for you is because of the difficulty (given the info available in Windows to the user) of telling either the rdisk or the partition number for boot.ini. Vista and W7 don't necessarily display disk numbers the same as the BIOS (the source for boot.ini) and the order of the partitions on the HDD doesn't necessarily match the boot.ini partition numbers, (which come from the MBR partition table). Because you and I can't see that information, Easy2 digs deep and locates it for you.
 
Last edited:

khits

New Member
#9
Well here's the thing, the W7 drive is the first drive in my bios boot sequence already. I'm not sure why the other drive is listed first but it's not even an option in my boot up sequence, in fact none of the other hard drives are. The E:grinning:AW is a partition on the main drive. Is the fact that there is no Boot.ini in that root drive a factor. In my bios the boot drive is actually the first drive listed in my sata devices, so would that make it drive 0 even tho in DM it's shown second in order?
 

Terry60

Knows where his towel is.
Staff member
#10
There was a problem with Vista DM displaying IDE drives before SATA even when SATA was booted first. W7 "fixed" it supposedly (by always displaying IDE last, which can be equally confusing if you happen to be booting from IDE)
However if W7 is showing a SATA drive as disk 0 ahead of another SATA drive containing your OS, I don't know of any other explanation than your BIOS boot sequence is not what you think it is.
If they're same-make HDDs, they can be difficult to distinguish in the BIOS.
Remember the SATA channel used for connection has no effect on the boot sequence, and that the boot section of the BIOS is a tree structure on modern chipsets, the top level being the precedence of device types (floppy/CD/HDD), then a branch for each type defining the order within those types.
 

khits

New Member
#11
Finally...

OK, Wanna say thanks to those who tried to help. In reply to ur last post Terry, it's interesting to note that before I attempted this install of W7 "partion magic" displayed my drives in proper order ie: C drive was always listed first in Win XP. I changed no hardware for this install. I checked the order once again in my Bios to make sure I wasn't on crack and the C: drive is listed first not the drive showing up first in DM. Sooooo, here's what I did. First, since there was no Boot.ini I created one with the tips from a page on here, which is what I tried a few days ago and got the "missing ntoskrnl.exe" message. I found out that that could be from the Boot.ini pointing to the wrong drive. So even tho DM listed the drives in the order in the screenshot, I went back and changed the drive number in Boot.INI to 0 and redid Easy BCD and viola...got my dual boot back. I still have no idea why it is listing the order wrong in DM. I even cracked my case open looked inside and can see that the C drive is in fact hooked up to the first SATA connection which is for "Boot Drives". It may be confused as the second drive on SATA2 which is for boot drives as well is the one showing up first in DM. All other drives are slaves and every device I have is SATA.
Either way I'm up and running again and I appreciate ur help and attempts at solving this.
 

Terry60

Knows where his towel is.
Staff member
#12
The BIOS will list the drives in the SATA channel order in the "connected hardware" section. As I said before, that has nothing to do with the boot sequence (I boot from SATA 4). The boot sequence of the HDDs will be in the HDD subsection of the "boot" section of the BIOS.
Where did you find the boot.ini that you edited ? Where had Easy2 put it ?
Can you copy/paste it here so we can see if it was created by Easy2
 

khits

New Member
#13
Well on my motherboard the SATA connections have everything to do with boot order as stated in the manual. Sata 1and 2 are for boot drives only. In the Sata order listing in my bios the drive listed as C drive is listed first in sequence as verified by the drive model number etc. The Boot.ini was completely missing I had to creat one from scratch and put it in my root dir. Whenever I used EasyBCD I never saw a boot.ini show up in the root drive. I've searched other drives and can't seem to find where it put it if indeed one was created.

Here's what I created....
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP Professional" /fastdetect

My MB is an ASUS P5KC. In my bios the only hard drive listed in the "Boot sequence" section is my C drive.... none of the others even show up as being able to boot from.
Either way it is working now. Thanks.
 

Terry60

Knows where his towel is.
Staff member
#14
That section only applies if you're using your SATA HDDs in IDE mode. The old concept of master/slave and jumpering drives doesn't apply any more in SATA mode.
If you use the down arrow to highlight your HDD line in the BIOS boot section, then right arrow, don't all the drives show up then ?
(My mobo is ASUS too, but MN2E-SLI for AMD Socket AM2, so it has a Pheonix BIOS Setup, which looks slightly different)

Forgive me going on and on, now your system is doing what you want, but every clue we can get to analyze those occasions when Easy2 fails to do what it succeeds in doing for 99% of users will be useful in helping the Beta into release status.
 

Attachments

Last edited:

khits

New Member
#15
I don't mind continuing this, if it helps you out at all. In my bios there is a hard drive list, which correctly shows my "C" drive as being first in that list etc. Then in the boot up device order section I can select between my DVD drive, Hard drive etc. I do not have the option of any other hard drives thru any type of selection. My "C" drive is the only drive in that boot device list. To be clear my "C" drive is listed as "St330620AS" it's model number, not as "C"drive. Hope this helps. Do you know of any good Win7 setup/optimization sites?