XP & Win7 Dual Boot - Stymied



Back Ground:
1) Now have TWO OS's installed on my 1st SATA HD : "C:\1st partition XP" & "C:\2nd partition Win7"...... of which each OS was installed while the other was "hidden".

2) After 2), discovering your fine boot manager on the 'Windows Seven' and other forums, I have tried installing both v1.72 & your latest on my "XP" partition AFTER unhiding the "Win7" partition, which now carries a drive letter assignment of 'M:\'.

Despite trying to follow instructions to set up boot XP & adding Win 7 etc, EasyBCD / BootLoader Screen is not apparently active / not showing up even after several XP reboots......XP just continues to reboot 'normally'.

If it's of any help, following is my XP boot.ini file which I assume should of showed the addition of "Win 7" after I ran EasyBCD but does not.

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

1 - Would appreciate your help to get BCD up & working.

2- When EasyBCD is up & running, does it automatically "hide" Win7 from the XP partition & visa versa as other previous boot manager do?


Stan :smile:
Last edited:
Hi Stan ,

It works the other way round

Add XP to the 7 boot menu.

It's no good adding 7 to XP boot.ini. NTLDR cannot load win7.

The idea is to reinstall 7 bootloader ( says Vista - it means the same thing).

Then Add XP to 7 bootmenu.
Hi Stan, welcome to NST.
The MBR on the HDD will look on the "active" primary partition boot sector.
Presumably you installed XP last, and its version of the MBR (which looks for NTLDR) is sucessfully finding it on the 1st partition (which I assume is "active").
NTLDR cannot boot newer OSs than XP. First you need to set the W7 partition "active", then repair the boot process, by booting your W7 DVD and selecting "repair your computer" then "startup repair" as many times as necessary to reinstate W7 as the controlling system.

Then install EasyBCD 2.0 latest build on W7 and add an entry for XP, accepting the offer to auto configure the XP dual boot for you.

Don't worry that XP is calling W7 M:\. Each system has its own internal map of disk letters. They won't match except by accident or if you shuffle the letters yourself in Disk Management. (except for the "system" "boot" and "page" partition(s) which cannot be changed)


Hi Simon, sorry for the identical post. I'll have to type faster.
Last edited:
Hi Terry & SIW2,

Thanks for the FAST!!! help!

1) After further rebooting between the XP vs Win7 partitions, indeed the BCD boot screen did finally show up.

When it did, I selected "XP" and XP booted up just fine . Unfortunately, when I rebooted & got the BCD boot screen again & selected "Win7".........it tried and failed just as you predicted / explained above.

2) Despite plenty of 'excellent' info & pic's at NST & Windows Seven forums, I loaded Easy BCD v1.72 & v2.x beta on my "XP" partition.

Question: In hindsight, I readily accept that 'XP', even with EZBCD cannot handle / boot a "later/newer" OS like Vista or Win7. Did I miss just such a warning within EZ BCD guide(s)?

3) I'll now set about removing EZBCD from the XP sector and reinstall it onto the Win7 sector and report the results.


Stan :lup:

You're getting EZBCD confused with the Windows bootloaders bootmgr/ntldr. Its a Windows configuration utility primarly for Vista/W7's bootloader bootmgr which uses what is called a BCD store to perserve settings. It itself isn't responsible for booting the system or making XP's bootloader capable of loading Windows 7.

With the latest build of EasyBCD you should be able to install a mbr that well work with Windows 7 though using the bootloader management page, or what I would recommend is just booting from your Windows 7 DVD and performing startup repair 2-3 times until its booting. If you read over Terry's last post he goes into some great detail as to what you need to do. We've also got an article in the wiki describing the process.
Hi Sylver,

If you can boot into XP , but not 7 ( because you installed XP after7):

Boot the 7 dvd and run startup repair 3 times.

Boot into 7 . Install Easybcd v2.0.

Click Add/Remove Entries.

Under the Windows Tab - in the "Type" dropdown , select "Windows NT/2K/XP/2K3".

Type the name you want e.g. XP Pro

Click Add Entry.


Hope it helps
Last edited:
No, no, no. Actually, is the other way around. Windows 7 is newer, so I installed it after XP. I can boot into 7, but not in to XP.
Previously, I was using a dual boot between XP x64 and XP x86 and it was working just fine. After I have installed Windows 7 instead of the 64-bit edition of XP, the boot screen is gone.
I have found some answear on the internet, but all seem to hard for me. And I understand that if I make some mistakes in changing BOOT.ini or whatever, I will not be able to boot into 7 anymore, wich would pretty much suck.
I have installed EasyBCD 2.0, but it isnțt that easy. It detects Windows 7, but no XP.

As you are already in 7, obviously you only need to do this:

Click Add/Remove Entries.

Under the Windows Tab - in the "Type" dropdown , select "Windows NT/2K/XP/2K3".

Type the name you want e.g. XP

Click Add Entry.
Which is the partition containing the XP boot files - ntldr, ntdetect.com and boot.ini.?

That is the partition you need to point the bcd entry at.

If you installed 7 where the first installation of XP was ( C is the first partition and D is the second , I assume) - then you won't have them any more. They would have been on the Active partition.

Download this .zip , extract it and copy&paste the 3 files ( not the folder) directly on the C partition.

View attachment xpbootfiles_rdisk(0)part(2).zip

Then add the entry with Easybcd.
Last edited:
Don't change the drive letter for XP.
Just trust EasyBCD 2.0.
Add an entry for XP, don't try to change anything - it's pointing to the right place.
Accept the offer to auto-configure and it will put all the XP boot files in the right place for you.

(the BCD doesn't point to XP. It points to copies of the XP boot files. They point to XP).
EasyBCD 2.0 does it all for you.