Advanced Setting Question

LunaEros

Member
I'm trying to move my system to a new drive for 2-3 weeks. I'm at the point where I'm booting in UEFI to the new 8tb GPT drive. The new drive has both the system and boot files but it's booting with the system bootloader on the new drive but reading the boot OS files from the old MBR drive and I can't seem to get everything to work from the new drive.

I see on the EasyBCD Advanced section that I can apparently change where the bootloader reads the OS files from the old to the new drive but I'm concerned that maybe this isn't what that setting does and will leave the system unbootable and I won't be able to fix it.
Is that what that setting does and how could I fix it if it makes it unbootable?
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Can you post a screenshot of your Disk Management and the contents of EasyBCD "view settings" (detailed mode)
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
What you've somehow contrived is to boot the OS on C from a BCD on H, the opposite of what you thought was happening.

Disk Management flags have the following meanings

"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"

On GPT there is no "active" flag and an EFI boot will just look for the EFI System Partition, but you've somehow booted from H.
Is that a clone of C ?
If so the BCD on H will actually still be pointing at C because there are no letters in the BCD, only UIDs which are a hash of the unique serial number of the device and the cylinder offset of the partition start, so booting from H will actually load the OS on C. EasyBCD lets you interact with it using letters by translating in each direction from the registry's device map which links UIDs with letters, which are either user specified (using Disk Management) or dynamically assigned at boot time.
The BCD you posted shows that you are telling the BCD on the EFI System partition to boot from C, though Disk Management implies that you're not actually booting from the EFI partition anyway.
Is there a /boot/BCD in the root of H (you'll need folder options set thus
to be able to see it.
If there is, that's where the PC is being told to start the boot process.
How have you set the boot in your BIOS.
Are you booting in compatibility mode ?
 

LunaEros

Member
There's a boot folder on H but no BCD under it.
The bios is set for UEFI at the moment if that's what you mean. The only other option in that is UEFI+LEGACY
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Add an entry to the BCD pointing to H. Give it a name that distinguishes it from the copy on C
Boot and choose the new entry
Check that Disk Management now shows the GPT copy as "boot" to confirm that you're successfully on your cloned copy.
It will probably now show as "C", bearing in mind what I said before
EasyBCD lets you interact with it using letters by translating in each direction from the registry's device map which links UIDs with letters, which are either user specified (using Disk Management) or dynamically assigned at boot time.
and the copy on the old HDD will have some other letter (EasyBCD is translating from a different map on a different OS,)
You can then remove the entry for the old OS if you wish.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
That would seem to confirm my initial diagnosis that the BCD details you posted are not from the BCD actually being used to boot your system.
Check that you don't have something specified in EasyBCD > Tools > Options > "Automatically load ..." that's forcing EasyBCD to look at the wrong BCD.
In File > Select BCD store, point it at C which the "system" flag is indicating as the location of the BCD actually being used, then repeat the drill from post #6
 
Top