Bitlocker Redux

Ex_Brit

If you're going through hell, keep going.
Staff member
#1
Here we go again. I've got myself a new U3 USB flash drive and this time the BIOS does recognize it as a hard drive.
My first question is do I have to set it as the 1st boot device or just any boot device - 2nd or 3rd? If I do then I have to make it the first hard drive (or 2nd I guess...going from memory here) ?? Otherwise it doesn't appear in the boot device priority list.
I just tried making it the 1st boot device and the system hung at a black screen with a blinking cursor and wouldn't budge. So I had to go back into the BIOS and remove it from the boot device priority list (1-2-3).
Bitlocker still wont start because I'm screwing this up royally.

CG you have the same M/B so what settings do I need in...
a) Hard drive list - make it the 1st or 2nd rather than the 3rd?
b) Boot Priority - make it the 1st or does that matter?
Previously it read 1st - floppy 2nd - my C: (XP) drive and 3rd CD/DVD.
I think even that is in the wrong order. It used to be (I think) 1st Floppy, 2nd CD/DVD and 3rd C: (HD0)

I have a feeling that this time it's going to work if only I can get the darn BIOS set properly.

Had to post through Firefox again...IE7 gives the same errors I emailed you about and it happens only with this one site.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Peter, try running ccleaner and see if that fixes the problem? I think maybe your clear cache isn't even working from within IE7? (I'm using IE7 right now myself...)

I think you need to set your vista drive as primary, boot and install bitlocker, setup your flash drive, then reboot and set the flash as the primary for it to work.

But I'm not sure :smile:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#3
Just let ccleaner clean everything....still no go in IE7, sorry. Posting from FF (which I loathe and detest by the way, unlike most other people...LOL). Your avatar has vanished, in FF anyway.

I'll fiddle with my boot. There is very little help on the internet regarding this.....loads if you have a TPM enabled motherboard, naturally.
My XP holds the boot sector though....this is why I get totally bamboozled with all this.
 
Last edited:

Ex_Brit

If you're going through hell, keep going.
Staff member
#4
P.S. CG I tried IE7 in both my XP's and although I can reach the main page OK as before, I can't get any further than that - same error. So it's happening in all 3 systems.
 

mqudsi

Mostly Harmless
Staff member
#5
Try it again now, maybe?
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#6
Can only access it via FF, sorry. Tried CCleaner again too, made no difference.

re: Bitlocker...I just realised it isn't going to work as on my M/B at least there is only a place for 1 of the hard drives in the boot priority list & drive 0 will always HAVE to be there because it has the bootsector. The other two are floppy and a CD drive.
 

mqudsi

Mostly Harmless
Staff member
#7
Try it - you never know.
The BIOS will load the top-priority drive. But that drive can then load whatever drive it wants. Maybe that's what MS made it do, I do not know.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#8
There are going to be many aborted boots in the next few days...I can tell!! I've already tried every which way. The boot sequence can only have 1 hard drive so that has to be HD0 so all my carefully laid out plans (not to mention money) have gone to waste I fear.

Now, if only I could access this particular website using IE7.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#9
Are 3 Windows Systems on the same physical machine?
 

mqudsi

Mostly Harmless
Staff member
#10
It seems there was some sort of weird glitch that only you could see!
Your hint about the avatar led me to it - can you use IE7 now?
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#11
Hearing you loud and clear CG in IE7 no less...LOL So it wasn't my fault! I was going crazy here!!!!
HD0 partition 0 has XP Pro # 1 which also houses all the bootsector, partition 1 houses XP Pro # 2
HD1 has Vista on partition 0

The USB key shows as HD3

There's a pic here, just linked because it's full screen: http://img261.imageshack.us/my.php?image=cm1wp3.jpg
 
Last edited:

Ex_Brit

If you're going through hell, keep going.
Staff member
#12
...this is what happens right now....
 

Attachments

mqudsi

Mostly Harmless
Staff member
#13
I don't know - from what I can see around the net, you should have been prompted insert a USB Drive to store the password on when Vista realized you don't have TPM....

Really glad to hear the IE7 thing is working - I have to say, in all my years of PC use/testing/troubleshooting, I've never seen a server-side component (the database) fail because of choice of browser.... and only for a single user at that! Just glad it's working now :smile:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#14
The key and password were stored on the USB key (plus backed up elsewhere) by the wizard which then prompts to restart...then it can't read the key. I checked and the key is powered right from the start of the boot.
I'm using one of my front USB2.0 ports. I could try the rear I guess. Some people seem to think they are better as they are more directly connected to the motherboard....logically that makes no sense to me.
I'll keep bashing at it.
I've yet to find anyone who has got it to work. Tried posting for help on the Vista M$ newsgroups....no answer.

Yes that IE7 thing was very weird.
 

mqudsi

Mostly Harmless
Staff member
#15
Did you try to set the USB disk as the first boot device? No harm in giving it a shot :wink:

(and, you are right, it doesn't make a difference if you use front or rear - both are connected through cabling anyway, just one uses a shorter - and hidden - cable while the others' is longer and visible :grinning:)
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#16
That's what I tried yesterday and all I got at boot was a black screen with a blinking cursor.

The D865GBF allows 3 devices in the boot priority section. 1 Floppy (no other choice there except disable), 1 CDROM and 1 HD.
So if I make the U3 the primary HD then the BIOS doesn't read my actual HD's and can't find the boot sector because it's been told to look for it on the USB drive.

I can't find anywhere on the web that says the USB has to be made the boot device, only that it has to be seen by the BIOS and that USB boot be enabled, which it is.

Looks like I'm stymied.

Yes I tried the rear slots - no difference.
 

mqudsi

Mostly Harmless
Staff member
#17
I honestly don't know - and you say you asked in the NGs as well to no effect?

Tell you what, the next time I have Vista on this machine I'll see what I can do. (Same mobo, ancient 128MB USB drive).

I've never seen a mobo that allows you to set two drives as top priority, so I doubt that's the problem :smile:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#18
Thanks. I've posted again on M$ groups. I don't expect any joy though. I guess I need a new M/B - but I'm afraid replacing a M/B and processor is beyond my capabilities. It'll will have to wait until this rig explodes and I have the money - whichever comes first...LOL
:tongueout:
 

mqudsi

Mostly Harmless
Staff member
#19
I was under the impression that even most new motherboards didn't ship with TPM - it's a controversial technology that is used more for DRM than for encrypting data.

However, it is the most powerful way to ensure that no one can clone your HD, mount it on another PC, then crack it with a stolen "key" they way they can with other HD encryption techniques like those used by PGP.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#20
Maybe - I haven't really read up that much about it. Thanks for the input anyway.