Can't boot recovery partition

#1
Hi, I'm having a bit of an unusual problem. My brother has an Asus laptop with Windows 7. He installed Linux on the second partition which in turn installed grub so he could dual boot.

In the grub menu there was 2 choices for windows, one for the recovery partition and one for the main windows install.

He decided he wanted to remove linux and grub and accidentally ran the auto fix startup problems in the Windows 7 recovery options. Anyways after this, both options in grub now both startup the main Windows install instead of one for recovery and one for main install.

I was able to remove linux and grub and get everything working back to normal again except for one small issue. I can access the limited recovery options (F8 "repair PC") when I boot Windows on the partition but the option to boot from recovery partition (F9) to do a complete reinstall is not there.

I ran super grub and was able to boot the recovery partition but again it just boots the main Windows install on C:.

He didn't make any recovery backups but the laptop did come with a recovery DVD. I reinstalled windows using that and it worked fine except the recovery boot option was still missing and now the recovery partition is no longer hidden and is visble in Windows and has been assigned a drive letter (e).

I opened up Computer Management and see that the recovery partition is also not set as active. I am assuming this is my problem. I checked the files on the recovery partition and nothing has been altered at all.

If I just make this partition active and hide it again, and reboot, do you think this will solve my problem? Also should I change the drive letter to X:?

I would really appreciate the help, I know this issue isn't directly related to BCD, but I figured if anyone would know the answer it would be here.

Thanks
 
#2
Hi Shogun, welcome to NST.
First of all, we (all the regulars, that is) read ALL the new posts no matter where its posted (the "New Posts" feature at the top of the page helps us with this), so posting it here under "EasyBCD Support" does not make your post get answered any quicker, just FYI. Again, we all read all the posts, and we'll reply if we have something to say.
Second, do NOT change the "active" flag as this will render your system completely unbootable, until you change it back to where it was originally pointed. The MBR finds the boot files through the "active" flag, and so if you change it, it'll be lying and telling the system the boot files are "here" when its really "there". :wink:
Third, most likely your recovery partition could only be accessed previously by the custom MBR factory-installed by the OEM. Since you obviously replaced this with first Grub, and then the standard Windows MBR, this feature can no longer be accessed, unfortunately. I know...this sucks. Believe me, I know since I had the same problem. But you just got to live with it, since the recovery partition feature was not designed with the user's best interests at heart. And, anyway, if your laptop came with a recovery DVD, you should be able to use that to achieve what the recovery partition feature offered (a reset to factory-condition).
 
#3
Thanks for the quick response Coolname007. I realized there was more appropriate forum on the board to post this after i had posted. Sorry about that.

I know I can reinstall back to factory pretty much with the DVD,s. It just would have been nice to have the the recovery working from the partition. I thought this was doable because i have seen other posts on other forums where people had similar situations.

Usually they installed Win 7 on there Vista laptops and lost the ability like me to boot the recovery partition. Some of them used a Hiren Live CD to set the recovery partition to active and then reboot. A few said that this was successful and that they were able to reinstall from the recovery partiton after rebooting and that the reinstall fixed everything back to factory including the MBR.

I'm sure there is more to it that I don't fully understand, so I will just take your word for it :grinning:. Thanks a lot for taking the time to help, I know you didn't have to.
 

Terry60

Knows where his towel is.
Staff member
#4
There is a post somewhere, which you might be able to locate with an assiduous search, where a user described accessing the recovery facility (on a Dell I think) after the OEM custom extended boot menu had been overwritten in this way.
 
#5

Terry60

Knows where his towel is.
Staff member
#6
No, that's not it.
He (or his wife) just managed to locate the OEM disk(s) they though had been lost, so the recovery was still a standard OEM "factory reset" from the disk rather than the partition.
The one I'm thinking of was a post from a casual visitor explaining how to access manually, the program which gets executed when you use the OEM extended boot recovery menu.
 
#7
But that thread did point out something useful:

Not all OEMs allow access to the recovery partition through a customized MBR. Apparently, the computer the person in that thread used, accessed it through a special entry in the BCD (I've been reading up on the same thing, btw, since a few days ago in a Vista whitepaper downloadble from this link). EDIT: Nevermind. Lost the link, but downloaded the file itself, so I'll just upload the file. Here it is (see attachment).

@ shogun: Its possible your recovery partition can be accessed the same way too, if you add a customized BCD entry like the one in that thread.
 

Attachments

Last edited:
#8
Thanks for the help! I don't see anything in this about the recovery partition unfortunately.


Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {8cb2d9b1-7c05-11de-842e-b4611d44fefa}
resumeobject            {8cb2d9b0-7c05-11de-842e-b4611d44fefa}
displayorder            {8cb2d9b1-7c05-11de-842e-b4611d44fefa}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30

Windows Boot Loader
-------------------
identifier              {8cb2d9b1-7c05-11de-842e-b4611d44fefa}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence        {8cb2d9b4-7c05-11de-842e-b4611d44fefa}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {8cb2d9b0-7c05-11de-842e-b4611d44fefa}
nx                      OptIn
 
#9
Is there a /sources/boot.wim in your "system" or in your "boot" partition according to Disk Management?
 
Last edited:
#10
Also i can fully access the recovery partition files if that helps. There is a bcd file in a folder /microsoft/boot/ on the recovery partition as well as some other boot files on /
 
#11
See post above yours.
 
#12
There is a /sources/boot.wim on the recovery partition. I dont know how to check if there's one on the system partition using disk management

Addendum:

Also i just searched my system drive and there is no boot.wim on it so it's just the recovery partition that has it.
 
Last edited:
#13
Ok, good.

Run the following commands from EasyBCD's Useful Utilities->Power Console:
Code:
[B]bcdedit /create {ramdiskoptions} /d "Ramdisk options"
bcdedit /set {ramdiskoptions} ramdisksdidevice partition=[/B][I]Recovery partition drive letter
[/I][B]bcdedit /set {ramdiskoptions} ramdisksdipath \boot\boot.sdi[/B]
[B]bcdedit /create /d "Recovery Partition" /application OSLOADER[/B]
Replace "recovery partition drive letter" with the correct drive letter of the recovery partition (for example, D: ).The last command will return the GUID for the newly created entry. Use it for the following commands, replacing "GUID" with the actual GUID.
Code:
[B]bcdedit /set {GUID} device ramdisk=[c:]\sources\boot.wim,{ramdiskoptions}[/B]
[B]bcdedit /set {GUID} path \windows\system32\winload.exe[/B]
[B]bcdedit /set {GUID} osdevice ramdisk=[c:]\sources\boot.wim,{ramdiskoptions}[/B]
[B]bcdedit /set {GUID} systemroot \windows[/B]
[B]bcdedit /displayorder {GUID} /addlast[/B]
Addendum:

Sorry for all the edits. Had to make a couple of changes.
Its correct now though.
 
Last edited:
#14
Ok I think we are close, i did everything u said, and i got the ramdisk options in the boot menu now and it started loading windows startup but then i got a blue screen with the error "UNMOUNTABLE_BOOT_VOLUME"
 
#15
Sorry again. Been reading and reading the Microsoft article where I found this information. Something it says is a bit confusing:
To create an entry to boot a Windows Imaging Format (WIM) image, you will need to create an OSloader type entry with RAMDISK options pointing to the boot partition. To do this, use the following procedure. In this procedure, the arcpath multi(0)disk(0)rdisk(0)partition(1) refers to the C: drive on the computer, and Boot.wim is a regular Boot.wim with Winload.exe in the System32 folder inside the WIM image.
That's all very well and good, except for the fact that Microsoft often uses the terms "boot" and "system" interchangeably, sometimes meaning one thing and sometimes meaning another. Most likely its talking about "system" in this case (i.e. the partition that contains the boot files)...
And another thing is, its unclear whether they're saying the OSLoader entry is what should be pointed at the "boot partition" or if the "ramdiskoptions" entry is what is.
To make matters worse, the whole the arcpath multi(0)disk(0)rdisk(0)partition(1) refers to the C: drive on the computer comment confuses me, because it seems like its saying ramdiskoptions counts partitions using the C: drive letter on the first partition, followed by D for the second partition, etc (meaning the drive letter in those commands may differ from the booted OS's version of drive letters)...
Or it could just be using it as an example, and you're supposed to change it to either the correct drive letter of the "system" partition or to the drive letter of the partition that contains the image (though the article doesn't explicitly tell you to).
 
Last edited:
#16
Also the boot manager pops up right away without pressing f9 when i boot. If there is a way i can just make the normal windows install the default so the boot menu only comes up after pressing f9?

Addendum:

It's okay Cool, I really appreciate you taking the time to help me here.
 
Last edited:
#17
What is the drive letter of the "system" partition?
Try doing the following commands again, this time changing "c:" to the correct drive letter of that partition:
Code:
[B]bcdedit /set {GUID} device ramdisk=[c:]\sources\boot.wim,{ramdiskoptions}[/B]
[B]bcdedit /set {GUID} osdevice ramdisk=[c:]\sources\boot.wim,{ramdiskoptions}[/B]
To find the GUID of the OSLoader entry again, use
Code:
bcdedit

Addendum:

Also the boot manager pops up right away without pressing f9 when i boot. If there is a way i can just make the normal windows install the default so the boot menu only comes up after pressing f9?
You can remove it from the menu with
Code:
bcdedit /displayorder {GUID} /remove
but not sure if pressing f9 will work or not.
 
Last edited:
#18
ok just so we dont confuse ourselves, when u say system partition I take that to mean my main windows install on C:. The first time u posted directions u said to replace [c:] with my recovery partition letter which is E:

so the second part of what i entered the first time looked like this

Code:
bcdedit /set {myrealGUID} device ramdisk=[e:]\sources\boot.wim,{ramdiskoptions}
bcdedit /set {myrealGUID} path \windows\system32\winload.exe
bcdedit /set {myrealGUID} osdevice ramdisk=[e:]\sources\boot.wim,{ramdiskoptions}
bcdedit /set {myrealGUID} systemroot \windows
bcdedit /displayorder {myrealGUID} /addlast
should i try it with c: now? I figured thats what u meant since sources/boot.wim is only on E:
 
#19
Nah, by "system" I meant the partition which is marked as "system" in Disk Management (Windows menu->right click on "Computer"->Manage->Disk Management), i.e. the partition that contains the boot files. That may be your OS partition, or it may not be (it doesn't have to be).

But yeah, if C: is "system" according to Disk Management, definitely try that in the commands (now that I know you tried E instead).