EasyBCD won't run

mqudsi

Mostly Harmless
Staff member
#22
Well, if you've *ever* booted into Vista on this machine, then you should have a BOOT folder on a partition, somewhere. Check all your drives?

EasyBCD was unable to locate it automatically, so it's asking you to do so. That in itself means there's something funky going on, because EasyBCD is usually quite good at finding the BCD file for itself.
 

oggie

New Member
#23
At the moment I amhsing my tablet computer that never had Vista on it.

On my other computer I have a partition with Vista but since I re-installed XP, it is as if I never ran Vista.

Say I want dual boot on tablet (I don't but for argument's sake, say I do), where can EasyBCD find the BCD file ?
 

Terry60

Knows where his towel is.
Staff member
#24
The boot files are "super-hidden" oggie.
Do you have folder options set like this ? (not just "hidden files")
btw. Have you repaired the Vista boot since reinstalling XP ?
(see sticky point 4)
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#26
You don't use EasyBCD to set up a dual-boot until Vista has been installed. Then it'll automatically locate the BCD file by itself.

So putting the tablet aside (this explains the BCD not found error you were getting after killing BootGrabber), if you killed BootGrabber on your other PC you'd have access to EasyBCD, except the XP dual-boot functionality won't work since BootGrabber was improperly terminated.
 

mqudsi

Mostly Harmless
Staff member
#27
This is a new version of BootGrabber that will print more debug info when used with the /v flag.

Please run "bootgrabber.exe /v /tlist" on any machine where EasyBCD hangs and tell me what it shows. Does it still hang on a blank cursor or will it print one or more error messages repeatedly (in a stuck loop)?
 

Attachments

oggie

New Member
#28
Seems this is the problem....ID 10 T error.....what I find strange is that I have done this before and I don't remember fixing Vista partition - however, I don't doubt your word. This afternoon I'll try and let you know.
 

mqudsi

Mostly Harmless
Staff member
#29
oggie, you can try this BootGrabber.exe on the tablet and post what error it shows. I believe it'll probably be the same issue as on your other machine.
 

mqudsi

Mostly Harmless
Staff member
#31
No, no.... I attached a file to my post above (post #27). That is the bootgrabber.exe that I need you to run from the command line with the "/v /tlist" arguments. And, yeah, please try it on the tablet.
 

oggie

New Member
#32
Sorry - hadn't seen attachment....

It goes into a loop saying "Allocating more space for partition info."....to stop it, ctrl-c

Addendum:

Just to tell you : /tlist and /list both work with same result......should they ?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#33
Excellent. That gives me a place to start!

/list and /tlist are *not* the same, but at this point (with BG being unable to continue to completion), they are.
 

mqudsi

Mostly Harmless
Staff member
#35
OK, I ***may*** have fixed it.

Try the attachment here with "/tlist" and if it still hangs, again with "/v /tlist"

I hope it'll work. If it does, you can replace the bootgrabber.exe in the EasyBCD program files with this one, and EasyBCD should magically work again :grinning:
 

Attachments

Terry60

Knows where his towel is.
Staff member
#36
Oggie, your post #23
Yes, if you've reinstalled XP on your dual-boot machine, it will have regressed the PBR to look for NTLDR instead of bootmgr, hence no sign of Vista, and no possibility of booting it from there.
First step would normally be EasyBCD > Boot loader setup > Install Vista/7 bootloader > write MBR, (if you could get EasyBCD to run), but otherwise you can boot the repair disk you downloaded (or the Vista DVD if someone's located it for you) and run "repair your computer" > "startup repair" three times and let MS fix it for you. Once in Vista, maybe EasyBCD will run without the problems you're seeing.
 

oggie

New Member
#37
Ok, bootgrabber doesn't hang....it gives some information - I attached a screenshot for you to decipher...
For now I won't fix the Vista partition so bootgrabber.exe will keep giving the error in case you want to test something else.
 

Attachments

Last edited:

mqudsi

Mostly Harmless
Staff member
#38
Nope, everything is golden!

You can now replace BootGrabber on the other PC with this one that works, then use EasyBCD to fix your dual-boot :smile:

You'll need to do
EasyBCD | MBR Management | Write MBR
EasyBCD | Add New Entry | Windows XP

And you should be all set.

Addendum:

Are drives J: through H: mapped network shares? I think they were the ones giving me trouble..

Addendum:

Actually, that explains a lot. I assume the NAS drives are mounted on both the Tablet and the other machine? That would be the reason BootGrabber was failing on the both of them.
 
Last edited:

oggie

New Member
#39
Yes, NAS drives are on network (Network Attached Storage) - I fitted them so they are available to both my computers. Could be they were confusing BootGrabber. They never gave me problems but, as we know, it means nothing...
 

mqudsi

Mostly Harmless
Staff member
#40
Yeah, I think so. Anyway, let's see what happens with EasyBCD now :smile: