Unable to chainboot Ubuntu 9.10 Beta with EasyBCD 2.0 Build 64

Discussion in 'EasyBCD Support' started by e030709, Oct 16, 2009.

  1. e030709

    e030709 New Member

    Joined:
    Oct 14, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    5 OS booting capability was working in the following configuration,

    MBR: Use Vista bootloader to chainload Linux bootloaders installed in /boot,
    sda1 (hd0,0): Vista OS partition, with EasyBCD 1.7.2, and Ubuntu 64-bit Wabi,
    sda2 (hd0,1): Vista recovery partition,
    sda5 (hd0,4): Ubuntu 9.04 64-bit, logical partition
    sda6 (hd0,5): Ubuntu 9.04 32-bit, logical partition
    sda7 (hd0,6): BackTrack 4, logical partition
    sda8 (hd0,7): linux swap.

    I elected to install ubuntu-9.10-beta-desktop-i386 on sda5 with a reformat to ext4 journaling. I also clicked the advanced button on install page 8 out of 8, and elected to install Grub2 in /boot. I verified Ubuntu 9.10 Grub2 files exist on sda5/boot by booting Ubuntu 9.04 32-bit on sda6 and exploring Places sda5, sda5/boot, and sda5/boot/grub.

    Uninstall EasyBCD 1.7.2, install EasyBCD 2.0 Beta.

    Attempt 1: Launch EasyBCD 2.0, delete old entryfor Ubuntu 9.04 64-bit, select Linux tab, add a new entry for Ubuntu 9.10 32-bit on sda5, select the Grub boot loader option, and check the box labeled, "Grub isn't installed to the boot sector"(as illustrated in FAQ link http://neosmart.net/forums/attachment.php?attachmentid=754&d=1237655670). When I reboot and select the Ubuntu 9.10 entry, the error message is “File system type is ext2fs Partition type 0x83”. Reading the FAQ again I find, “If Linux is on the same HDD as Windows "system" (boot) files, then you do not need to tick the box. The chaining will be done directly without Neogrub being needed.”

    Attempt 2: Same as attempt 1 except I do not check the box labeled, “Grub isn’t installed to the boot sector”. This time no error message, just a blank screen. I google and find The Linux Space website suggests using neoGrub.

    Attempt 3: Delete entry of attempt 2, click neoGrub tab, click install neoGrub, click configure, enter the following lines, and save.

    default 0
    timeout 1

    title Chainload into GRUB v2
    root (hd0,4)
    kernel /boot/grub/core.img

    When I reboot and select the neoGrub entry, error message is same as attempt 1, “File system type is ext2fs Partition type 0x83”

    2 months ago, my total knowledge of Linux consisted of six commands: cp, mkdir, rm, cd, mv, pwd, which I've used for many years on an HP linux workstation to execute one software application as part of my day-to-day job. I’ve found posts where others resolved this issue, so I tried the above attempts again without success. Ubuntu is rapidly becoming my favorite OS. It’s frustrating to be stuck on this after successfully setting up a 5 OS boot system with little or no difficulty by reading posts and documentation. Did I make a mistake with the sda or hd0 count? Thanks in advance for suggestions to resolve this issue.

    Doug
     
  2. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    Doug, try the following for chainloading with NeoGrub:

    title Chainload to grub2
    find --set-root /boot/grub/core.img
    chainloader /boot/grub/core.img
     
  3. e030709

    e030709 New Member

    Joined:
    Oct 14, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Kairozamorro,

    I edited C:/NST/menu.lst with notepad, inserting the following text,

    default 0
    timeout 3
    title chainload into grub2
    find --set-root /boot/grub/core.img
    chainloader /boot/grub/core.img

    When I reboot, the title "chainload into grub2" appears and the system halts. Ctrl-c and Ctrl-alt-delete have no effect. I touch the power button to shutdown.

    Doug
     
  4. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    Ok, what about this?

    title Chainload grub2
    find --set-root /boot/grub/core.img
    map --mem /boot/grub/core.img (fd0)
    map --hook
    chainloader (fd0)+1
     
  5. e030709

    e030709 New Member

    Joined:
    Oct 14, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Kairozamorro,

    I performed a copy & paste to avoid typing errors. I still have a blank screen upon reboot with neoGrub. Grub2 supports "bash", would you recommend erasing all text except the title, enter the interactive mode and typing commands to observe the effect? I viewed a list of commands by pressing the tab key, however I'm not familiar with them.

    I attached screenshots of the boot and grub folders. What may I do to check the integrity of core.img? Shall I reinstall Ubuntu 9.10 Beta?

    I forgot to mention, the md5sum of the iso download was verified, and the burned disk passed the imbedded integrity check that comes up when it is booted.

    Thanks, Doug
     

    Attached Files:

  6. e030709

    e030709 New Member

    Joined:
    Oct 14, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Just a note, the screen is not totally blank, it shows the title, "Chainload grub2".
     
  7. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,288
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Chicago
    Time for me to dig into GRUB2 support :X
     
  8. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    That might be a little hard, since grub2 is under beta too.

    Yeah Doug, enter the command prompt and type it in line by line excluding the title line. Does find line return a location? Type "boot" after you've entered those commands to attempt booting if you weren't getting any errors. You might need to revert to an ext3/ext2 filesystem before it well work. You could also try renaming the core grldr, placing it on the root of the partition, and chainloading it from there instead.
     
    Last edited: Oct 17, 2009
  9. e030709

    e030709 New Member

    Joined:
    Oct 14, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Success

    I can now boot Ubuntu 9.10 Beta and I'm writing this reply within a fresh OS. I tried everything you suggested to make chainbooting the ext4 file system work. See details below. Finally, I reinstalled 9.10 Beta with an ext3 reformat, kept only a title record in C:/NST/menu.lst which then opens grub CLI, and manually entered the following,

    root (hd0,4)
    kernel /boot/grub/core.img
    boot

    With that, Ubuntu 9.10 Beta finally launched. I'll configure neoGrub with those commands and this thread is resolved. Perhaps I should post a Karmic Koala bug report?

    Here's what happened when I used grub CLI in attempts to make ext4 work:

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub>kernel /boot/grub/core.img
    (hard freeze, power down to restart)

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    chainloader /boot/grub/core.img
    (hard freeze, power down to restart)

    grub>find --set-root /boot/grub/core.img
    (hard freeze, power down to restart)

    Launch Ubuntu 9.04, refer to Mark Sobell's book to set root password, login to root, mount /dev/sda5 and copy /boot/grub/core.img to /grldr and /grldr.img (is file extension required?) Using grub CLI again, this is what happened when I attempted to make ext4 work,

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub>ls
    (directory and file list includes grldr and grldr.img)
    grub>kernel /grldr
    Error 13: Invalid or unsupported executable format

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub>kernel /grldr.img
    Error 13: Invalid or unsupported executable format

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub>chainloader /grldr
    Error 13: Invalid or unsupported executable format

    grub>root (hd0,4)
    Filesystem type is ext2fs, partition type 0x83
    grub>find --set-root /grldr.‫img
    (hd0,4)
    grub>map --mem /grldr.img (fd0)
    Autodetect number-of-heads failed. Use default value 2
    Autodetect sectors-per-track failed. use default value 18
    floppies_orig=0,
    harddrives_orig=1,
    floppies_curr=1,
    harddrives_curr=1
    grub>map --hook
    grub>chainloader (fd0)+1
    Error 13: Invalid or unsupported executable format

    Also note, reinstall of Ubuntu 9.10 Beta on ext3 did not end gracefully. When cd carriage opened, an infinite loop commenced with the following 2 lines,

    gdm main process (nnnn) terminated with status 1
    gdm main process ended, respawning

    Thanks for your assistance, Doug
     
  10. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    Yeah, jsut enter those lines into your neogrub config. Glad its working.
     
  11. Yakumo

    Yakumo New Member

    Joined:
    Apr 24, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I'm having the same problem with EasyBCD 2.0 Beta, Build 64

    ubuntu-9.10-beta-desktop-amd64.iso downloaded last night.

    I have (iirc but sda5.6 are definitely correct)

    sda1 win7boot, sda2 win7, sda5 linux swap, sda6 ubuntu 9.10 64 ex4 , sda4 empty atm

    All the partitions are primary except for the last one on the disk that I am not currently using for anything.

    win7 was installed first allowing it to settup it's boot partition. grub2 was installed to sda6 during ubuntu settup

    EasyBCD 2 b64 used with the linux tab, type - grub.

    I've tried initially NOT ticking 'grub is not installed' and just pointing it to the linux partition it detects "Partition 4 (Linux - 21gb)"

    And I've also tried ticking the 'grub is not installed' box as some grub2 easybcd guides suggested.

    The result is either a black screen with boot /grub/menu.lst or a black screen with a flashing cursor only and no further activity.
     
    Last edited: Oct 20, 2009
  12. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    Yakumo, re-install with ext3 filesystem.
     
  13. Yakumo

    Yakumo New Member

    Joined:
    Apr 24, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I realise that would work, but easyBCD 2 claims full support for ext4
     
  14. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    Everything, including grub2, ubuntu, and easybcd itself are still beta. Its going to take some time to work it out.
     
  15. Gemnoc

    Gemnoc New Member

    Joined:
    Oct 17, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have a similar problem. Ubuntu Netbook Remix 9.10 beta installed on an ext4 logical partition, in dual-boot with Vista, Grub doesn't show up, I get a flashing cursor on a black screen. I wasn't aware of the change to Grub2 till I read this thread.

    One thing I don't understand: the French Ubuntu wiki says not to install NeoGrub in EasyBCD, as it isn't compatible with Ubuntu's grub?

    I just downloaded UNR 9.10RC, I'm going to give it another go, this time in ext3 and I might create a principal partition for it instead of logical. Would that ease the process?

    And anyone knows if it's possible to install 9.10 with the legacy grub instead of grub2? It seems to me like it would be easier.

    Thanks.
     
  16. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,288
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Chicago
    Full Ubuntu 9.10 support in EasyBCD 2.0.

    Download: EasyBCD 2.0 Beta Builds - The NeoSmart Forums

    Can boot via the traditional NeoGrub method (because of full ext4fs support) or by chainloading GRUB2. If the latter, make sure to select the GRUB2 option from the drop-down EasyBCD menu.
     
  17. Yakumo

    Yakumo New Member

    Joined:
    Apr 24, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Fantastic.
    I just downloaded the ubuntu 9.10 RC cd, installed to a primary partition with ext4, and bootloader on THAT partition. ran windows, ran easyBC 2 (build 65)chose add new, linux -> grub 2 (no other options necessary) reboot and it worked first time :smile:
     
    Last edited: Oct 24, 2009
  18. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,375
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Phoenix, AZ US
    And EasyBCD saves the day again. Awesome job CG.
     
  19. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,288
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Chicago
    Awesome.

    Thanks, guys.
     
  20. Gemnoc

    Gemnoc New Member

    Joined:
    Oct 17, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Well it solved my problem too! I won't have to reinstall Karmic.

    I wouldn't have thought you'd be able to roll out a revision this fast! Thanks!:happy:
     

Share This Page