Using NeoGrub to hide Vista partition from XP

Actually, is there a way to have the Neogrub "unhide" command somehow run upon choosing VISTA from the main bootloader menu. Right now I am manually running "unhide (hd0,1)" from the Neogrub command line and then rebooting & choosing Vista from the boot menu each time I need to switch from XP to Vista...That's really cumbersome, and I am probably missing something simple.....Any suggestions are welcome....
Hi Yukkell,

Welcome to NeoSmart Technologies. It's possible, but it's not a trivial thing. We're considering writing an app to automate it, though at the moment, we're just not sure.

We'll probably just update the guide and make it as easy-to-understand as possible.
Would it be possible for me to include a statement in the menu.lst file which would include the "unhide (hd0,1)" and point the bootloader to Vista instead of XP? This way I could choose to unhide & launch Vista (Or alternatively, hide Vista & launch XP) from within the Neogrub menu. I am not sure what the syntax would be, or if this is even possible...
No, unfortunately it isn't possible, at least AFAIK.

The problem is that you cannot boot Vista directly, you must instead call bootmgr - which brings you back to the choice between Vista and NeoGrub once more.

I have a solution in mind, but I'm not sure if it'll even work at all - I'm really busy today, but I'll see if I can't get it to work.
Hey, before you leave..

Can you tell me how do you say "Please tell me where do you live, I'm your friend" in your language...
Last edited:
NeoGrub only produces a "Grub_" prompt

I spent considerable time yesterday trying to get NeoGrub to work but without much luck.

My machine now successfully dual boots between Vista and XP. I have a copy of ntldr and boot.ini on the C drive which is also the Vista partition. XP or resides on the E drive which is partition 4 of drive 0.

All works well without NeoGrub. With NeoGrub (script as below) I get only a "Grub_" prompt and the boot attempt hangs at that point. Does anyone have any idea of why this is happening and how to fix it?

Grateful thanks for any help!

default 0
timeout 0

title Boot XP - Hide Vista

# Optionally repeat the above entry for all the Vista drives
chainloader (hd0,1)/ntldr # SET THIS TO THE BOOT PARTITION

Thanks for the suggestions. 1.61 seems to work better but now I am getting a message about Windows failing to boot when I try to use NeoGrub to boot into XP. The message says I should repair Windows but XP works just fine without NeoGrub. I get the following notice as well:

File: \NST\NeoGrub.mbr
Status 0xc000000f

Any further ideas. I really would like to get this working so I can have Vista restore points again!

Thanks very much!!!
Interestingly I just did that and all is well now!!

Thanks for a wonderful cure to a nasty problem--and especially thanks for the quick and friendly help!!!!
Hey, that's good news!

Glad it worked for you - stick around, see if you can't help those to come!
Oh dear--I just tried to go back to Vista and got the following error followed by BSOD:

autochk program not found--skipping autocheck

I checked with BootIt to see if the first partition can somehow been hidden but is hasn't. I hope I'm not back to square-one!!!

I did make a copy of the MBR this time before I started working with NeoGrub so hopefully all is not lost. Have you heard of anything like this???
No luck--EasyBCD seems to be working alright in XP now. Twice I've removed NeoGrub and reinstalled it with and unhide for the Vista partition. When I try to boot though the NeoGrub option is not even present!

Any ideas????
How do you mean, it's not present?
Actually, a better question: when you reboot and pick the OS, do you see the old XP bootloader or the Vista one?
I see both but not NeoGrub even after installing it and configuring it--which I guess makes some sense if the first volume has grub bit set to hidden.

Here's what really distrubs me though. I booted Ubuntu from a CD and went into a terminal session, started grub, then typed in unhide (hd0,0) the command drew no error message and I thought my problem was solved--wrong, its still showing hidden in EasyBCD's Linux tab and the volume doesn't show in XP.

So why wouldn't Ubuntu/Linux grub reset the hidden bit????

I'm fast getting desparate here!

Thanks again!
A live CD would do the trick - but the problem with Linux Live CDs is that they use different numbering schemes.

Just try the different combinations... like (hd0,1), (hd1,0), etc.