Vista on fake raid 0 with Ibex dual boot, Help

#1
I've 2x 36GB hd's in raid 0 for Vista and a single 160GB HD for Ibex with grub written to the bootloader. I can get in2 both by rearranging the bios boot order. I've read thru several threads and seem to be getting nowhere. I've tried several times trying with Grub and with NeoGrub etc.

Diskpart tells me that my grub is installed on Disk 1 partition 3

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ---------- ------- ------- --- ---
Disk 0 Online 69 GB 0 B
Disk 1 Online 149 GB 0 B
Disk 2 Online 932 GB 0 B

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> list partition

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Primary 143 GB 32 KB
Partition 0 Extended 6236 MB 143 GB
Partition 2 Logical 6236 MB 143 GB
But when I try EasyBCD it only gives partition 0 & 1 which fails, can anyone figure?

 

mqudsi

Mostly Harmless
Staff member
#2
Partitions 0 and 2 are identical.... Ones the container for the Linux partition and the other is the logical partition within it.

Your problem is that GRUB is written to the MBR of the Linux drive, not the bootsector of the Linux partition.

Dual-booting directions: Ubuntu - NeoSmart Technologies Wiki
 
#3
Doesn't work, followed it too a T
I get a partman error when I try to do the install after "sudo apt-get install dmraid" in Ibex, see. The raided drives show as one but I cant install on the other drive.



I get "boot manager is missing" when i reboot from Vista to Ibex when I install without dmraid installed. Grub is on the bootsector of the linux partion. Any ideas.
 

Attachments

#4
Look, I've tried several times and always fail. Grub is being written to the bootsector but I can't boot it no matter what I try. Can anyone help?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
Did you try and go thru the process of adding the Linux entry but check the box for GRUB is not installed to the MBR?
 

Terry60

Knows where his towel is.
Staff member
#8
Do you have a SATA/IDE mix with your HDDs ?
If yes, read this post
 
#9
Do you have a SATA/IDE mix with your HDDs ?
If yes, read this post

:lup: You know what, that worked. I tried again and this time I selected the next drive in EasyBCD, My storage drive (Drive2,partion 0) which worked first time as grub was installed there



Thanks for all the help, hope You fix the bug

Pog
 

mqudsi

Mostly Harmless
Staff member
#10
Great job getting that to work, Pog. Congrats.

We're doing our best to fix that bug - thanks for your patience.
 

Terry60

Knows where his towel is.
Staff member
#11
Thanks due to Tony Marshall for spotting it and providing the workaround.
 

mqudsi

Mostly Harmless
Staff member
#12
Terry, if you select the partition based on the size and FS shown in EasyBCD, do you get the right results?
 

Terry60

Knows where his towel is.
Staff member
#13
I don't think so CG. (I haven't done it yet)
According to the original post

"When creating the Linux entry in EasyBCD I had initially selected Grub from the Linux tab and Drive 0, Partition 0 (Linux Native - 143GB) from the drop down drive selector. THis resulted in an error message (seen so many I can't remember which one).

I then Installed Neogrub and undertook many edits of the Menu.lst file to replicate the entries in the Menu.lst file on the Ubuntu installation - all to no avail. Again numerous error messages - bad file, can't mount etc.

As a last resort (and I have spent hours reading numerous similar forum posts) I decided to do what I beleived was completely illogical and that was to start from scratch and this time select drive 2 as the drive to boot Ubuntu from (i.e. the XP disk). The logic being that if Ubuntu thought it was installed on the 3rd disk (Disk 2) then it might actually be!!

This now works perfectly

So - despite EasyBCD telling me that Drive 0 is my Ubuntu disk - it is actually Disk 2 - even though EasyBCD tells me that Drive 0 has Partition 0 - 143GB and Partition 1 - Swap - 6GB"

Which leads me to an apparently unrelated question " How do you get the snipping tool to capture a drop-down?"
I've seen examples posted here, and the Vista help says to minimize the clipper then CTRL + Prt Scn with the menu displayed, but no matter what I try, the menu disappears as the clipper grabs focus.
I was trying to show you the drop-down I get, which shows the IDE disk (all properly configured) as disk 0 instead of disk 1, identical to disk mgmt.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#14
Just use the printscrn button instead and paste the contents of the clipboard into paint to save.

This is weird though :frowning:
 

Terry60

Knows where his towel is.
Staff member
#15
That's cheating.
I can workaround, but the snipper help says it can capture menus.
If I can figure how, it'll be a lot quicker. (discounting the hours spent figuring of course)
 

JustinW

Super Moderator
Staff member
#16
I imagine changing the focus of windows would close any menus for windows that are no longer active unless you can find a shortcut key with snipper to do this trick while the application who's menu you want to get a screenshot of continues to have the focus.

In paint use the seclection tool after a print screen to select the area you want and than copy to the clipboard. Open another instance of paint and paste the contents so it is only what you want and not the entire screenshot.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#17
I can do it Jus, (exactly as you would). I'm just trying to find out if the Vista help is accurate in its claim that snipper can do it.
It tells you how, but it just doesn't work (for me at least)
I wondered if anyone else had made it work, maybe my extra keyboard software was getting in the way ? whatever ?
 

JustinW

Super Moderator
Staff member
#18
Speaking of the snipping tool, I got a week old install of Vista Ultimate 32 here and I cant find it in the accessories menu or by search. Went to MS help and pulled up the source of a how-to page to find out where its normally located (windir\system32) and it is indeed not there. Is there a feature I'm missing that I need to enable or do I need to get a copy from my other computer?

Edit: Part of tablet pc components... adding now.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#19
Control Panel / Programs / Turn features on / Tablet options.

Sorry saw your edit later.
 

mqudsi

Mostly Harmless
Staff member
#20
Terry, take a look at SnagIt - it's like the snipper tool except it's awesome :grinning:

I wouldn't recommend it for the casual user, but if you take screenshots like crazy (for me, it's reviews and guides) then you'll love it.