Windows root

Coolname007

Distinguished Member
Hi Boris.
Adjust the XP entry under "Change Settings" in EasyBCD to point to the "system" partition (which is C in your case). Then copy over those XP boot files you mentioned (i.e. boot.ini, ntldr, and ntdetect.com) from the other computer, and place them in the root of the C: partition, and make sure that the boot.ini is correctly pointed at the XP partition in the rdisk() and partition() values (which needs to be the same in both lines).

Then XP should boot when you select it in the boot menu.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Boris,
In your post
"then i change the associated setting in easybcd,"

In the sticky thread (point 5)

Using EasyBCD 2.0 will take away a lot of the previous manual customizing necessary with the 1.7 release. As you click Add, you'll trigger the automatic boot.ini configurator which will detect the correct values and create your boot.ini file for you. It will also ensure that copies of the other XP boot files are placed in the correct location if needed.

The drive option will be "greyed out" to prevent you from pointing the entry at the XP partition because the BCD should point to the XP boot files, on the "system" partition, which in turn point to XP.

Don't change what EasyBCD sets up. It knows what it's doing. That's why it's called automatic configuration.

Just put the XP drive back to C:. You shouldn't need to copy files. Auto-configure has already done that.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
OK Boris.
Reading your post again, the NTLDR problem only happened after you'd changed XP incorrectly to D:, and now you've put it back to C:, It's trying to boot but crashing ?
What are the crash symptoms ?
It sounds like your problem is a bad XP install rather than a incorrect boot configuration.
 
windows boot loader

Hi T. I have checked in bios, win 7 is the 1st boot drive.
I get EasyBCD screen when booting and can select either drive, but that windows boot loader still pops up after selection and I have to use that as well and then it works. I would really like to get shut of that extra win boot loader. Regrds Rob.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Ok Rob, if you're getting an NTLDR boot menu after the W7 BCD then that's an entirely different problem.
That indicates that boot.ini thinks there is more than one XP system to choose between.
That shouldn't be happening if you let EasyBCD create it for you.
Use EasyBCD / Tools / Edit legacy entries, to display boot.ini and copy/paste it here.

Boris, what were the crash symptoms ?
 
Thanks Terry, Here we go.
[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP on E:\" /fastdetect
Thanks Rob.
 

boris

Member
i'm not sure about the symptoms, :shame:
the xp just load for a few seconds, then it restart by itself (there's a bluescreen, but i can't see the text in it.. it's too fast..)
after the restart, when i choose windows xp it gives me options to use safe mode, safe mode w/ networking, start windows normally.. etc.

is there any way to diagnose the symptoms? i'm sorry if its confusing

thanks :smile:

Addendum:

Hi T. I have checked in bios, win 7 is the 1st boot drive.
I get EasyBCD screen when booting and can select either drive, but that windows boot loader still pops up after selection and I have to use that as well and then it works. I would really like to get shut of that extra win boot loader. Regrds Rob.

hi robanfield, sorry for asking questions in your thread :shame:
 
Last edited:

Terry60

Telephone Sanitizer (2nd Class)
Staff member
If G is the letter you gave the previously unlettered partition, then that's correct.
There's nothing wrong with boot.ini, so it shouldn't present a second menu with only one option.
Must be a NTLDR quirk/bug.
Try setting timeout to 0 instead of 20 in boot.ini and that should suppress the menu.


Addendum:


Boris, when you choose XP from the boot menu, immediately hit the F8 key, to enter the NTLDR extended boot menu. Then choose the option "no automatic restart".
That should make the BSOD stop while the error is displayed and you can make a note.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Uploading images was broken since moving the site to a new server, it should be working 100% now once more.

With regards to EasyBCD, is there a problem with the latest build?
 

mqudsi

Mostly Harmless
Staff member
Can you tell me exactly what goes wrong, Terry?

Mostly it'll be one or more of these:

* NTLDR, NTDETECT are not copied
* NTLDR, NTDETECT are copied to the wrong partition
* BOOT.INI created on wrong partition
* BOOT.INI contains incorrect entries (points to something other than the XP partition)
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Nobody's been that specific unfortunately, but PMs to robanfield, druid(possibly - not yet determined if it is another), might yield some data.
huran,kruemel33 and razer have all reported that pointing the BCD at XP directly fixed the failure to auto-configure, maybe you could PM them for details of config .

btw Monk is getting twitchy about your post count.
 

Coolname007

Distinguished Member
I believe one of the users (don't remember which one it was) did not have NTLDR or NTDETECT.COM on his computer at all, and so that could be why the auto-configure failed. However, I think I remember you saying CG sometime in the past that the auto-configure feature creates those files from scratch (and doesn't copy them)..but now you're saying it copies them. So which is it? :smile:

Thanks.
 

boris

Member
That should make the BSOD stop while the error is displayed and you can make a note.

got this..
Check for viruses on your computer. Remove any newly installed hard drives or hard drive controllers. Check your hard drive to make sure it is properly configured and terminated.
Run chkdsk/f to check for hard drive corruption and then restart computer.
Technical Information:
Stop: 0X0000007B


i changed the hdd type from sata to ide in bios setting, and it worked! the xp worked again! :grinning:
is this mean is should install the sata drivers? :smile:
 

Coolname007

Distinguished Member
Yeh, got a similiar problem myself a while back, when I installed XP in a multiboot on a Dell Studio 1535 laptop...
I could boot into XP by changing the operating mode in the BIOS settings from AHCI to ATA, but unfortunately Vista could not boot in ATA mode, so I had to install the Intel Matrix Storage Manager in XP, after which I was able to boot in AHCI mode for both.
 
Top