Problem Dual Booting Vista & Ubuntu 8.10 with 2 Drives

#61
Okay weird
I uninstalled and reinstalled easyBCD
told it to recover BCD and MBR what the heck.

I then made a linux entry pointing at my linux hard drive. Still no joy. got the cant find boot partition.
Tried to make another linux entry now there are two and now my linux drive is listed as hd5 instead of hd2 where it should be listed.
Made another linux entry this time pointing at HD5 and this time it works???

So your problem and mine, as I suspected was not grub( your thrashing was for nothing ) but Vista and easybcd.
Posting pictures maybe the experts can find an answer for this strange bug
first linux entry gets me this message

Bootpart 2.60. Bootsector (c) 1993-2005 Gilles Vollant http"//www.winimage.com,b
ootpart.htm
Loading new boot partition
Bootsector from C.H Hochstatter

BOOTMGR is missing
Press Ctrl + Alt + Del to restart

Second linux entry works but not the same as before. I now get

Bootpart 2.60. Bootsector (c) 1993-2005 Gilles Vollant http"//www.winimage.com,b
ootpart.htm
Loading new boot partition
Bootsector from C.H Hochstatter

Cannot load from Harddisk
Insert System disk and press any key

Now if I press a key my Grub menu loads and I can load ubuntu.

this very strange as before I would go straight into Grub menu

Kgrach
 

Attachments

Last edited:
#62
Okay weird
I uninstalled and reinstalled easyBCD
told it to recover BCD and MBR what the heck.

I then made a linux entry pointing at my linux hard drive. Still no joy. got the cant find boot partition.
Tried to make another linux entry now there are two and now my linux drive is listed as hd5 instead of hd2 where it should be listed.
Made another linux entry this time pointing at HD5 and this time it works???
Hi, Kgrach. Welcome to NST.
According to the screenshot you posted of the "Drive" menu in EasyBCD, hd4 (Disk 4) is indeed right, and not hd2...so I'm not quite understanding your problem. :wink: Why would you think it was hd2, and not hd4? Remember...you're going by what EasyBCD in Windows calls them, and not the BIOS or Grub. Windows and Grub both start counting at 0 for disks, not 1, and so what you thought was hd5 is actually hd4 (Disk 4).
So your problem and mine, as I suspected was not grub( your thrashing was for nothing ) but Vista and easybcd.
Posting pictures maybe the experts can find an answer for this strange bug
first linux entry gets me this message

Bootpart 2.60. Bootsector (c) 1993-2005 Gilles Vollant http"//www.winimage.com,b
ootpart.htm
Loading new boot partition
Bootsector from C.H Hochstatter

BOOTMGR is missing
Press Ctrl + Alt + Del to restart

Second linux entry works but not the same as before. I now get

Bootpart 2.60. Bootsector (c) 1993-2005 Gilles Vollant http"//www.winimage.com,b
ootpart.htm
Loading new boot partition
Bootsector from C.H Hochstatter

Cannot load from Harddisk
Insert System disk and press any key

Now if I press a key my Grub menu loads and I can load ubuntu.

this very strange as before I would go straight into Grub menu

Kgrach
That error was simply because it was pointed at hd2 at that point in time, and not hd4.

Cheers.

-Coolname007

Addendum:

@andy-min: If everything's failed for you so far, you can try doing the following:

Delete any and all Ubuntu entries you have currently in EasyBCD.
Open up the Notepad application as administrator (by going to Start>All Programs>Accessories>Notepad, and right-click on it, and select "Run as administrator") in Vista, and paste the following lines into it:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
Next, go to File>Save, and in the dialog box that appears, navigate to the root of your "system" partition (as shown in Start>Right click on "Computer">Manage>Disk Management), and save the file there as "boot.ini" without the quotes.
Now open up the Command Prompt (by going to Start>All Programs>Accessories>Command Prompt), also as an administrator. And then run the following commands in the Command Prompt:

Code:
cd \
cd \Program Files\NeoSmart Technologies\EasyBCD\bin
bootpart
[B]C[/B]:\bootpart [B]4[/B] [B]C[/B]:\ubuntu.lnx Ubuntu Linux
Note that the "4" and both "C"s in that last command need to be replaced by whatever is right in your case. For instance, if your command prompt opened up in the partition with the D letter, for example, you would need to put D in instead. And you would need to replace the 4 with the correct partition number as shown by Bootpart, and enter in whatever number it is that is right next to the partition that has <Linux native> in the same line.
And then after running those commands (before closing the Command Prompt window) please take a screenshot of what the Command Prompt displays, and save it in a Paint document, and select the jpeg extension for the file.

And now reboot, and you should see a boot entry called "Ubuntu Linux" without the quotes. Select that, and you should boot right into Ubuntu. :smile: If you don't and you get some kind of error, then please post the screenshot you created of the Bootpart output in the Command Prompt, so I can make sure you selected the correct partitition number, and got the commands right.

-Coolname007
 
Last edited:
#63
Still hangin in there..

Coolname,
I will look this over and consider doing this...

Kgrach -- thank you for your thoughts and efforts -- goes to show me that I am not crazy (the voices in my head tell me so :evil:smile:.

Cheers-- andy-min
 
#64
According to the screenshot you posted of the "Drive" menu in EasyBCD, hd4 (Disk 4) is indeed right, and not hd2...so I'm not quite understanding your problem. Why would you think it was hd2, and not hd4? Remember...you're going by what EasyBCD in Windows calls them, and not the BIOS or Grub. Windows and Grub both start counting at 0 for disks, not 1, and so what you thought was hd5 is actually hd4 (Disk 4).
well Its connected to SATA three in the BIOS
Grub and linux show it as HD2
Originally before the MBR was wiped EasyBCD showed it as hd2
With this MBR EasyBcd showed as Hd2 until after I saved the first linux entry.
In both cases I pointed to the same hard drive its the only 80Gb linux drive
The only difference in the two entries was the name I called them and the fact EasyBcd changed it hd designation between entries

like I said weird.
The reason I posted this is it points to something odd happening related with Vista and that helps eliminate ubuntu and grub as a cause for error.
That should help andy with his ubuntu problem as I struggled for days till at random last night I tried to add another entry and it worked all of a sudden.

kgrach
 
#65
well Its connected to SATA three in the BIOS
Grub and linux show it as HD2
That's because HD2 is the third hard drive in the boot sequence in the BIOS...simply because Grub starts counting drives at 0, instead of 1. :wink:
Originally before the MBR was wiped EasyBCD showed it as hd2
With this MBR EasyBcd showed as Hd2 until after I saved the first linux entry.
In both cases I pointed to the same hard drive its the only 80Gb linux drive
The only difference in the two entries was the name I called them and the fact EasyBcd changed it hd designation between entries
Now...that is strange. :wtf: Do you happen to have an SATA/IDE drive mix? There have been reports of strange behavior of EasyBCD's drive/partition detector when there is a mix of SATA and IDE drives...I guess for the simple reason that an IDE drive is usually detected first. But this is the first time that I've heard of EasyBCD changing how it detects drives or partitions after simply wiping and reinstating Vista's MBR...:wtf:
like I said weird.
The reason I posted this is it points to something odd happening related with Vista and that helps eliminate ubuntu and grub as a cause for error.
That should help andy with his ubuntu problem as I struggled for days till at random last night I tried to add another entry and it worked all of a sudden.

kgrach
One good thing to point out in regard to selecting the correct partition for Ubuntu is that it will almost always have "Linux native" in the same line for the Ubuntu partition...and also, you can usually make a good guess on picking the right one based on the size. For instance, in my case, I had only one approx. 20 GB partition, and that was Ubuntu's, so I had little trouble picking the correct partition to point the Ubuntu entry at. But I have also heard of instances where people actually had to point to a totally different drive as shown in EasyBCD, and one that did not have a "Linux native" partition...so I guess the only real reliable method of picking the right partition in EasyBCD is by going by the size. :wink:

-Coolname007

EDIT: Here it is:
Vista on fake raid 0 with Ibex dual boot, Help - The NeoSmart Forums
Post #13
 
Last edited:
#66
The state of my machine..

Hi,

I took a snapshot of my machine config to have anyone take a peek at it. As of this posting I am not able to dual boot, can just boot into Vista, my Ubuntu option gives ma a blank screen. I am trying out an Easy BCD Beta 2.0....from the Guru.

Ubuntu was installed with both SATA drives attached and running (using guided install, using entire disk and pointing GRUB to install in the same partition Ubuntu is on)

Attached are screenshots of my Ubuntu drive (screenshot.png) AND my Easy BCD (neo2.png) configuration as well as a view from Vista Disk management (vista.png). In Easy BCD, I have tried BOTH the check box checked and unchecked with no success...

+++++++++++++++++++++++
Settings In my BIOS:
SATA0: Vista hard disk
SATA1: Ubuntu Hard disk
SATA2: Unavailable
SATA3: Unavailable
SATA4: DVD drive
SATA5: DVD Drive
RAID ON
USB controller enabled

Boot sequence:
1.Onboard USB CD-ROM
2.Vista Hard disk
3.Ubuntu Hard Disk
4.Onboard or USB floppy (not present)
5.Onboard SATA hard drive (not present)
6.Onboard network controller (not present)
7.USB device
+++++++++++++++++++++++


In easyBCD:
-----------------------------------------------
There are a total of 2 entries listed in the bootloader.
Default: Microsoft Windows Vista
Timeout: 30 seconds.
Boot Drive: C:\
Entry #1
Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: NeoSmart Linux
BCD ID: {89fb9b65-dc75-11dd-aa21-001a70151331}
Drive: C:\
Bootloader Path: \NST\nst_.mbr
-----------------------------------------------

menu.lst from Ubuntu:
------------------------------------------------
# menu.lst - See: grub(8), info grub, update-grub(8)
# savedefault=false
## ## End Default Options ##
title Ubuntu 8.10, kernel 2.6.27-7-generic
root (hd1,0)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=0e719a23-ded1-4c6b-ab63-a1dbd9dc2c95 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet
title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=0e719a23-ded1-4c6b-ab63-a1dbd9dc2c95 ro single
initrd /boot/initrd.img-2.6.27-7-generic
title Ubuntu 8.10, memtest86+
root (hd1,0)
kernel /boot/memtest86+.bin
quiet
### END DEBIAN AUTOMAGIC KERNELS LIST
# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Dell Utility Partition
root (hd0,0)
savedefault
chainloader +1

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title Windows Vista/Longhorn (loader)
root (hd0,1)
savedefault
chainloader +1
------------------------------------------------

So if you think there are any thoughts of things to try in EASY BCD of menu.lst, please let me know :wink:.

Thank you!
 

Attachments

Terry60

Knows where his towel is.
Staff member
#67
There appears to be a fundamental clash between Disk management and everything else, where it shows disk 1 partition 2 as primary, where everything else says it's a logical drive inside an extended partition.
EasyBCD should reflect what the OS it's running on says !
Not sure if this has any bearing whatsoever on your Linux boot problem, but it looks weird to me.
 
#68
If you go into your bios and make the Ubuntu drive your boot drive leaving your windows drive installed does Ubuntu boot? If it does then switch back to windows boot and run bootpart manually, and save the linux boot partition as c:\NST\nst_.mbr. If it doesn't boot then reinstall Grub on the Linux drive to get it to boot, if it still fails then reinstall ubuntu leaving this drive as the boot drive. Once you get your computer booting off of this drive it should just be a matter of switching to making your windows drive your boot drive and copying the linux partition with bootpart. If all else fails grub should have an option to load windows if you leave Linux as your boot drive. I hope this makes sense to you.

Mike
 
#69
There appears to be a fundamental clash between Disk management and everything else, where it shows disk 1 partition 2 as primary, where everything else says it's a logical drive inside an extended partition.
EasyBCD should reflect what the OS it's running on says !
Not sure if this has any bearing whatsoever on your Linux boot problem, but it looks weird to me.
Yeah, that is indeed very strange...:wtf: According to his Disk Management screen, partition 2 of disk 1 (starting the count from 0, of course, for the disk) is a primary partition, but according to the screenshots of the Gparted window and the EasyBCD "drive" menu (as well as fdisk), it is actually an extended/logical partition. :tongueout:oint:

@ andy-min: Are you sure that you installed Grub to the partition? Everything appears to be configured correctly in your case, leaving only the possible reason that Grub has not been installed to the partition...

Cheers.

-Coolname007

Addendum:

Actually...I just found an easier way to use Bootpart manually. :grinning:
Simply open up EasyBCD, go to the "Useful Utilities" window, click on the "EasyBCD Power Console" button, which opens up in EasyBCD's bin folder, and then simply run:

Code:
bootpart
[B]C[/B]:\bootpart [B]4[/B] [B]C[/B]:\ubuntu.lnx Ubuntu Linux
Where the "C"s and the "4" is replaced with the correct drive letter and partition number as shown by Bootpart.

Done! :smile:
Now its simplified to just two simple commands, and you'll have a working Linux boot shortly thereafter.

Cheers!

-Coolname007
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#70
If EasyBCD didn't work, most likely bootpart won't either.


I won't say it's impossible, just in case, but I highly doubt it.
 
#71
If EasyBCD didn't work, most likely bootpart won't either.


I won't say it's impossible, just in case, but I highly doubt it.
Well, it happens to work in my case, while EasyBCD doesn't, for Linux...:wink: I can create a working boot entry in the Vista bootloader with Bootpart (which doesn't show up in EasyBCD) for Ubuntu, while I can't with the EasyBCD method. I'm not trying to diss EasyBCD or anything, just merely stating a fact...

Cheers.

-Coolname007

P.S. Here's a couple of screenshots to prove that the entry that I just created (after reading your post) in EasyBCD for Ubuntu is pointing at the correct place, but it doesn't work. I only get a blank screen when selecting it at bootup. You will notice that Disk Management shows C:\ as my system, boot, and active partition, and the Linux entry (created in EasyBCD) is pointed at C:\ and that the correct partition is selected in EasyBCD...just so you don't have any doubt. :smile:
 

Attachments

Last edited:

Terry60

Knows where his towel is.
Staff member
#72
You're using BING Cool.
It specifically procludes the use of any other partitioning utility, because they'll clash with its use of non-standard methods.
The same will apply presumably to any other software which makes assumptions about the standard nature of the partitions.
You should be using BING to set up all that stuff on your system, not EasyBCD.
For example, you have a HDD claiming to have 4 primaries, 2 invisible and an extended partition containing 2 logical disks. This is not a situation which exists in the standard architecture, only in the propriatory world of BING.
If you set up a non-standard paradigm, you have to manipulate it with the tools designed for it specifically.
 
#73
You're using BING Cool.
It specifically procludes the use of any other partitioning utility, because they'll clash with its use of non-standard methods.
The same will apply presumably to any other software which makes assumptions about the standard nature of the partitions.
You should be using BING to set up all that stuff on your system, not EasyBCD.
For example, you have a HDD claiming to have 4 primaries, 2 invisible and an extended partition containing 2 logical disks. This is not a situation which exists in the standard architecture, only in the propriatory world of BING.
If you set up a non-standard paradigm, you have to manipulate it with the tools designed for it specifically.
It makes no difference, Terry. :smile: Just because I have BING doesn't mean its not possible to get the two to work together correctly...and this I have managed to do successfully, so that everything is working as it should. :wink: I can boot into XP from the Vista bootloader (from the boot entry created by EasyBCD), and I can also boot into Ubuntu from the Vista bootloader using the (manual) Bootpart method, and also using the NeoGrub (also in EasyBCD) method...the only one that fails is the one that goes away from the standard method of using Bootpart (the method that EasyBCD uses, with Bootpart). :brows: So what does this tell us? It tells us that everything works (in EasyBCD), even with BING, except for the non-standard method with EasyBCD that uses Bootpart, which is a problem not related to BING. :smile:

Believe me when I tell you this, Terry...BING isn't the problem. If the method in EasyBCD was going to work in my case, it would still not work, even if I was not using BING, and had a normal setup !

-Coolname007

EDIT: And BTW, EasyBCD isn't another partitioning utility...
 
Last edited:
#74
Hi Coolname--

bootpart
C:\bootpart 4 C:\ubuntu.lnx Ubuntu Linux
so, if I do this, how do I undo it or change it after issuing the command? let's say I want to enter a different partition, drive etc?

Where the "C"s and the "4" is replaced with the correct drive letter and partition number as shown by Bootpart.
Since Ubuntu is installed entirely on my second SATA drive (and there are no other windows-realated filesystems on the drive), Windows does not recognize the second drive at all, so I am not sure what to replace the "C's" with? Your thoughts?

Thanks, andy-min
 
#75
Can I jump in here please

I'm having the EXACT same problem. I've been reading this thread for about an hour and you have been describing exactly what happens to me. The difference is I already have a working Vista/Xp Dual boot using EasyBCD 1.7. I can get to a grub menu using NeoGrub but I can never boot Ubuntu 8.10. I have two hard drives:

500GB -vista partition/xp partition/ storage
36gb sata ubuntu partition/swap partition (had a raptor layin around)

I can still boot into vista and xp no prob but when i select ubuntu i get error codes (mostly 17 and 22)or the grub menu where i edit the "root (hdx,y)" line over and over and get nowhere. I was gonna try edit the Grub file in Ubuntu, boot off the cd, but andi didn't have much luck with that. I'll give you guys all the info i can maybe it'll help, figure out what the problem is, meanwhile back to virtual box

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {5a3e6b90-520f-11dd-8a6c-89f19b2c4eac}
resumeobject {5a3e6b91-520f-11dd-8a6c-89f19b2c4eac}
displayorder {5a3e6b90-520f-11dd-8a6c-89f19b2c4eac}
{39f40967-5221-11dd-846b-001e8c6ae126}
{39f4096f-5221-11dd-846b-001e8c6ae126}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 20

Windows Boot Loader
-------------------
identifier {5a3e6b90-520f-11dd-8a6c-89f19b2c4eac}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
bootdebug Yes
osdevice partition=C:
systemroot \Windows
resumeobject {5a3e6b91-520f-11dd-8a6c-89f19b2c4eac}
nx OptIn
pae ForceDisable
sos No
debug No

Real-mode Boot Sector
---------------------
identifier {39f40967-5221-11dd-846b-001e8c6ae126}
device partition=C:
path \NTLDR
description Windows XP

Real-mode Boot Sector
---------------------
identifier {39f4096f-5221-11dd-846b-001e8c6ae126}
device partition=C:
path \NST\NeoGrub.mbr
description ubuntu


I tried different variations but had luck(gets me to the grub menu when i select ubuntu) with setting NeoGrub like this:

root (hd1,0)
kernel /boot/vmlinuz-2.6.27-7-generic root=/dev/sdb ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic

I'll attach screen shots, hope this helps..
 

Attachments

#76
Hi Coolname--


so, if I do this, how do I undo it or change it after issuing the command? let's say I want to enter a different partition, drive etc?
Undo what? :S There's not much to undo (and why would you want to?)...
Running those commands will simply add a line to your boot.ini file, create a file called "ubuntu.lnx" in the root of C:, and tell Bootpart how to find the information it needs to boot Ubuntu. :wink: And as for the "different partition, drive etc" thing...well, you would need to use whatever partition number Bootpart shows as your "Linux native" partition, after typing "bootpart" without the quotes from EasyBCD's Power Console.

Since Ubuntu is installed entirely on my second SATA drive (and there are no other windows-realated filesystems on the drive), Windows does not recognize the second drive at all, so I am not sure what to replace the "C's" with? Your thoughts?

Thanks, andy-min
It is C (or whatever drive letter the Power Console opens up in) because you're giving Bootpart the instructions from Vista, which uses drive letters. Please just try it, so we can see if it works, while EasyBCD apparently failed. :smile:

Cheers.

-Coolname007

EDIT: Wait...hold on! So you say you can't even access your second drive from Windows? why is that...and could you please give more details? thanks! And one thing I may have neglected to explain before concerning Bootpart is...you don't need to manually enter in the disk number. Just the partition number, as it continues counting the partitions from disk to disk, without going back to 0 or 1, as is normally the case. You'll see right away what I mean after typing in "bootpart" in the Power Console, and taking a look at your disk and partition setup as seen by Bootpart.

Addendum:

I'm having the EXACT same problem. I've been reading this thread for about an hour and you have been describing exactly what happens to me. The difference is I already have a working Vista/Xp Dual boot using EasyBCD 1.7. I can get to a grub menu using NeoGrub but I can never boot Ubuntu 8.10. I have two hard drives:
Hi, UbuntuNoob. Welcome to NST.
Have you tried the automatic method of using NeoGrub? Its easier.
Please try deleting the NeoGrub in existence (under the NeoGrub tab in EasyBCD), and create a new entry for Ubuntu under the Linux tab, making sure to point it to the correct partition that Ubuntu's installed to (preferably going by the size, and "Linux native", instead of by the disk and partition numbers...), and selecting Grub in the "Type" menu...and making sure to check the box titled "Grub isn't installed to the bootsector". This will install the automatic version of NeoGrub, which will hopefully work, while the other failed. :wink:

Cheers, and if you have any more problems, don't forget to post! :smile:

-Coolname007
 
Last edited:
#77
From the Bootpart read me:

Example :
You create and move to a directory for the boot file, and display the
list of partitions :
C:\>MD BOOTFILE
C:\>CD BOOTFILE
C:\BOOTFILE>BOOTPART
Boot Partition 2.60 for WinNT/2K/XP (c)1995-2002 G. Vollant (info@winimage.com)
WEB : Gilles Vollant software and BootPart
Add partition in the Windows NT/2000/XP Multi-boot loader
Run "bootpart /?" for more information

0 : C:* type=6 (BIGDOS Fat16), size = 1044193 KB
1 : C: type=a (OS/2 Boot Manag.), size = 8032 KB
2 : C: type=5 (Extended), size = 8032 KB
3 : C: type=7 (HPFS/NTFS), size = 8001 KB
4 : D: type=6 (BIGDOS Fat16), size = 261104 KB
5 : D: type=5 (Extended), size = 769024 KB
6 : D: type=7 (HPFS/NTFS), size = 102384 KB
7 : D: type=5 (Extended), size = 369664 KB
8 : D: type=7 (HPFS/NTFS), size = 369648 KB
9 : D: type=83 (Linux native), size = 296944 KB

Note : Extended partitions (type 5) are the only partitions that can contain
other partitions. It's not useful to add extended partitions to the NT boot
menu !
The * after C: means that partition 0: is the active partition.

Now, you add some partitions :
C:\BOOTFILE>BOOTPART 9 BOOTLINX.BIN Linux
C:\BOOTFILE>BOOTPART 1 BOOTLINX.BIN Boot Manager OS/2
C:\BOOTFILE>BOOTPART a: BOOTLINX.BIN Boot floppy A:

The last line (A:smile: is special, and is designed for a BIOS configured for
booting from C: before reading from the floppy (A:smile: .

The next time you boot, the Windows NT menu will show Linux, OS/2 Boot
Manager, and the floppy !

BOOTPART is a Win32 console application written in C++ and compiled with Visual C++ 2.2
bootpa32.mak is the Visual C++ Makefile, bootpart.cpp is the source file,
bootpart.exe is the executable, and bootpart.txt is this documentation.

Mike
 
#78
Thanks for the quick response, I've tried just about every way possible to configure Easybcd to find my Ubuntu install. I've tried to manually configure NeoGrub, and the automatic procedure, and neither has been successful at getting it to boot. I followed the installation procedures here http://neosmart.net/wiki/display/EBCD/Ubuntu twice, after reading this thread and seeing all the problems andy-min had, I stopped and hoped a resolution could be found here. If not I'm thinking I'm just gonna start from scratch and let Grub install in the MBR. I thought maybe the info from my install would help. btw, I use Alcohol52% in vista and xp to mount ISO's could that be causing a problem? haven't tried turning it off yet. Other than that it's not really worth the hassle you guys are going through I can run Ubunutu in a virtual box if I really want to use it, I was mostly installing it because i had the extra drive and wanted to check hardware compatibility and performance vs vista, and to have a triple boot :smile:

oh and I've tried it with "Grub isn't installed to the bootsector" checked and unchecked with no luck
 
Last edited:
#79
Hi Andy-min.
If you did not get you dual boot to work, here is what helped me.
My troubles with this problem can be found here on the easybcd forum under a triple boot heading.
My thanks goes to PC-eye and others here for their help.
I too have a Dell with 2 SATA hds.
HD 1 has Vista and XPPRO installed.
HD 2 is for Ubuntu.
Here is what I can remember that worked for me:
Unplug the data cable from HD1.
Get the tutorial here called "Dual-Booting Ubuntu Linux and Windows Vista".
The windows that are hard to read can be expanded.
Follow the tutorial to the letter in installing Ubuntu.
Plug in HD1.
Run Easybcd from HD1.
This should give you access to both OS systems.
I hope something that I have said will help somebody. It certainly worked for me.
Phenix
 

mqudsi

Mostly Harmless
Staff member
#80