IntelliPoint & Intellitype on Vista

There’s a new version of IntelliPoint & IntelliType out that addresses this issue!

To get IntelliPoint running on Vista:

  1. Grab the latest version of the Microsoft IntelliPoint software.
  2. Run setup, it will extract the files and folders to C:\Program Files\Microsoft IntelliPoint 5.x\
  3. After it extracts, exit setup.
  4. Open Windows Explorer, go to C:\Program Files\Microsoft IntelliPoint 5.x\IPoint\SETUP, and find “oemsetup.exe”
  5. Download intellipoint.ini from our servers.
  6. Drag and drop intellipoint.ini over oemsetup.exe; wait ten minutes, then go to CP -> Mouse and have a little look see.. It should be installed :)
  7. Enjoy!
  8. If after these steps some functionality is missing, see this forum topic on hard-coding the device ID.

To get IntelliType running on Vista:

  1. Grab the latest version of the Microsoft IntelliType software.
  2. Run setup, it will extract the files and folders to C:\Program Files\Microsoft IntelliType 5.x\
  3. After it extracts, exit setup.
  4. Open Windows Explorer, go to C:\Program Files\Microsoft IntelliType 5.x\IType\SETUP, and find “oemsetup.exe”
  5. Download intellitype.ini from our servers.
  6. Drag and drop IntelliType.ini over oemsetup.exe; wait ten minutes, then go to CP -> Mouse and have a little look see.. It should be installed :)
  7. Enjoy!

40 thoughts on “IntelliPoint & Intellitype on Vista

  1. I am with Kenan, can you post the ini file so we can get our Microsoft hardware to work with the Microsoft OS?

  2. Ouch… >.< Sorry about that guys... Really am. I'm in Linux ATM, as soon as I boot back into Vista I'll recreate the files you need. We lost them when we upgraded to our new site design. Apologies, CG PS: Use the "Subscribe to Comments" feature if you want email notification when it's ready!

  3. Any chance you have this file yet? I am still annoyed with the lack of my middle double click button that I can only seem to get with this software. Thanks!

  4. Hey Keith…
    What’s more important: the intellitype file or the intellipoint one?

    I have to DL a 50MB file we published a long time ago to get either, and our ISP capped us at Dial-Up speeds for downloading too much on an entry-level business line (we’re cash-strapped..); so let me know which is more important to you guys.

  5. lmao… I was just coming to tell you that we had uploaded the intellitype file too.
    Good call Hao, unfortunately if we did that you can bet on having people not knowing how to save it or something.. This way is easier for us in the end :)

    No matter, we have both files back up, and on behalf of NST, I’m really sorry.

  6. Some personal experience for whoever stumble across this page and going to try install intellipoint. I have wireless intelli explore 2.0, after intalling intellipoint, the scrolling stopped working. Before it was behaving funky, but works somewhat. I was reading on Vista newsgroup, seems others have experienced similar problem. You do get to configure those extra buttons though, so there’s a trade off there. I guess we just have to wait till Microsoft release beta drivers.

  7. Thank you so much — I’ve been really annoyed that Microsoft wouldn’t make their own mouse work on their own new operating system!

  8. For anyone using Microsoft Keyboard Elite for Bluetooth. The latest Vista build 5536 will only allow your keyboard to be added to the Bluetooth devices using a passkey. We all know that a passkey is important for security reasons, but Microsoft in their wisdom never dreant of dual boot scenarios, therefore you can’t have a passkey in both XP and Vista.
    You either have to go through the chore of uninstalling/reinstalling it, or use an old wired KB that you may have lying around.
    The mouse still (fortunately) has the option to work without a passkey so can be used in both boots.

  9. This worked perfectly for my mouse – but not with my keyboard – gonna give it another try here so see if it was a fluke.

  10. [quote comment=”3986″]For anyone using Microsoft Keyboard Elite for Bluetooth. The latest Vista build 5536 will only allow your keyboard to be added to the Bluetooth devices using a passkey.

    We all know that a passkey is important for security reasons, but Microsoft in their wisdom never dreant of dual boot scenarios, therefore you can’t have a passkey in both XP and Vista.
    You either have to go through the chore of uninstalling/reinstalling it, or use an old wired KB that you may have lying around.
    The mouse still (fortunately) has the option to work without a passkey so can be used in both boots.[/quote]

    Update: Same problem in RC-1. You can get around this behaviour by adding the device but once it is detected do not click “next”. Instead right-click the device in the “Add Bluetooth Devices” display and click “Properties” go to the Services tab and a box should show for the drivers. Check it then click Apply and OK. Exit the Add Bluetooth Devices Wizard without finalising.
    Exit Bluetooth Devices. Redisplay Bluetooth Devices…the keyboard should then show connected without passkey. This would apply to any device that doesn’t support more than one passkey.

  11. [quote comment=”4870″]It does NOT work
    (Vista RC1, Tried Intellitype 5.0, 5.2, 5.5)[/quote]
    Intellitype procedure worked for me with RC1, despite a half dozen incompatibility warnings from Vista, LOL. I am now able to prgram my Digital Media Pro Keyboard through the control panel.

  12. PS Someone should edit the IntelliType procedure above. It refers to “Point” instead of “Type” at least three times! Thanks though.

  13. Awesome patch guy. Got it installed and working, only I’m having problems with the volume bar with the intellitype. I have just a basic MultiMedia Keyboard (wired, nothing fancy) and when I use the volume up/down the bar displays on screen but it’s always a solid green even though the volume is going up and down with the keyboard keys. Quite annoying actually lol, do you think it’s related to the way Vista handles audio and if there’ll ever be a fix?

    Thanks again for the awesome patches.

  14. You’re very welcome! Glad we could help..
    Unfortunately we can’t distribute a fix for that without doing something illegal (distributing reverse-engineered files), so we’ll just have to wait for MS to finally release the new IntelliPoint/IntelliType packages…

    Cheers!

  15. Fair enough, keep up the good work! The fix will be microsoft’s christmas present when they release the Vista versions then :-)

  16. Well, let us hope that they make everything backwards compatible as they’ve just announced new keyboards and mice specifically designed for Vista. Hopefully they wont forget those of us with earlier models.

  17. [quote comment=”6040″]Fair enough, keep up the good work! The fix will be microsoft’s christmas present when they release the Vista versions then :-)[/quote]

    I heard it was Easter actually… see OSNews’ homepage!!!!

  18. Thank you very much for taking the time to fix what microsoft didn’t have time to do in the rush development of longhorn. I guess it is hard to make a new operating system compatible with every single insignificant un-heard-of software manufacturer. Thanks again, I am very impressed!

  19. This information is priceless and has worked great for me in RC1 and now RC2, I’d like to formally thank you for having it up, since being able to map my middle mouse button is something I’ve grown so used to.

  20. In order for this to work on vista x64, I used the xp64 drivers, and it worked flawlessly. I initially tried the standard drivers, since I have heard that xp64 drivers don’t always work in vista…but couldn’t get it to work. Much thanks for the instructions, and after using the xp64 drivers, just what I needed.

  21. It works beautifully! Hail to you for restoring my double-clicking wheel!!! My hat’s off to you! Thanks and keep up the excellent work!

    ~ Josh

    Vista RC1, Build 5600, IntelliPoint 5.5

  22. Hello!

    It doesn’t work on Windows Vista RC2 (Build 5744) but it works on Windows Vista RC1 (Build 5600). Is there some way I can make it work on Windows Vista RC2?

    Please help,

    Panarchy

  23. It works perfectly! :D thanks :)

     Panarchy, i use build 5744 to, and it works! maybe you’ll have to try again ;-)

    thanks!

     

    Ruben

Leave a Reply

Your email address will not be published. Required fields are marked *